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PC-Duo overview

Thank you for selecting PC-Duo remote desktop solutions.

PC-Duo remote desktop solutions provide professional features that enable helpdesk
technicians, network administrators, IT managers, and software trainers to deliver
professional remote support for a fraction of the cost of hosted solutions.

Some selected features include:

€ Remote Access: Reach anyone, anywhere, anytime using firewall- and NAT-friendly
remote control connections.

€ Remote Control: Diagnose and resolve support issues without having to physically
visit remote computer.

€ Remote Management: Repair remote computers and make configuration changes in
real-time and without disturbing currently logged-on user.

4 Collaboration: Enable two or more technicians to work on the same remote computer
at the same time using chat, screen-sharing and easy-to-pass remote support.

NOTE: Before you use PC-Duo remote desktop solutions, you should be familiar with
basic network concepts, such as protocols, encryption, IP addresses, ports, and subnets.

To learn more about PC-Duo remote desktop solutions, see:
"What's New"

"PC-Duo solutions"

"PC-Duo applications"

"PC-Duo technologies”

"PC-Duo services"

"PC-Duo connection types"

"PC-Duo security features”

"PC-Duo networking features”

L JER ZER 2B 2R N JEE JER 2N 4

"PC-Duo documentation and technical support"”
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What’s New in PC-Duo 12.0

PC-Duo 12.0 introduces the following new features and capabilities:

& Web Console: A new server-side application that enables browser-based access to
the Gateway Server (see PC-Duo Web Console Operating Guide)

4 “Click Once” Remote Desktop Window: Ability to launch a Remote Desktop
Window to a remote desktop through the Web Console without a Master. No
administrative rights needed and no reboot required (see PC-Duo Web Console
Operating Guide)

& Citrix XenApp support: Option to restrict injection of Terminal Services Host
instances into “desktop” sessions only, and not into “application” sessions (see PC-Duo
Host Guide)

& Kernel-mode Screen Capture driver: The kernel-mode screen capture driver is now
available for Windows 7, Vista and Windows 2008 Server. In many situations, the kernel-
mode screen capture driver will outperform the default user-mode screen capture driver
(see PC-Duo Host Guide)

@ Input Suppression: Ability to turn off keyboard and mouse input on the remote
desktop machine for Windows 7, Vista and Windows 2008 Server (see Menu Options)

€ Assignment of Hosts: Ability to automate the assignment of Hosts to custom
Gateway Groups using Windows Powershell scripting (see PC-Duo Host Guide)

€ Address Bindings: Ability to bind the SSL and TCP network protocols to all
addresses or to select specific addresses on the Gateway Server see PC-Duo Gateway
Server Guide)

What’s New in PC-Duo 11.6

€ Windows 7 support: PC-Duo 11.6 provides full support (remote access, remote
control, remote management) for Windows 7 computers, including 32- and 64-bit
platforms.

€ Windows Server 2008 R2 support: PC-Duo 11.6 provides full support (remote
access, remote control, remote management) for Windows Server 2008 R2 computers
(64-bit platforms only).

€ Mac, Linux support: PC-Duo 11.6 provides support (remote access, remote control)
for Macintosh and Linux computers running VNC server software (standard on Macs).

€ Wake-on-LAN support: PC-Duo 11.6 includes ability to turn on remote computers
that are configured to listen for Wake-on-LAN signal.

€ Remote Power Scheme management: PC-Duo 11.6 includes new remote
management tools that allows Master user to view and change power scheme settings on
remote computers.

€ Screen Recording Playback via URL: PC-Duo 11.6 includes ability for Master to
playback a PC-Duo screen recording from a standard web server over HTTP or HTTPS.

& RDP compatibility: If a remote computer is hosting an active RDP session, PC-Duo
11.6 Host will capture and provide input control to the RDP session.
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€ Active Directory integration: PC-Duo 11.6 Deployment Tool can now be used to
discover computers and OUs in Active Directory domains, install new PC-Duo software,
upgrade existing software, and/or push configuration changes to existing software.

What’s New with PC-Duo 11.3

€ Remote Management service: PC-Duo 11.3 features a new service that allows
Master user to generate inventory of hardware and software assets on a remote Host.
Also allows Master user to query and change certain system settings.

€ Terminal Services support: PC-Duo 11.3 supports server-side Hosts for thin client,
terminal services sessions for Citrix XenApp (formerly Citrix Presentation Server) and
Windows Terminal Server.

€ User-Mode Screen Capture optimization: PC-Duo 11.3 includes significant
performance and reliability enhancements for user-mode screen capture technology
introduced in PC-Duo 11.2.

What's New with PC-Duo 11.2

PC-Duo 11.2 introduced the following new features and capabilities:

€ Windows Vista and Server 2008 support: PC-Duo 11.2 applications (Host, Master,
Gateway, Deployment Tool) now run on Windows Vista and Windows Server 2008
operating systems.

NOTE: PC-Duo 11.2 introduces a new screen capture technology (user-mode) for
Windows Vista and Windows Server 2008 platforms.

€ Bandwidth throttling: PC-Duo 11.2 allows screen capture settings to be modified in
order to reduce the amount of bandwidth used. Usually, this will reduce screen capture
quality but improve responsiveness and overall performance (see PC-Duo Host Guide for
more information).

€ Popup notifications: PC-Duo 11.2 supports popup "toast" notifications when
connections are established to remote computers (see PC-Duo Host Guide for more
information).

€ Send keystroke button: PC-Duo 11.2 now provides a new toolbar button on the
Master Remote Desktop Window, which can be configured to send Ctrl+Alt+Del or one of
the other available keyboard combinations to remote computer (see PC-Duo Master
Guide for more information).

€ Host-based chat: PC-Duo 11.2 introduces support for Host-based chat. This new
service automatically creates a private chat room including Host user and any technicians
connected to the Host. Technicians can see and participate in multiple chat rooms
simultaneously (see PC-Duo Master Guide for more information).

& File transfer resume: Occasionally, a file transfer operation is interrupted when a
connection is lost. PC-Duo 11.2 introduces the ability to resume interrupted file transfers
exactly from the point of interruption (see PC-Duo Master Guide for more information).

€ Windows Media format support: PC-Duo screen recording files are produced in a
streamlined, proprietary format and play back in a viewer provided with PC-Duo Master.
PC-Duo 11.2 introduces a new utility to enable technicians to convert PC-Duo screen
recording files into Windows Media format for play back in WM-compatible players and
editing in off-the-shelf media tools (see PC-Duo Master Guide for more information).
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PC-Duo solutions

Vector Networks provides two solutions for remote desktop support:

PC-Duo Express

PC-Duo Express is an easy-to-use remote desktop solution that uses simple peer-to-peer
connections between helpdesk technicians and end-user remote computers. It is ideally
suited for smaller companies and workgroups in which the number of remote computers
being supported is small and manageable.

PC-Duo Enterprise

PC-Duo Enterprise is an enterprise-class remote desktop solution that uses a robust,
scalable server to establish and maintain a secure network of connections to end-user
machines. It leverages centralized administration, security and network access to simplify
and automate the creation, management, and monitoring of this “network within a
network”. PC-Duo Enterprise is ideally suited for enterprises and corporate workgroups
with large numbers of remote computers, multiple domains and/or employees with
remote computers outside the network.

PC-Duo Features PC-Duo Express Eﬁt-(?rl;(r)ise
Components

PC-Duo Host Yes Yes
PC-Duo Master Yes Yes
PC-Duo Gateway No Yes
PC-Duo Web Console No Yes
PC-Duo Deployment Tool Yes Yes
Connection Types

Peer-to-peer connections Yes Yes
Gateway-managed connections No Yes
Firewall-friendly connections No Yes
Terminal services connections No Yes
VNC connections Yes No
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PC-Duo applications

The PC-Duo remote desktop solutions include some or all of the following applications:

PC-Duo Applications E)?r_)?:sos Egt-eDrl;)cr)ise
PC-Duo Host Yes Yes
PC-Duo Master Yes Yes
PC-Duo Gateway No Yes
PC-Duo Web Console No Yes
PC-Duo Deployment Tool Yes Yes

10
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PC-Duo Host

PC-Duo Host is an agent application that enables remote support connections to be
established to the machine on which it runs. By installing PC-Duo Host on a computer in
your network, you can:

4 Allow technicians to make peer-to-peer remote control connections to the machine,
whether someone is there or not. Each Host manages its own security settings and
access rights.

& Allow or force technicians to make Gateway-managed remote support connections to
the machine through a central server (PC-Duo Gateway), which will automatically enforce
security settings and access rights according to policies set at the server.

PC-Duo Host can now be installed in server-side terminal sessions for application
virtualization solutions such as Citrix XenApp and Microsoft Terminal Server.

For more information about configuring and operating PC-Duo Host, please see the PC-
Duo Host Guide.

11
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PC-Duo Master

PC-Duo Master is a console application that technicians can use to establish remote
support connections to one or more Host computers. With PC-Duo Master, you can:

€ Make one or more peer-to-peer remote support connections to Host computers in your
network.

4 Connect to PC-Duo Gateway and make one or more Gateway-managed remote
support connections to Host computers from a directory of available Hosts.

& View the entire screen of the remote computer.

€ Take complete control of a Host computer using the local keyboard and mouse.
€ Share control of the Host computer with its end-user.

& Passively monitor the Host computer without exercising control.

€ Use the clipboard transfer feature to transfer portions of text, bitmaps, and other
objects between your Host and Master computers.

€ Use the PC-Duo file transfer feature to copy files between your Host and Master
computers.

€ Use the PC-Duo remote printing feature to print locally from applications running on a
remote computer.

€ Record screen activity on the Host and play back the recording on the Master.
4 Chat with end-user and any other technicians connected to the same Host.

For more information about configuring and operating PC-Duo Master, please see the
PC-Duo Master Guide.

12
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PC-Duo Gateway

PC-Duo Gateway is an enterprise class server, which provides centralized administration,
security and management for a network of remote support connections to Host
computers in your environment.

With PC-Duo Gateway configured as the hub of your remote support network, you can:

4 Organize large numbers of Host computers into logical groups for easier access and
management.

€ Reach remote computers outside the network, behind firewalls or NAT-devices.
& Utilize SSL for certificate-based authentication.

€ Create custom access rights policies and apply them to groups to make configuration
changes more quickly and efficiently.

€ Monitor and manage remote support activity in real-time.

& Keep detailed records of all remote support activity in your network with
comprehensive audit logs.

€ Record screen activity on one or more remote computers simultaneously using PC-
Duo Gateway’s screen recording feature.

PC-Duo Gateway includes the PC-Duo Gateway Administrator, a tool for configuring the
Gateway and for monitoring, managing and auditing remote support activity in your
network.

For more information about configuring and operating PC-Duo Gateway, please see the
PC-Duo Gateway Server Guide.

13
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PC-Duo Web Console

PC-Duo Web Console is a web application that provides browser-based access to the
PC-Duo Gateway Server.

With PC-Duo Web Console:

€ Administrators can access and edit all the configuration information on the Gateway
Server, including Groups, Security, Permissions, etc. The Administrative web account
can be used in conjunction with or instead of the standalone Gateway Administrator
application.

€ Helpdesk technicians can view and access and remote machines that they have
permission to view. The Master web account can be used in conjunction with or instead
of the standalone Master application.

€ Regular employees can view and access their computers at work, even if they are on
the road or at home. The Personal web account offers convenient, secure, reliable
alternative to VPN.

For more information about configuring and operating PC-Duo Web Console, please see
the PC-Duo Web Console Operating Guide.

For more information about installing PC-Duo Web Console, please see the PC-Duo Web
Console Installation Guide.

14
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PC-Duo Deployment Tool

PC-Duo Deployment Tool is an easy-to-use software distribution utility that automates the
deployment and installation of PC-Duo applications to remote computers in your network.

With PC-Duo Deployment Tool, you can:

€ Automatically deploy an image of PC-Duo Host, Master or Gateway to one or more
computers or groups of computers in your network and avoid manual effort of going to
each machine.

& Create an image of PC-Duo Host, Master or Gateway with custom configuration
options that can be mass deployed on large numbers of computers in your environment.

€ Create and push custom configuration options for PC-Duo Host, Master or Gateway,
without having to reinstall underlying software.

€ Use Active Directory to find remote computers and push software and configuration
settings to them.

For more information about configuring and operating PC-Duo Deployment Tool, please
see the PC-Duo Deployment Tool Guide.
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PC-Duo technologies

PC-Duo remote desktop solutions utilize highly optimized technologies to deliver speed,
performance and reliability, including:

& Highly efficient screen capture algorithms. PC-Duo utilizes two kinds of screen
capture technology:

+ Kernel-mode screen capture for Windows XP, Windows Server 2003 and older
platforms. This technology utilizes the PC-Duo mirror driver, which reproduces
graphics drawing commands from the remote Host on the PC-Duo Master user’s
screen quickly and efficiently.

+ User-mode screen capture for Windows Vista and Windows Server 2008
remote computers. This technology works without a mirror driver and is designed to
adjust automatically to the amount of CPU and bandwidth available on the remote
Host machine.

& Streamlined communication protocol. The PC-Duo protocol has been honed over
15 years for efficiency and reliability when sending screen capture data to another
computer in real-time and receiving keyboard/mouse input.

Using these technologies, PC-Duo remote support solutions enable technicians to find
and fix problems on remote computers faster and easier than ever before.
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PC-Duo services

PC-Duo remote desktop solutions offer technicians a number of professional-quality
services for investigating and solving problems on Host remote computers, including:

€ Remote Control: ability to view screen activity on an end-user’s remote machine, and
with proper authorization, take control of and send keyboard/mouse inputs to the remote
machine in real-time

€ Remote Clipboard: ability to copy selected items on the screen of a remote machine
into the clipboard on the remote machine and transfer the contents to the clipboard on
the technician’s machine, and vice versa

& File Transfer: ability to drag-and-drop files or directories on the remote machine to
the technician’s machine, and vice versa

€ Host-based Chat: ability to chat with the end-user on a remote machine, and any
other technicians connected to that machine

€ Remote Printing: ability to print selected items from the remote machine to a printer
attached to the technician’s machine

€ Host Administration: ability to view and edit configuration settings of the PC-Duo
Host installed on the remote machine

€ Remote Management: ability to generate inventory of hardware and software assets
on remote machine, and to query and change certain system settings. See "Remote
Management features" for more information about tools available through this service.

Remote Management features

PC-Duo provides tools to enable technicians to generate inventory of hardware and
software assets on a remote computer, and to view/modify configuration settings.

Remote management tools include:

€ Hardware Manager: provides a graphical view of physical devices and resources
available on the remote Host computer.

€ Software Manager: provides a graphical view of the software applications that are
installed on the remote Host computer

€ System Manager: provides a graphical view of various configuration settings on the
remote Host computer.

& Shared Resource Manager: provides a graphical view of currently available shared
resources (Shares) and any current network users with connections (Sessions) to the
remote Host computer to access the shared resources.

€ Account Manager: provides a graphical view of currently available user, group and
system accounts on the remote Host computer.

€ Service Manager: provides a graphical view of and ability to start/stop/restart
currently available services and system drivers on the remote Host computer.

€ Process Manager: provides a graphical view of and ability to stop currently running
processes on the remote Host computer.

€ Registry Manager: provides a graphical view of and ability to create/modify/delete
Registry keys on the remote Host computer.
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€ Event Manager: provides a graphical view of the Application, Security and System
logs kept on the remote Host computer.

& Power Manager: provides a graphical view of the power management and power
scheme management options for the remote Host computer, as well as ability to restart,
reboot or shutdown the remote computer.

For more information, see PC-Duo Master Guide.
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PC-Duo connection types

PC-Duo services are performed over service connections between a PC-Duo Master
(with appropriate access rights) and a PC-Duo Host. Service connections are established
on demand, when a PC-Duo Master requests a service from a PC-Duo Host.

PC-Duo supports several different types of remote access connections:

PC-Duo Connection Types PC-Duo Express Erc\:tgl;)(r)ise
Peer-to-peer connections Yes Yes
Gateway-managed connections No Yes
Firewall-friendly connections No Yes
Terminal services connections No Yes

VNC connections Yes No

RDP compatibility: Follow the active session
PC-Duo connections can be used to share an active RDP session in real-time.

If PC-Duo Host is running on a desktop-class operating system (e.g. Windows XP or
Vista), and there is an active/connected RDP session being hosted on that computer,
then the Host will automatically capture and provide input control to that RDP session. In
essence, the Host will capture what the remote RDP session user is seeing, not what the
local physical console on that machine is showing (probably the Windows login screen).

When there is no active/connected RDP session being hosted on that computer, or if an
active/connected RDP session is stopped, the Host will automatically capture and provide
input control to the session running on the computer and being displayed on the local
console. The Host will follow the active session as it moves from RDP user back to the
local console.

Note: This feature only applies to desktop-class operating systems, which support only
one active session at a time. Server-class operating systems (e.g. Windows Server 2003
or Server 2008) can support multiple sessions simultaneously via Terminal Services; use
the Terminal Services support in the Host to capture and/or provide input control to one
or more sessions on server-class OS.

Wake-on-LAN support

PC-Duo can be used to "wake-up" remote computers that have been shut down
(sleeping, hibernating, or soft off; i.e., ACPI state G1 or G2), with power reserved for the
network card, but not disconnected from its power source. The network card listens for a
specific packet containing its MAC address, called the magic packet, that is broadcast on
the subnet or LAN.

In order to execute this feature, both the MAC address and the last known IP address of
the remote computer must be known. Since the PC-Duo Gateway knows both of these
pieces of information, it is in a position to send the Wake-on-LAN signal.
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PC-Duo implements this functionality in Gateway-managed connections in two ways:

€ Implicit Wake-on-LAN: If Gateway is asked to make a connection to a remote
computer and the last status indicates that the remote computer is "Offline", the Gateway
will automatically attempt to wake up the remote computer by sending appropriately
configured WOL signal. If the remote computer was shut down in a state capable of
receiving WOL signal, it will wake up and report to the Gateway and a connection will be
established.

& Explicit Wake-on-LAN: A network administrator, using either PC-Duo Master or PC-
Duo Gateway Administrator, can attempt to wake up a remote computer by explicitly
sending the WOL signal to that machine. If the remote computer was shut down in a state
capable of receiving WOL signal, it will wake up and report to the Gateway and a
connection will be established.

See "Send Wake-on-LAN Signal" for more information.

Peer-to-peer connections

When a computer with PC-Duo Master establishes a direct connection to a computer with
PC-Duo Host, the connection that is established is a peer-to-peer connection.

By default, PC-Duo Master searches the network for Host computers when it starts up.
Any Host computers it finds are listed on the Peer-to-Peer Hosts tab of the PC-Duo Master
window.

Peer-to-peer connections from Master (M) to Host (H)
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The dotted and solid lines, shown in above depict two different sets of peer-to-peer
connections between PC-Duo Masters to PC-Duo Hosts. PC-Duo’s peer-to-peer
connections enable the following:

€ PC-Duo Master users with proper credentials can securely access Host computers
within the network.

€ When you permit full access to a Host computer, the PC-Duo Master user can monitor
all activity on the Host computer. In addition, PC-Duo Master users with full access rights
can exercise complete control over that computer.

€ When the Host and Masters are in the same domain, PC-Duo Host can be configured
to use the Microsoft Windows authentication service to check credentials of any PC-Duo
Master users. An access control policy can allow (or deny) full or partial access for
authenticated PC-Duo Master users to access services on a Host computer.

Although PC-Duo’s peer-to-peer connections provide a secure solution for remote
support, this solution is not recommended for large and/or highly distributed networks;
instead, consider using PC-Duo Gateway for centrally managed remote support
connections.

Gateway-managed connections

When a computer with PC-Duo Master establishes a connection to a computer with PC-
Duo Host through a central server (i.e. PC-Duo Gateway), the connection that is
established is a Gateway-managed connection. In this way, the Gateway serves as a
central location for managing and monitoring connections, configuration, security and
reporting. Any Host computers found by the Gateway are listed on the Gateway Hosts tab
of the PC-Duo Master window.

In large networks, the PC-Duo Gateway can be configured to manage connections with
hundreds or thousands of Hosts simultaneously, enabling Masters to find and take
control of Hosts instantly.

Gateway-managed connections utilize the same strong authentication and authorization
that is available with PC-Duo’s peer-to-peer connections. In addition, PC-Duo Gateway
provides the following capabilities:

€ Seamless connections from Master computers to Host computers through a PC-Duo
Gateway. To the PC-Duo Master user, the connection appears as if it were a peer-to-
peer connection to the Host computer, even if the Host is outside the domain and/or
behind a firewall or NAT device.

& Centralized management of access rights to remote computers in your network. Once
you configure your Host computers to report to the PC-Duo Gateway, you can achieve
global management through a single security policy that you configure using PC-Duo
Gateway Administrator.

€ User-based access policies. Customize and apply access policies to individual PC-
Duo Master users or groups in your network. Allow full remote access to one or more
Host computers for some PC-Duo Master users, while restricting access rights for others.

4 Comprehensive logging and auditing of all remote control activity within your network.
With this feature, you can keep records of all remote support connections.

4 Continuous screen recording. PC-Duo Gateway allows you to record screen activity
on any remote Host. Efficient file compression makes 24x7 recording economical and
manageable.
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Gateway (G)-managed connections from Master (M) to Host (H)

Firewall-friendly connections

When PC-Duo Master users need access to Hosts that are outside the domain, and/or
behind a firewall or NAT-device, hormal peer-to-peer or Gateway-managed connections
will not work. In these cases, it is difficult to find and maintain a secure remote support
connection because of dynamic port assignments and other network challenges.

For these situations, PC-Duo Gateway builds special firewall-friendly connections to
these Hosts. When Hosts are outside the domain, the Hosts are programmed to
automatically initiate contact with the Gateway. The Gateway will use this initial contact to
build a firewall-friendly connection to the Host. In this way, the remote Host outside the
domain will appear just like any Host inside the domain.

Terminal services connections

PC-Duo provides server-side support (screen capture, input control, screen recording) for
session-based virtual desktops hosted by Terminal Services on Windows Server 2003 or
Window Server 2008 (now called "Remote Desktop Services"). Windows Server creates
and hosts the Terminal Services (TS) sessions like virtual machines. A presentation
technology using a display protocol such as RDP from Microsoft or ICA from Citrix is
typically used to remote the session display, as well as the keyboard and mouse input, to
and from an end user device (such as a thin client computer like a Wyse terminal).

PC-Duo allows technicians to capture (and if desired, record) the session presentation
information at the Windows Server before it is remoted to the end user device over the
RDP or ICA display protocol. PC-Duo is able to do this by injecting a Host instance into
each server-side TS session, which in turn captures and sends presentation information
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directly to PC-Duo Gateway for recording and/or further transmission to a PC-Duo
Master.

Note: Because TS sessions are captured at the Windows Server (and not at the end user
device), PC-Duo Host effectively bypasses the technology used to remote the sessions to
the end users, and will therefore be compatible with Microsoft Terminal Services clients
as well as Citrix Presentation Server (now known as XenApp) clients.

Note: PC-Duo only supports TS sessions created on server-class Windows operating
systems such as Windows Server 2003 and Windows Server 2008.

See Terminal Services tab in PC-Duo Host Guide for more specific configuration and
setup information.

Root Host for TS sessions

The “Terminal Services” feature of Windows Server 2003 and Windows Server 2008
allows multiple virtual desktop sessions to be active simultaneously. PC-Duo provides
remote access and remote control to these sessions on the Windows Server by injecting
a separate instance of the Host service into every new TS session. A special version of
the Host called the "root" Host must be loaded on the TS server (a "root" Host is a
standard Host with a special TS license key - see About tab in the PC-Duo Host Guide
for more information); it will automatically spawn new Host instances every time a new
TS session is created.

Transient Hosts

Each TS instance of the Host will have its own unique workstationIlD and must be
configured to report to a Gateway. When it first reports to the Gateway Server, it will be
automatically managed and added to the “All Hosts” group. The TS Hosts are considered
transient, since they go away when the TS user logs out of his/her session. In order to
keep track of transient TS Hosts, the PC-Duo Gateway will create a new Group called
"Terminal Services on <Servername>", and automatically insert transient Hosts into this
Group. They are automatically deleted from the Gateway when the TS session ends. The
main purpose of this Group is to allow security to be assigned to the Hosts and TS
sessions that belong to this Group, and to provide the correct and appropriate access to
the TS-based Host instances.

Note: PC-Duo Host for Terminal Services works on Server 2003 & Server 2008, and
requires a Gateway Server v11.3 or later.

Recording TS Hosts

Recordings are normally deleted from the Gateway database when their associated
workstation record is deleted. Transient TS Host workstation records are automatically
deleted from the Gateway when the TS user logs out of his/her session. However, to
prevent recordings of TS Hosts from being automatically deleted when the TS session
ends, the TS session recordings are reassigned to an artificial permanent workstation
record called "Recordings on <Servername>". All recordings of all TS Hosts on a given
TS server will be associated with this one record. This approach has the following
advantages:

4 Recordings are not orphaned
@ All recordings can be kept in one place,
€ TS recordings can be kept separate from console (root Host) recordings

€ Security can be configured separately for each recording.
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Limitations of TS Hosts

Due to technical limitations and the nature of Terminal Services sessions, the following
Host features are not supported.

€ Remote printing
& Keyboard and mouse suppression (requires kernel-based input stack intercept)
€ Screen blanking (requires kernel-based support and physical display to blank)

& Peer-to-peer connections: all protocols are disabled, and the only connections that
can be made are through a configured Gateway Server

€ Kernel-mode screen capture (even on Windows Server 2003, requires kernel-mode
display support)

VNC connections

PC-Duo provides remote access and remote control to computers running a standard
version of VNC (Virtual Network Computing) server. A VNC server is built into recent
versions of the Mac OS X operating system from Apple Computer, and is also available
on many versions of the Linux operating system. When properly configured, technicians
can use PC-Duo Master on Windows to connect to and take control of Mac and Linux
computers running standard VNC server.

PC-Duo currently supports peer-to-peer connections to VNC servers. Support for
Gateway-managed connections to VNC servers is expected in the next release.

See "VNC Hosts" for more information on configuring and connecting to VNC servers.

Supported Platforms

PC-Duo Master can interoperate with standard VNC servers on following platforms:
¢ Mac OS X v10.5-10.7

4 Red Hat Linux Fedora 11-16
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PC-Duo security features

One of the most valuable aspects of PC-Duo remote desktop solutions is the ability to
create and enforce fine-grained access control policies, and to easily modify them to
reflect changes in your organization.

PC-Duo security features include the following:
4 “Authentication”

4 “Authorization”

¢ “Auditing”

€ “Encryption”

Authentication

In the PC-Duo model, PC-Duo applications that request information and services are
considered “clients” and those that provide information and services are considered
“servers”. For example, the PC-Duo Master is considered a client when it connects to and
requests a list of Hosts from a PC-Duo Gateway. In turn, the PC-Duo Gateway is
considered a client when it connects to and requests information from a PC-Duo Host in
the same domain.

Connection Client Server
Peer-to-peer Master Host
Gateway-managed (Gateway & Host are in same domain)

€ Master-Gateway relationship Master Gateway
€ Gateway-Host relationship Gateway Host
Gateway-managed (Gateway & Host are not in same domain)

€ Master-Gateway relationship Master Gateway
€ Gateway-Host relationship Host Gateway

When PC-Duo Host is not in the same domain as the Gateway, the relationship is
automatically reversed: The Host is programmed to be the client and will reach out to the
Gateway (see “Firewall-friendly connections” for more information about PC-Duo firewall-
friendly connections).

To guarantee security in the PC-Duo environment, it is critical that PC-Duo components
acting as servers validate the credentials of users of PC-Duo components acting as
clients before they provide access or data. The burden is placed on the client to
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authenticate itself to the server. PC-Duo implements two types of authentication to

support this:
€ ‘“ldentity Authentication”
€ “Endpoint Authentication”

Identity Authentication

In general, this operation answers the following security question: How does the server
know who the client is? A PC-Duo application acting as a server will not provide access

or information to any PC-Duo application acting as a client until it can validate that client’s
identity. PC-Duo provides the server three different methods of authenticating the identity

of the PC-Duo client:

i . Shared-
. Windows Simple
Connection S secret
authentication password
password
Peer-to-peer Yes Yes No
Gateway-managed (Gateway & Host are in same domain)
4 ‘Master-Gateway Yes No No
relationship
& Gateway-Host relationship Yes No Yes
Gateway-managed (Gateway & Host are not in same domain)
L 4 Master-Gateway Yes No No
relationship
€ Gateway-Host relationship No No Yes

€ Windows authentication: By default, a PC-Duo application acting as a server uses
Windows authentication to check the Windows credentials of the client application:

+ The Host will check the Windows credentials of the PC-Duo Master user in

the case of a peer-to-peer connection;

+ The Gateway will check the Windows credentials of the PC-Duo Master users

in the Master-Gateway part of a Gateway-managed connection;

+ The Host will check the Windows credentials of the user logged into the
Gateway in the Gateway-Host part of a Gateway-managed connection (when

Host and Gateway are in the same domain).

NOTE: If Host and Gateway are not in the same domain, Windows authentication will not
usually be available. In that case, Host and Gateway will rely on Shared secret password.

€ Simple password: Prior to making a connection, a custom password can be created

on the Security tab of the Host and shared with PC-Duo Master user. This feature permits

26



PC-Duo overview

the PC-Duo Master user to connect to a Host without regard to PC-Duo Master user’s
Windows credentials.

NOTE: Simple password applies only to peer-to-peer connections.

& Shared secret password: In the case that the Host does not share a domain
relationship with the PC-Duo Gateway, or if the Host is outside of the network and cannot
contact its domain controller, Windows authentication will not usually be available. Behind
the scenes, the PC-Duo Gateway and the Host will exchange a 16-byte secret password
that only they will know. As a result, in all subsequent connections, the PC-Duo Gateway
and Host will have some measure of authentication when they are not in the same
domain. If the Host belongs to the same domain as the PC-Duo Gateway, and the Host is
able to reach a domain controller, the Host will prefer to do Windows authentication
instead of shared secret password.

Endpoint Authentication

In general, this operation answers the following security question: How does the client
know it is connected to the right server? ldentity authentication doesn't prohibit the client
from being fooled into connecting to a different server. In order to guarantee that
information and services are coming from the expected server, PC-Duo supports
endpoint authentication using Secure Sockets Layer (SSL).

€ SSL certificate authentication (PC-Duo Gateway only): PC-Duo has implemented
server endpoint authentication using SSL, which means the client will request and
validate a certificate from the server before providing requested information or services.
This ensures the client has connected to the right server. The following list describes
where SSL authentication can and cannot be used:

+ Peer-to-peer connections: SSL authentication is not available for peer-to-peer
connections. This would require each Host (acting as server) to carry its own
certificate, which would be unwieldy and costly to manage.

+ Gateway-managed connections (Host is in same domain as Gateway): SSL
authentication is available between Master (acting as client) and Gateway (acting
as server). Before connecting, the Master will request and validate a certificate
from the Gateway. In general, SSL between Master and Gateway would be most
useful when the Master is outside the LAN and/or coming in through a corporate
firewall to access the Gateway.

NOTE: SSL authentication is not available between the Gateway (acting as client) and the
Host (acting as server). As in peer-to-peer connections, this would require each Host to
carry its own certificate. SSL connections to the Host are generally not required because
the Host can be configured to use a reverse connection to the Gateway, which can use
SSL.

+ Gateway-managed connections (Host is not in same domain as Gateway):
When the Host is outside the LAN and/or behind a firewall or NAT-device, the Host
is the client and has responsibility to contact the Gateway. SSL authentication is
supported and would be appropriate to ensure that the Host is connecting to the
right Gateway. The Host will validate the Gateway Server certificate before
accepting the connection, ensuring that the Host is communicating with the correct
Gateway Server.

In summary, SSL can be used by the Master to authenticate a Gateway, and by a Host to
authenticate a Gateway when the Host is outside the domain:
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Connection Client Server gj{%ported
Peer-to-peer Master Host No
Gateway-managed (Master & Host are in same domain)

€ Master-Gateway relationship Master Gateway Yes

€ Gateway-Host relationship Gateway Host No
Gateway-managed (Master & Host are not in same domain)

@ Master-Gateway relationship Master Gateway Yes

€ Gateway-Host relationship Host Gateway Yes

Authorization

One of the strongest features of PC-Duo remote support solutions is the fine-grained
access control. For example, to perform remote support, you must have the following:

# Proper credentials with which to connect to the Host computer
€ Authorization to view the Host computer remotely
€ Authorization to control the Host computer remotely

Your credentials are established when you connect to a Host computer (or to a PC-Duo
Gateway), and persist until the connection breaks. You can configure access and other
rights directly on the Host computer for peer-to-peer connections. Alternatively, you can
use the PC-Duo Gateway to enforce custom access rights policies on PC-Duo Master
users, roles, or groups for Gateway-managed connections.

Auditing

PC-Duo Gateway provides a detailed log of connection attempts, actions and other
activities that occur in the network. This log is also customizable and exportable to 3rd
party reporting products using standard formats.

PC-Duo Gateway also features screen recording for any Host in contact with a Gateway,
whether or not there is an active remote support connection. With this feature, PC-Duo
Master users can keep a visual log of activities going on in the network.

Encryption

To ensure privacy of communications between PC-Duo applications across the network,
PC-Duo provides advanced encryption using Advanced Encryption Standard (AES) block
ciphers and Secure Hashing Algorithm (SHA-1). This protection will be automatic and
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transparent every time two PC-Duo 5.20 components or later are communicating with
each other.

By default, PC-Duo Express and PC-Duo Enterprise uses AES 256-hit encryption,
however other encryption options can be set, including:

& AES encryption (256-bit key) with SHA1 hash

& AES encryption (192-bit key) with SHA1 hash

& AES encryption (128-bit key) with SHA1 hash

& Triple-DES (3DES) encryption (192-bit key) with SHA1 hash
€ RC4-compatible encryption (128-bit key) with MD5 hash

NOTE: PC-Duo 5.10 applications and older support only RC4 encryption; thus, this would be the
encrpytion option negotiated between a PC-Duo 5.20 or later application (e.g. PC-Duo Master)
and PC-Duo 5.10 application (e.g. PC-Duo Host).

Order of precedence

When two PC-Duo components have different encryption options set, the first encryption
choice in common between the two is used (going down the list in order), with preference
set as follows:

& Preference set by the Host, when the Gateway requests connection to the Host

& Preference set by the Gateway, when the Master requests connection to a Host
through the Gateway
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PC-Duo networking features

PC-Duo remote desktop solutions support several standard transport protocols for
computer-to-computer communication, and two types of network addressing schemas.

Network protocols
PC-Duo products support most of the standard networking and transport protocols,
including:

& |P: IP is a general-purpose protocol supported on a wide variety of networks and
servers. PC-Duo components support communications using either the TCP or UDP
transport protocols running over IP. PC-Duo has established the following standard ports
for use with either TCP or UDP:

¢+ PC-Duo Host listens on port 1505 by default
+ PC-Duo Gateway listens on port 2303 by default

€ IPX: IPX provides access to Novell NetWare servers. PC-Duo components support
communications using this protocol.

€ SSL: The SSL protocol runs above TCP/IP and below higher-level protocols such as
HTTP or IMAP. Using TCP/IP on behalf of the higher-level protocols allows an SSL-
enabled server to authenticate itself to an SSL-enabled client, and then establish an
encrypted connection between the remote computers.

+ By default, PC-Duo Gateway listens for incoming SSL connections on port 443,
but it might be appropriate to note that this can be easily changed to avoid conflicts
with other server software installed on the same machine.

+ The PC-Duo Gateway now ships with a Gateway Certificate Manager to manage
the creation and/or selection of a SSL security certificate for the PC-Duo Gateway.

Network addressing schemas

The PC-Duo UDP, TCP and SSL transport protocols support the use of either IPv4 (32-
bit) or IPv6 (128-bit) addresses.
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PC-Duo documentation and technical support
Each of the four PC-Duo components has its own guide:

PC-Duo Master Guide

PC-Duo Host Guide

PC-Duo Gateway Server Guide

PC-Duo Web Console Operating Guide

PC-Duo Web Console Installation Guide

® 6 O 0 0 o

PC-Duo Deployment Tool Guide

For more information about PC-Duo documentation and technical support, see:
€ "Typographical conventions"

€ "Technical support options"

Typographical conventions in documentation

PC-Duo documentation uses typographical conventions to convey different types of
information.

Computer text

Filenames, directory names, account names, IP addresses, URLs, commands, and file
listings appear in a plain fixed-width font:

You can use the default domain user account named ‘RemoteControlGateway’.

In examples, text that you type literally is shown in a bold font.
To run the installation program, type installme in the command line.

Screen interaction
Text related to the user interface appears in bold sans serif type.
Enter your username in the Login field and click OK.

Menu commands are presented as the name of the menu, followed by the > sign and the
name of the command. If a menu item opens a submenu, the complete menu path is
given.

Choose Edit > Cut.
Choose Edit > Paste As... > Text.

Variable text

Variable text that you must replace with your own information appears in a fixed-width
font in italics. For example, you would enter your name and password in place of
YourName and YourPassword in the following interaction.
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Enter your name: YourName
Password: YourPassword

File names and computer text can also be displayed in italics to indicate that you should
replace the values shown with values appropriate for your enterprise.

Key names

Names of keyboard keys appear in SMALL CAPS. When you need to press two or more
keys simultaneously, the key names are joined by a + sign:

Press RETURN.

Press CTRL+ALT+DEL.

Technical support options

If you have any problems installing or using the PC-Duo remote support products,
information and support resources are available to help:

This manual and the Release Notes may contain the information you need to solve
your problem. Please re-read the relevant sections. You may find a solution you
overlooked.

Our technical support staff can be contacted by the following means:
& For Americas and Asia/Pacific:

email: support@vector-networks.com

phone: (800) 330-5035

& For Europe, Middle East and Africa:

email: support@virtualnetworkpartners.eu

phone: +44 2030040750

We offer a range of support options including support and maintenance contracts, and
time and materials projects. Consult our web site for the support plan that best meets
your needs. Goto http://www.vector-networks.com and navigate to the Support
section of the web site for more information.
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To install PC-Duo Master, the following requirements and recommendation should be
met:

€ "Requirements"

& '"Display considerations"
€ ‘"Installation notes"

& "Start options”
*

"Licensing"
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Requirements

PC-Duo Master can be installed on any computer that runs a supported operating system
(OS) and meets the minimum requirements described in this section.

Operating system requirements
Supported operating systems are:

¢ Windows XP

€ Windows Server 2003

¢ Windows Vista

4 Windows Server 2008

4 Windows 7

4 Windows Server 2008 R2

PC-Duo applications are supported on both 32- and 64-bit editions of these operating
systems (except Windows Server 2008 R2, which is 64-bit only).

Hardware requirements
The hardware requirements are:

€ Minimum requirements — Same as those specified by Microsoft for your operating
system.

€ Recommended requirements — Same as those specified by Microsoft for your
operating system.

Other requirements

The following additional requirements are required or recommended for installation of
PC-Duo Master:

€ Windows Installer 1.2 or later — Required by the installer. If needed, this upgrade is
applied automatically when the SETUP . EXE installer image is run.

€ Adobe reader — Required for documentation.

@ Local Administrator access rights — Required for the user who is installing PC-Duo
Master on the machine.

€ Additional memory — Required for each PC-Duo Master Remote Desktop or PC-Duo
Master Cycling Monitor window. The amount should be equal to the display size of the
Host. 3MB should be considered for each 1024x768 Host screen.

€ Microsoft Core XML Services (MSXML) 11.2 — Required for Remote Management. If
the Master cannot find the redistributable MSXML6 system component, an error message
will appear in the Remote Management window. In this case, you must install MSXML6
and restart the Master. See http://www.microsoft.com for more information about the
redistributable msxml6.msi package.

Network requirements
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PC-Duo Master can operate over any type of network, including dial-up, Ethernet, token
ring, and FDDI, provided that the network supports the TCP/IP, UDP/IP, IPX or SSL
protocols.

The following conditions apply:

& |P is a general-purpose protocol supported on a wide variety of networks and servers.
To enable communication using TCP or UDP over IP, you must enable the Microsoft
TCP/IP Protocol (or you can use another WinSock 2 compliant IP stack).

€ |IPX provides access to Novell NetWare servers. To enable communication using IPX,
it is not necessary for any computer to be logged into a NetWare server, nor is it
necessary to run a NetWare client. To enable communication using IPX, you must have
the Microsoft NWLink IPX/SPX Compatible Transport (included with the operating
system).

€ The SSL protocol runs above TCP/IP and below higher-level protocols such as HTTP
or IMAP. Using TCP/IP on behalf of the higher-level protocols allows an SSL-enabled
server to authenticate itself to an SSL-enabled client, and both machines to establish an
encrypted connection.

& The PC-Duo UDP, TCP and SSL transports fully support IPv4 and IPv6 addressing.
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Display considerations

To achieve the best color reproduction, the display capabilities of the computer on which
you run PC-Duo Master must match or exceed those of the remote Host computer.

If the Host computer’s resolution exceeds that of the local computer, the Host computer
display includes scroll bars.

Support for multiple monitors

In the Windows OS, multiple monitors can be used to increase the size of the desktop. By
connecting more than one monitor, you can see more programs and windows
simultaneously without overcrowding the desktop on one monitor.

PC-Duo Master supports multiple monitors so that you can access the entire desktop
remotely. For example, consider a Host computer that uses three monitors. PC-Duo
Master shows everything that is displayed on each monitor when you connect to that
Host.

If the Host computer’s display configuration is non-rectangular, the following caveats
apply to the Master screen:

€ A bright border traces the non-rectangular edge of the multiple-monitor desktop.
@ The space outside of the multiple-monitor desktop appears in a dark color.

4 Additional Host monitors must be positioned below and to the right of the primary
monitor; any monitor space above and/or to the left of the primary monitor will be cut off
(this is a Windows restriction).

(1]

(2]

3 ]
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Installation notes

If you plan to use PC-Duo Master to make remote connections through a PC-Duo
Gateway, see PC-Duo Gateway Server Guide before installing PC-Duo Master.

PC-Duo Master is distributed using Internet download. It can also be deployed and
installed to large numbers of machines using PC-Duo Deployment Tool.

Install via internet download

PC-Duo applications are distributed as ZIP files available for download from
http://www.vectornetworks.com. Unzip the contents (while preserving the
directory tree structure) on your computer.

To install PC-Duo Master, simply click on the Master .msi file.

Install via PC-Duo Deployment Tool

PC-Duo Deployment Tool can be used to install PC-Duo Master on one or more
computers in your network. For detailed information, see the PC-Duo Deployment Tool
Guide.
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Start options
Start PC-Duo Master using any of the following options:
¢ Choose Start > All Programs > Vector Networks > PC-Duo Master

€ Choose Start > Run and enter pcduo . exe. If you cannot open the application right
away, navigate to your product install directory from the command window before you run
pcduo. exe.

4 Double-click a PC-Duo Master shortcut file that stores remote Host computer
connection information. The shortcut file ends with the . PRX4 extension. When you use
this method to start PC-Duo Master, you establish a connection to a specified Host
computer immediately. For more information, see “Save as Shortcut”.

When PC-Duo Master is started, the PC-Duo Master Console appears.

g Master =]

Jg:unnecticun Wiew Options Goto Help
| 20 g X
Peer-to-Peer Hosts

Protocol: ILlDF'.I'IF' vI itatinn:l j Connect! |
Pork: |=:5tanc|arc|:=— "I Range: I::Lu:u:al Mebwork UDPJIPyS = j |_E|:ull ! | Manage. .. |
Cisplay Mame | Pratacal | Metwark Address | -
'-.-'M-QF'. -WESE LDRTP 222.738.1.67 —
'-.-'M-QF'. -aRY LDR{IP 222,738,173
'-.-'M-Q.ﬁ. -DiZ LIDR{IP 282.7368.1.52
'-.-'M-QA-WKS LDR{IP 222.7368.1.57
'-.-'M-Q.ﬁ.-SR'u'Z LDR{IP 222.7368.1.66 ;l
Peer-to-Peer Hosts ;{. Gateway Hosts }-.. Active Connections }H. Histary }-.. Favorites h Cyeling Manitar Has
29 Hosts, 0 selected =
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Licensing

If you download this software from the Vector Networks’ web site on a 30-day trial basis
and want to continue using the product, you may purchase it by contacting a preferred
reseller, or by contacting Vector Networks directly. Your purchase provides an
appropriate license key to use with PC-Duo Master.

The software does not have to be reinstalled after you purchase it. The product package
contains a license key that you can add to your existing installation. This key converts
your 30-day trial software directly to an unlimited version.

Add a license key before your trial period expires
To add a license key before your 30-day trial expires, follow these steps:
1 Select Start > All Programs > Vector Networks > PC-Duo Master.

2 Select Help > About PC-Duo Master from the PC-Duo Master window.

3 When the About PC-Duo Master window appears, click Add License. The Add License
Key window appears.

4 Enter the license key, and click OK.

Add License Key |

When wou purchase you receive a License Key ko unlock the
sofbware,

If wou have a version upgrade license key, wou musk add both the original
produck license kew {if not already shown) and the upgrade license key to unlock
the software,

Please enter wour License Key exactly as wou received it in the space below:

(a8 I Zancel

Your license is activated immediately. PC-Duo Master does not need to be restarted.

NOTE: If you are upgrading, then you will see both the original product license and the
upgrade license in the About PC-Duo Master window.

Add alicense key after your trial period expires

If you attempt to run PC-Duo Master after your trial period has expired, the message
Thank you for trying PC-Duo appears. Within the message, click Add License and enter
your new license key.
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Your license is activated immediately. PC-Duo Master does not need to be restarted.

Upgrade your license

If you are upgrading your license, you will receive an Upgrade license key, which you
should add using the instructions above. Both the original product license and the
upgrade license will be listed on the About tab.
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This section describes the components of the PC-Duo Master window:

Double-click on any Host computer in either the Peer-to-Peer Hosts tab or the Gateway
Hosts tab of the PC-Duo Master window in order to open a connection to that computer. A
Master Remote Desktop Window will open for that computer (see "Remote Desktop
Window Operation" for more information). You can have one or more Master Remote
Desktop Windows to different Host computers open at the same time.

25 Master M=l E3
J Connection  Wiew Gateway Options Goto  Help
E2% T

Gateway Hosts
Gateway: |local ~|  Manage... | By Connected tolocal via UDPYIP on 2303 at 127.0.0.1

GEroup: IF'.II Hosts j Refresh |

B0 oo

Display Mame | IJser | Skation | Machine | Protocal ﬂ
F‘ru:ux';.-'-gw adminminms Proey-gw PRI -3 IDPIF an
G.':'.TE'-.-'-.-'F'.'\" Bdrminiskratar GATEM &Y GATEMWAY LIDP| TR
SLIP'F‘ORT Adrministratar SUPPORT SUPPORT LIDPTP -

-
J | o
Host Recordings X
Display Marne | Recorded ak | Durakion |

Pear-to-Peer Hosts hﬁateway Hosts lfl:; Active Connections }1. Histary }1. Fawvarites h Cyeling Monitor Hosts f
4 Hosts, 1 selected £

The PC-Duo Master window has a set of tabs to organize access to remote Host
computers in your network. These tabs are at the bottom of the window:

€ "Peer-to-Peer Hosts": Find and make peer-to-peer connections to remote machines with
PC-Duo Host in this tab.

€ "Gateway Hosts": Choose a Gateway and a Gateway Group (by default, the Group is set
to All Hosts), and find and make Gateway-managed connections to remote machines with
PC-Duo Host in this tab. Screen activity on the Host machine can also be recorded (with or
without an active connection) and played back in the "Playback Window".

€ "Active Connections": View and/or disconnect active peer-to-peer or Gateway-managed
connections in this tab.
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€ 'History": Review a list of recent peer-to-peer and Gateway-managed connections in
this tab. If the Hosts are still available, make connections to those Hosts in this tab.

€ "Favorites": Keep a list of favorite peer-to-peer or Gateway-managed connections in this
tab.

€ "Cycling Monitor Hosts": Continuously monitor peer-to-peer or Gateway-managed
connections in this tab. Create a list of Host computers to monitor in a view-only mode by
cycling through the connections to each Host.

NOTE: Windows Firewall may prevent some Host computers from appearing in the Master
window. By default, PC-Duo Host automatically adds the PC-Duo Host service to the list of
Windows Firewall exceptions, but if this is turned off, then you may need to add the PC-
Duo Host application (along with appropriate transport and port, e.g. UDP 1505 and/or TCP
1505) as an exception to Windows Firewall on that Host computer.

In addition to the tabs, the following additional features are available through the PC-Duo
Master window:

€ Connecting to computers running VNC server (e.g. Mac, Linux). See “VNC Hosts”.
€ Menus for selecting features. See “Menu options”.

& Default Master window settings. See “Master Settings”.

Host status icons

Each Host computer that is listed in any of the tabs of the PC-Duo Master window has a
workstation icon associated with it. The connection status and availability of the Host
computers is indicated by the color of the icon.

Icon Color Status

Host computer is available for

Blue .
connection.

Host computer is not currently
Gray available for connection, usually
because it is busy.

Light Are currently connected to this
green Host computer.

Are currently connected to and
Dark monitoring this Host computer in
green the PC-Duo Master Cycling
Monitor window.

NOTE: When logged-in users are displayed on the managed Hosts tab, the icon resembles
a user (head in profile) rather than a workstation, but the color and status indicators are
identical to those listed above. See “Gateway Hosts” for information on logged-in users.
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Tool bar options

Table below summarizes the functions of icons on the tool bar in the PC-Duo Master
window.

Icon Function

it Connects to the selected Host computer and
displays remote desktop only

Connects to the selected Host computer with

E the Remote Control tab selected.
)E Connects to the selected Host computer with
the File Transfer tab selected.
% Connects to the selected Host computer with
the Remote Printing tab selected.
Connects to the selected Host computer with
E=] the Remote Management tab selected.
Lo Displays the available Host computers as
i large icons.
bt~ Displays the available Host computers as
small icons.
= Displays the available Host computers as an

alphabetical list.

Displays the available Host computers as a
detailed list.
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Peer-to-Peer Hosts tab

If a Master can locate a Host in its network, the Host is known as a Peer-to-Peer Host and
will be listed on the Peer-to-Peer Hosts tab in the Master. Double-click on any remote Host
to establish a direct remote control connection (called a "peer-to-peer connection”); a
Master Remote Desktop Window will pop up showing the desktop of the remote Host (see
Remote Desktop Window Operation for more information).

With peer-to-peer connections, security and other configuration settings will be negotiated
between the Master and Host.

g Master [_ (O] =|
Jg::unnectinn Wigw Options Goto Help

| 20 g 3 X
Frotocol; Im itatiu:un:l j Zanmneck! |

Fork: Im Rgnge:l::L-:n:aI Metwork UDPTPw4 = j 5 ling| =nace. |

Display Mame | Praotacol | Metwork Address |

DD oooac oo

Peer-to-Peer Hosts .f{. Gateway Hosts h Active Connections }-.. History ,]H. Favarites }H. Cyeling Monitor Hos
Polling 255,255,255, 255 { 29 Hosts | o

From the Peer-to-Peer Hosts tab of the PC-Duo Master window, you can find Hosts by using
one of the following 3 options:

& “Type the station or address”
€ "Select from automatic polling lists"

€ "Search with custom polling list"

Type the station or address

Sometimes polling for machines in the network with PC-Duo Host is not ideal (such as a
network with a large number of machines distributed across multiple domains). In these
situations, polling by the Master may be slow and bandwidth-intensive.

Instead, if you know the IP address of the Host computer, you can initiate a connection by
typing its address in the Station field of the Peer-to-Peer Hosts tab.
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=& Master M=l &3
Jgnnnectiu:un Yiew Opkions Goto  Help

| %0 g X
Protacal; Im itaticun:l
Port: | <standard= v Fange: [<Local Netwark UDR{IPv4

Display Mame | Pratacal | Metwaork Address |

(=]
=]

H Mamage... |

Peer-to-Peer Hosks ;{. Gakeway Hosts }H. Active Connections h Hiskory }H. Favarites }H. Cyeling Maonitar Hos
Palling 255,255,255, 255 { 29 Hosts A

To manually specify a Host connection directly from the Peer-to-Peer Hosts tab, follow
these steps:

1 Choose UDP/IP, TCP/IP, or IPX from the Protocol list to specify the required Host
computer connection protocol.

2 If you do not choose the (default) standard PC-Duo port, type the port number next to
Port to specify a port number.

NOTE: PC-Duo Host uses port 1505 by default.

3 Type the network address or station name of the remote Host computer in the Station
field. You can also select recently typed stations or addresses from the drop-down list.

4 To establish a connection to the specified Host computer, use one of the following
methods:

& Click the Connect! button.
& Select Connect from the Connection menu.

€ Select Connect Special from the Connection menu if you want to connect for a particular
service, such as file transfer, or as another user.

When a connection is established to the Host computer, the PC-Duo Master Remote Desktop
Window appears. For more information, see PC-Duo Host Guide.

Select from automatic polling list

When PC-Duo Master starts up and the Peer-to-Peer Hosts tab is selected, the Master
automatically starts polling the network for machines with PC-Duo Host. Soon, a list of all
Host computers in your network will appear.

NOTE: The polling feature works with the UDP/IP and IPX protocols only. Polling does not
work with the TCP/IP protocol.

By default, when PC-Duo Master is started, it polls for all Host computers using the default
search parameter in the Range list (by default, this is set to UDP/IP on local network
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segment). Automatic polling can be disabled in Options > Master Settings so that search for
computers is always initiated manually.

For each computer, the following information is provided:

€ An Icon to indicate connection status. For information on the icons, see “Master
Operation”.

€ Display Name
¢ Protocol
@ Network Address

To refresh the list, click Poll or to stop a polling operation, click Stop.

=2 Master M=l

Connection  Wiew Options Goto Help
[ % X 9 X
Peer-to-Peer Hosts

(=

2R B

Prokocal; IUDP.I'IF‘ TI il:al:il:un:l j Comneck! |
Port: Im Flgnge:l-::anal Metwork LUDPTPvd = j |_E|:|II ! | Manage. .. |
Display Mame | Protocol | Metwork Address | *l
'-.-'M-QF'. -WkS2 LIDR{IP 222.735.1.67 —
'-.-'M-Q.ﬁ. -SRY LIDR{IP 222,738,1.73
'-.-'M-Q.ﬁ. -DZ LIDR{IP 222,738.1.52
'-.-'M-QA-WKS LIDR{IP 222,738.1.57
'-.-'M-QP.-SR'-.-'E LIDP)IF Z222,738,1.66 ;I
Peer-to-Peer Hosts .f{. Gateway Hosts }-.. Active Connections h Histary }H. Favorites }-.. Cyeling Monitor Hos
29 Hosts, 0 selected o

When you select a Host computer in the list, the Station field is updated to reflect your
selection. For display options for this field, see “Master Settings”.

Double-click a Host computer in the list to connect to it.

Search using custom polling list

When PC-Duo Master starts up and the Peer-to-Peer Hosts tab is selected, the Master
automatically starts polling the network for machines with PC-Duo Host.

To limit or expand the number of computers listed, adjust the range of addresses polled
with your own search criteria. From the Manage Polling Ranges dialog, create and save a
search to poll a range of network addresses or a single broadcast address. Once more
than one search is created and saved, you can create a group of searches to poll more
than one network segment at a time.

For more information about creating and managing searches, see:
& “Create a search for peer-to-peer Host computers”
& "Create a UDP/IP search"
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4 “Group one or more saved searches”

€ “Manual polling”

Create a search for peer-to-peer Host computers

By default, PC-Duo Master searches only your local network segment when it starts to poll
for Host computers. To search for Host computers on a different network segment, a
named search must be created.

To create, edit, or remove a search, click Manage in the Peer-to-Peer Hosts tab. The
Manage Polling Ranges window appears.

Manage Polling Ranges

work LIDP =

«Link Local Mebwark UDPTPywG =
«5ike Local Metwork UDPTPwG =
«Local Mekbwork, TPE =

: Mew ==
Edit. ..

Remove

iy

Mave o

[Mave Do

Close

Help

dll

The Ranges list displays any searches that you have specified and saved, as well as the
default local network searches. The searches that can be saved include a single address, a
range of addresses, or a grouping of previously saved searches.

Four entries (<Local Network UDP/IPv4>, <Link Local Network UDP/IPv6>, <Site Local
Network UDP/IPv6>, and <Local Network IPX>) represent the local networks to which you are
connected. You cannot edit or remove any of them. You can edit or remove any other
searches listed:

4 Click Edit to change the definition of a selected search.
4 Click Remove to delete a selected search from the list.

A new search can be created using either a custom polling range or a custom group by
clicking New>>.

Create a UDP/IP search
Use UDP/IP to poll for Host computers using one of the following techniques:
Create a UDP/IP broadcast to IPv4 address

To locate a Host computer by polling a specific IPv4 address, follow these steps:
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1 From the Manage Polling Ranges window, select New > UDP/IP. The Polling Ranges
Definition window appears.

Polling Range Definition |

UDPAP Palling Fangs |

% Broadcast to IPv4 address

™ Scan IPv¢ address range

" Broadcast to IPv6 link-local mulkicast address
" Broadcask to IPv6 site-local multicast address

" Poll single computer {ak one IPv6 address)

Address; IEI.EI.IZI.IZI

Descripkive Mame: I

Pork: I =Standard = vI

[ Hide this range on the Peer-to-Peer Hosts page.

k. I Cancel Apply Help

Select Broadcast to IPv4 address.
Enter the Host computer network address that you want to poll in the Address field.

Enter a name for the search next to Descriptive Name.

a b~ W N

To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

6 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

7 Save your search using one of the following methods:
@ Click Apply to save changes and leave the Polling Range Definition window open.
@ Click OK to save changes and close the Polling Range Definition window.

NOTE: Select Broadcast to IPv4 address to search for remote Host computers by sending
a packet to a specific address. Note that broadcasts to other networks or subnets only work
if intervening routers are configured to forward broadcasts.

Create a UDP/IP scan IPv4 range of addresses
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To locate one or more Host computers by polling a range of IPv4 addresses, follow these
steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Palling Fangs |

" Broadcast to IPwd4 address

fs Scan IPv4 address range:

" Broadcast to IPv6 link-local mulkicast address
™ Broadcast to IPv6 site-local mulkicast address

" poll single computer {ak one IPv6 address)

First Address: I

humber of addresses: I 1

Descripkive Mame: I

Part: I <5kandard = vI

[ Hide this range on the Peer-to-Peer Hosts page.

k. I Cancel Apply Help

UDP/IP Polling Range - Scan IPv4 address range

2 Select Scan IPv4 address range.
3 Enter the first address in your desired network polling range next to First Address.

4 Specify the size of the range by entering the number of addresses to search beyond the
First Address next to Number of addresses.

5 Enter a name for the search next to Descriptive Name.

6 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

7 To omit the search from the Ranges list on the Peer-to-Peer Hosts tab, click Hide this
range on the Peer-to-Peer Hosts page.

8 Save your search using one of the following methods:

4 Click the Apply button to apply changes and leave the Polling Range Definition window
open to create and save more UDP searches.

4 Click the OK button to save changes and close the Polling Range Definition window.
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Create a UDP/IP broadcast to IPv6 link-local multicast address

IPv6 link-local addresses are used only on a particular local link (physical network),
typically for special purposes such as address resolution or neighbor discover. The link-
local broadcast address is FF02::1.

To locate a Host computer by polling a specific IPv6 multicast address on a local link, follow
these steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Palling Fiange |

™ Broadcast ko IPv4 address

" Scan IPv4 address range

{* Broadcast to IPv6 link-local mulkicast address:

" Broadcast to IPv6 site-local multicast address

i~ Poll single computer {at one IPvE address)

Descripkive Mame: I

Part: I <A5kandard = vI

[ Hide this range on the Peer-ta-Peer Hosts page.

k. I Cancel Apply Help

UDP/IP Polling Range - Broadcast to IPv6 link-local multicast address

2 Select Broadcast to IPv6 link-local multicast address.
3 Enter a name for the search next to Descriptive Name.

4 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

5 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

6 Save your search using one of the following methods:
4 Click Apply to save changes and leave the Polling Range Definition window open.

4 Click OK to save changes and close the Polling Range Definition window.
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Create a UDP/IP broadcast to IPv6 site-local multicast address

IPv6 site-local addresses allow data to be sent only to the devices within a site or
organization. The site-local broadcast address is FF05::4000:1.

To locate a Host computer by polling a specific IPv6 multicast address within a site or
organization, follow these steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Palling Fiange |

i~ Broadcast ko IPv4 address
" Scan IPv4 address range

™ Broadcast ko IPvE link-local multicast address

{* Broadcast to IPv6 site-local multicast address!

i~ Poll single computer {at one IPvE address)

Descripkive Mame: I

Part: I <A5kandard = vI

[ Hide this range on the Peer-ta-Peer Hosts page.

k. I Cancel Apply Help

UDP/IP Polling Range - Broadcast to IPv6 site-local multicast address

2 Select Broadcast to IPv6 site-local multicast address.
3 Enter a name for the search next to Descriptive Name.

4 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505

5 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

6 Save your search using one of the following methods:
@ Click Apply to save changes and leave the Polling Range Definition window open.

4 Click OK to save changes and close the Polling Range Definition window.
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Create a UDP/IP Poll single computer (at one IPv6 address)
To locate a Host computer by polling a specific IPv6 address, follow these steps:

1 From the Manage Polling Ranges window, select Local Network UDP/IP and click New.
The Polling Ranges Definition window appears.

Polling Range Definition |

UDPAP Palling Fiange |

™ Broadcast ko IPv4 address
" Scan IPv4 address range
{” Broadcast to IPv6 link-local multicast address

" Broadcast to IPv6 site-local multicast address

i Poll single computer (at one IPv6 address);

Address: I

Descripkive Mame: I

Part: I <A5kandard = vI

[ Hide this range on the Peer-ta-Peer Hosts page.

k. I Cancel Apply | Help |

UDP/IP Polling Range - Poll single computer (at one IPv6 address)

2 Select Poll single computer (at one IPv6 address).

3 Enter the address of the computer in your desired network polling range in the Address
box.

4 Enter a name for the search in the Descriptive Name box.

5 To specify a UDP port number to use for polling, enter it in the Port field. The default
<Standard> port is 1505.

6 To omit the search from the Ranges list located on the Peer-to-Peer Hosts tab, click Hide
this range on the Peer-to-Peer Hosts page.

7 Save your search using one of the following methods:
@ Click Apply to save changes and leave the Polling Range Definition window open.

4 Click OK to save changes and close the Polling Range Definition window.

Group one or more saved searches
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Two or more searches can be grouped together to poll for Host computers. The result of
using a polling group is that the combined results appear in a single list on the Peer-to-Peer
Hosts tab. For example, polling groups can be used to combine the results of UDP/IP and
IPX searches. Searches must be created separately and saved, before they can be
combined into a group.

To create a group of searches for polling, follow these steps:

1 Select New > Group from the Manage Polling Ranges window. The Polling Range
Definition window appears.

Polling Range Definition |
Group Palling B ange |

Select segments to include in Group:

O <Local Metwark UDPAPwd:

O <Link Local Metwork, UDPAPE:
[ <Site Local Metwork UDPAPE:
O <Local Metwork [P

Dezcriptive Mame; I

k. I Cancel | Apply Help

2 Click the check box to select any previously created searches to include in the polling
group.

3 Enter a name for the polling group in the Descriptive Name field.
4 Save your polling group using one of the following methods:

@ Click Apply to apply changes and leave the Polling Range Definition window open to
create more groups.

@ Click OK to save changes and close the Polling Range Definition window.

Manual polling

Saved searches can be used to manually poll for Host computers, even if the Master is
configured for automatic polling.

To use a saved search to poll for Host computers, follow these steps:

1 Use the Range list to select a search. This list includes two default searches through

your local network and any searches you create using the Manage Polling Ranges window.
Note the following:

€ When you select a new search from the list, polling begins automatically.
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@ Click Poll to refresh the current list of Host computers. This list reflects the search that is
currently listed next to Range.

€ The search for Host computers might take some time. New Host computers are added
to the list as they are found.

2 The Poll button changes its title to Stop Polling when polling begins. You can click Stop
Polling to terminate the search and leave the current results in the display.
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Gateway Hosts tab

When a remote Host computer is configured to report to a PC-Duo Gateway, the Host is
known as a Gateway Host. To find a Gateway Host, follow these steps:

Gateway Hosts
Gateway: I j Manage... |
Group: I j Refresh |

€ Choose a Gateway from the Gateway drop-down list. Add/modify/delete Gateway entries
by clicking on the Manage button (see "Add a Gateway" for more information).

€ Choose a group from the Group drop-down list. By default, this value is initially set to the
All Hosts group. To add/modify/delete custom groups, please see Gateway Server Guide.

Once you choose a group, all the Gateway Hosts in that group will appear in the main
Master window. The list of Gateway Hosts can be refreshed at any time to reflect any
changes to the group or Gateway by clicking Refresh or choosing Gateway > Refresh Host
List from the menu.

2 Master M=l

Jg:-nnecticun Wiew Gateway Opkions Goto Help
BT
Gateway Hosts

Gateway: [local ~|  Manage... | By Connected tolocal via UIDP/IP on 2303 at 127.0.0.1
Group; I.ﬁ.ll Hosts j Refresh |

EE SeEe Bl
e

Display Mame | Lser | Skation | Machine | Praotocol :l
F‘r-:ux';.f-gw adminmmms Priocy-guw PR -3 IDPYIF an
GF'.TE'-.-'-.-'F'.\" Adniniskrator GATEMWAY GATEWAY LIDP)IF
SLIF‘F‘DRT Administrator SUPPORT SUPPORT LIDRIP —

-
J | o
Host Recordings b
Display Mame | Recorded at | Duration |

Peer-to-Peet Hosts hﬁateway Hosts lr'-r.. Active Connections }H. Histary }-.. Faworites h Cycling Maonitor Hosts f
4 Hosts, 1 selected £ 4
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From the Gateway Hosts tab of the PC-Duo Master window, you can:
“Connect to a Gateway Host”

“Record screen activity on a Gateway Host”

“Play a recording”

“‘Add a Gateway”

“Manage access rights to a Gateway Host”

“Send Wake-on-LAN Signal”

L 2BR BN JEE 2R JER 2

Connect to a Gateway Host

You can establish a remote control connection through the selected Gateway (called a
"Gateway-managed connection") to one or more Gateway Hosts using any of the following
methods:

¢ Double-click the Host.
¢ Select the Host and choose Connection > Connect.

& Select the Host and choose Connection > Connect Special, and then choose Remote
Control, File Transfer, Remote Printing or Remote Management to specify the default tab to
display whenever you connect to that Host computer.

@ Select the Host and choose Connection > Connect Special > Connect As, and then type
the Username and Password to log in as a different user.

A separate Master Remote Desktop Window will pop up showing the desktop of the remote
Host (see Remote Desktop Window Operation for more information):

& GATEWATY via SUPPORT - Master Connection

Jg::unnectiu:un Edit Mjew Options Goko Help

EL IS [BEO b 88 o Gd

Remote Control .f{. File Transfer .Ih Remate Printing .Ih Remate Managerent f‘

For Help, press F1 i
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The benefit of a Gateway-managed connection is that security and other configuration
options can be enforced by the Gateway on all Hosts in a particular Gateway group or on
all Gateway Hosts. These settings will override any individual settings at the Host level.

Record screen activity on a Gateway Host

From the Gateway Hosts tab of the PC-Duo Master console window, screen activity on any
managed Host can be recorded, even if there is not active remote control connection.
When PC-Duo Master initiates a recording session, screen data from managed Host is
streamed to a file on the PC-Duo Gateway. The Gateway can support multiple recording
sessions at the same time. Consult the screen recording hardware requirements for
scalability information.

Host Recordings list

To set up the Gateway Hosts tab to display a list of recordings, click View > Host Recordings.
The Host Recordings portion of the tab lists the following information:

€ Display Name — Shows the name of the Host computer on which you recorded screen
activity, followed by the data and time that you began to record it.

€ Recorded at — Shows the date and time that you began to record.

€ Duration — Shows the duration of the recording in seconds

Begin recording

To record activity on a Host computer, you must be connected to the PC-Duo Gateway that
manages the Host, but you do not have to be connected to the Host computer itself. One or
more recording sessions can occur at the same time.

To record screen activity:

1 Connect to the PC-Duo Gateway that manages the Host computers on which you want
to record screen activity.

2 Inthe list of managed Hosts, select each Host on which you want to record activity.

3 Right-click and choose Record, or choose Connection > Record from the menu. The
Record Selected Host(s) window opens.

4 In the Record Selected Host(s) window, specify the Recording Span in minutes. The
default setting is 5.

5 Click OK to begin recording.

As soon as the recording begins, it is listed in Host Recordings. When a recording has
finished, it remains listed in Host Recordings but the icon changes.
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The following icons indicate the status of a recording:
L 4 in the Gateway Hosts list indicates a Host on which a recording is in process.
2 @ in the Host Recordings list indicates a recording in process.

L 2 @ in the Host Recordings list indicates a recording that has finished.

Adjust the time span for recording
When a recording is in process you can adjust its recording time.

1 Inthe Host Recordings list, select each recording for which you want to change the
recording span.

2 Right-click and choose Adjust Recording Time.

3 Inthe Record Selected Host(s) window, select a different Recording Span in minutes
and click OK.

Stop recording
A recording can be stopped at any time:
1 Inthe Host Recordings list, select each recording that you want to stop.

2 Right-click and choose Stop Recording Time or choose Connection > Stop Recording
from the menu. The recording stops immediately.
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Play a recording
Recordings can be played back in the following ways:
& From the PC-Duo Gateway, which streams the recording to the Master.

€ From a PC-Duo recording file, that has been saved with the . PrxRec extension to a
local drive.

The recording plays in the PC-Duo Master Playback window. For more information, see
“Playback Window Operation”.

Play a recording from the PC-Duo Gateway
To play a recording from the PC-Duo Gateway:
1 Select the recording you want to play.

2 Right-click the recording and choose Playback Recording or choose Connection >
Playback Recording from the menu.

The Playback window opens and the recording begins to play.

Play a recording from a file

Use this feature to either copy to a disc or email a recording file to a location that may not
be able to access the PC-Duo Gateway. The recordings are stored by the PC-Duo
Gateway at a location configured by the Gateway Administrator (which may or may not be
accessible through a network share).

Delete a recording
Delete a recording from the Host Recordings list and the PC-Duo Gateway.
1 Inthe Host Recordings list, select each recording that you want to delete.

2 Right-click and choose Delete Recording or choose Connection > Delete Recording from
the menu. The recording is removed from the Host Recordings list and deleted from the PC-
Duo Gateway.

NOTE: If you save a PC-Duo recording file to a local drive, you must use Windows Explorer
to delete the . PrxRec file.

Add a Gateway

To make a connection from PC-Duo Master to a Gateway Host computer, the PC-Duo
Gateway must be added to the drop-down list of PC-Duo Gateways.

To add a PC-Duo Gateway:

1 From the Gateway Hosts tabs, click Manage, or choose Gateway > Manage Gateway List
from the menu. The Manage Gateways window opens.
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Manage Gateways

Gateways

Edit...

Bemove

Cloze

e Ier |

Help

2 Click New. The Gateway Connection Properties window opens.

Gateway Connection Properties |

Connection | Connect fe I

—Gakteway

Display Mame: I G|

Praotocol; ILlDF'.I'IF' vI Port: I-::Standard::- vI

Gateway Specifier: I 152.1.1.1

Skation Mame: I

Metwork Address: I

¥ Use encryption

Find Gateway. .. I

k. I Cancel Apply | Help |

3 Inthe Connection tab, follow these steps:
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& Enter a name for the PC-Duo Gateway in the Display Name box.
€ Select a connection protocol from the Protocol list.
€ Select a standard Port or type in a port number.

NOTE: The default port number for SSL protocol is 443. Both TCP and SSL cannot listen
on the same port, and must therefore be configured for distinct ports. The default
<Standard> PC-Duo Gateway port number for TCP and UDP is 2303.

& ldentify the PC-Duo Gateway in the Gateway Specifier text box with either of the
following methods:

+ Type the server name, DNS name, or network IP address

+ Click Find Gateway to open the Find Gateway Wizard, which walks you through the
steps to find a PC-Duo Gateway.

4 If you want to change the default Protocol or Port, select another choice from the list.
See “Connection tab” for details.

5 In the Connect As tab, there are two login options for connecting to the PC-Duo
Gateway:

& Leave the default, Use logged-in username and password, to accept the existing user
login credentials.

€ Select Use the following username and password and type a different User name and
Password to change the login credentials.

Gateway Connection Properties |

Connection  Connect Az |

&+ Use logged-in usemame and pazsword

i~ Ugze the following usemame and passward;

I zer name: I

Pazswoard: I

Fate: viou will =till be prompted if the zelected security
mode iz hot accepted by the remaote Host or if some of
the login parameters are mizzing.

] I Cancel Al Help
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6 Click OK to close the Gateway Connection Properties window. The PC-Duo Gateway is
now listed in the Manage Gateways window.

7 Modify/delete Gateways in the Manage Gateways window:
& Select a PC-Duo Gateway in the list and click Edit to edit its properties.
€ Select a PC-Duo Gateway in the list and click Remove to remove it.

@ Click Close to return to the PC-Duo Master window.

Manage access rights to a Gateway Host

For auditing purposes, your network administrator may require that all remote control
connections be established through a PC-Duo Gateway. If this is the case, your remote
control access rights for Gateway Hosts are determined by the credentials you use to
connect to the PC-Duo Gateway. Usually, these are your Windows credentials.

If your administrator has restricted your access rights, the remote control functionality on a
Gateway Host may be limited or denied. See your administrator if you are unable to
connect to either a PC-Duo Gateway or a Host computer.

Note: If you connect to a Gateway using an Administrative account (see PC-Duo Web
Console Operating Guide) and all available Administrative licenses are already in use, you
will be placed in Restricted Administrative Mode, and a message to that effect will appear
on right side of the page header on the Gateway Hosts tab. In this mode you have no
rights to see any Groups or Hosts. Use the Gateway Administrator or the PC-Duo Web
Console to login and resolve any concurrent usage or licensing issues.

Send Wake-on-LAN Signal

When a Master attempts to connect through the Gateway to a remote computer with a
Host, and the last Host status in the Gateway indicates that the Host is offline, PC-Duo
assumes that the remote computer is asleep, and will automatically send the Wake-on-LAN
signal (based on its MAC address and last known IP address). If the Gateway doesn’t think
the Host is offline, this step is skipped.
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Conneck

Conneck Special ¥
Conneck to YWMC Server. ..

Send Wake-On-LAMN Signal

Recard. ..

Stop Recording

Elay Recaording
Delete Recording
Expart Recording

Add ko Fayvarites
add ko Cycling Monikor Hosts

Save As Sharkcuk

Propetties

Flay Recording Fram Eile. ..

Play Recording via URL...

Exit

If the remote computer was asleep, and wakes up in a timely manner, the Master
connection attempt will be successful (although it may take longer than if the computer
were already awake). If the computer doesn’t wake up in a timely manner, the connection
attempt will fail, but the computer will now be awake so if the Master attempts a connection
again, it should be successful.

The Master user can also explicitly try to wake up an offline computer by selecting a Host
with offline status in the Gateway Hosts tab and then invoking the Send Wake-on-LAN
Signal command from the console menu bar (Connection > Send Wake-on-LAN Signal)
or Gateway Hosts tab context menu. If a Host is not selected, the Send Wake-on-LAN
Signal command will not be active.
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Active Connections tab

View active remote connections from the Active Connections tab of the PC-Duo Master
window.

=g Master =]

Jg::unnectinn Wiew Options Goto Help

| 20 3 X

Active Connections

Display Mame Connecked at | Prokocal Gateway | Mebw... | Recaorded at Ciurakian
Sl prowys 8/25/2007 ... UDP/IP 192....
=) yp-pROKYI0 8/25/2007 ... LUDP/IP 192....

Pear-to-Peer Hosts }1. Gateway Hosts }-..Acti\re Connections ;{. Histary }1. Fawvarites h Cyeling Monitor Hosts j'
2 Hosts, 0 selected 5

View active connections as follows:

& Each Host computer to which you establish a remote control connection is listed
separately.

@ If you establish a cycling connection, then the corresponding currently active Host
computer is listed with a dark green icon.

Select the Active Connections tab to view concise information about each of the current
connections in five columns:

€ The Display Name column indicates the name by which the connection is identified.

€ The Connected at column indicates the time and date at which the connection is
established.

€ The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or
IPX protocol.

€ The Gateway column indicates the PC-Duo Gateway (if any) that manages the
connection.

€ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

€ The Recorded at column indicates the time when a recording session on the Host
computer was started

€ The Duration column indicates how long the recording session lasted
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Double-click an entry to return to the associated connection activity (remote control or
cycling).

Connection menu from the Active Connections tab

When one of the entries in the Active Connections list is selected, the following Connection
menu items are available:

€ Use Show Window to move the associated connection activity to the foreground.
& Use Disconnect to terminate a selected active connection.

€ Use Add to Favorites to add a selected remote Host computer to the list of favorite Host
computers. See “Favorites”.

€ Use Add to Cycling Monitor Hosts to add a selected Host computer to the list on the
Cycling Monitor Hosts tab of the PC-Duo Master window. See “Cycle through the Cycling
Monitor Hosts list”.

€ Use Save as Shortcut to create a shortcut file (with the extension . PRx4) for the
selected Host computer.

€ Use Properties to display information about a selected remote connection.
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History tab

View a list of the most recent Host computers to which you have connected through the
History tab of the PC-Duo Master window.
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Select the History tab to view concise information about each of your most recent

connections:

€ The Display Name column indicates the name by which the connection is identified.

€ The Connected at column indicates the time and date at which the connection is

established.

¢ The Disconnected at column indicates the time and date at which the connection was

terminated.

¢ The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or

IPX protocol.

€ The Gateway column indicates the PC-Duo Gateway (if any) that manages the

connection.

€ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

€ The Recorded at column indicates the time when a recording session on the Host

computer was started

€ The Duration column indicates how long the recording session lasted

The following tasks can also be performed:

66



Master Operation

€ Sort history information: Sort the information displayed in the History tab according to
the values of any column heading by clicking the column heading. For example, click
Display Name to sort the items in the list alphabetically by name.

€ Open a connection to a Host computer: Open a connection to any Host computer listed
in the History tab by double-clicking the Host computer name.

& Clear items in the history list: Select Edit > Clear History from the History tab of the PC-
Duo Master console window to clear the history list.

NOTE: See “Master Settings” for information on settings relevant to the History tab.
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Favorites tab

Save information about the most common or important connections that you make, and list
these connections on the Favorites tab of the PC-Duo Master window.

For see specific properties of Hosts listed on Favorites tab, see "Properties of favorite Host
computers".
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Select the Favorites tab to view concise information about each of your favorite
connections:

€ The Display Name column indicates the name by which the connection is identified.

¢ The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or
IPX protocol.

€ The Gateway column indicates the PC-Duo Gateway (if any) that manages the
connection.

€ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

€ The Recorded at column indicates the time when a recording session on the Host
computer was started

€ The Duration column indicates how long the recording session lasted

Connection menu from the Favorites tab
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When one of the entries in the Favorites list is selected, the following Connection menu
items are available:

€ Use Connect to connect to a favorite Host computer

€ Use Connect As to connect to a favorite Host computer with credentials other than your
Windows user name and password.

€ Use Remove to delete a favorite Host computer from the list of favorites
€ Use Rename to assign a new name to a favorite Host computer

€ Use Add to Cycling Monitor Hosts to add a favorite Host computer to the list on the
Cycling Monitor Hosts tab of the PC-Duo Master control panel. See “Cycle through the
Cycling Monitor Hosts list”.

€ Use Save as Shortcut to create a shortcut file (with the extension .PRX4) for the favorite
Host computer.

€ Use Properties to display information about a favorite Host computer.

Properties of favorite Host computers

Use Connection > Properties from the Favorites tab of the PC-Duo Master console window
to view or edit connection parameters for a selected Host computer.

Connection tab
Use the Connection tab to set and display the settings for favorite Host computers.

If the favorite computer you select is a peer-to-peer Host computer (originally listed on the
Peer-to-Peer Hosts tab), the Connection tab displays information similar to the following:
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The following Host computer connection properties can be edited:

€ Connection protocol: Select a Protocol from this list.
€ Connection port: Select the standard Port or type in a port number.

€ Type in the Station Specifier or other items using the following syntax:
network address:machine network name. A station specifier is an optional network
specifier followed by a colon, and a station name (which can include wild cards). It can be:

+ a protocol-specific network address prefixed with ‘@’
+ a DNS name (for UDP and TCP)
+ a PC-Duo station specification

€ Check or uncheck Use encryption.

If the favorite computer you select is a managed Host computer (originally listed on the
managed Hosts tab), the connection properties of a managed Host computer displays.
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Edit the Host key, which is the key used by the PC-Duo Gateway to specify the Host
computer address.

When Gateway is clicked, the following information relevant to your local connection to the
PC-Duo Gateway appears.
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Connect As tab

Specify credentials to use when connecting to a Host computer for peer-to-peer
connections or to a PC-Duo Gateway.

Select the following options from the Connect As tab:

€ Select Use logged-in username and password to log in with the username and password
for your local computer.

€ Select Use the following username and password to log in to the associated Host
computer with other credentials (username and password). Enter the appropriate
credentials in the fields provided.

If you do not enter the required username and/or password, the Enter Network Password
window appears when you attempt to connect. See “Connecting with different credentials”
for more information.

Startup tab

From the Startup tab, choose the name of one of the PC-Duo Master Remote Desktop
Window tabs from the Make the following tab active at connect list. The name you
choose is the default tab you view when you connect to a Host computer.

For more information, see the Startup tab on the "Default Remote Desktop Window
Settings" page.

Remote Control tab
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Specify the default behavior for remote control connections from the Remote Control tab.

For more information, see the Remote Control tab on the "Default Remote Desktop
Window Settings" page.

Effects tab

Use the options on the Effects tab to provide default settings for enabling and disabling
certain visual effects when connecting to a Host computer. By disabling any of the listed
visual effects, you can reduce the amount of screen data that needs to be captured and
transmitted over the network.

For more information, see the Effects tab on the "Default Remote Desktop Window
Settings" page.
File Transfer tab

Use the File Transfer tab to provide default settings for remote file transfer.

For more information, see the File Transfer tab on the "Default Remote Desktop Window
Settings" page.
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Cycling Monitor Hosts tab

The Cycling Monitor allows you to serially check in on a set of remote Host computers to
monitor the activity of those Hosts but not to take control of them. The Cycling Monitor has
its own window, similar to the Master Remote Desktop Window, except that it is view-only
mode at all time (see “Cycling Monitor Window Operation” for more information). The
Cycling Monitor window will show the desktop of each remote Host listed on the Cycling
Monitor Hosts tab for a predetermined period of time.
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In the Cycling Monitor Hosts tab, you can perform the following tasks:
€ “Add Host computers”

“Sort Host computers”

“Connect to Host computers”

“Cycle through the Cycling Monitor Hosts list”

“Open Cycling Monitor”

“Remove Host computers”

* 6 6 O o o

“Clear all Host computers”

Select the Cycling Monitor Hosts tab to view concise information about any Host you want
to monitor:

€ The Display Name column indicates the name by which the connection is identified.
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& The Protocol column indicates whether the connection uses the TCP/IP, UDP/IP, SSL or
IPX protocol.

€ The Gateway column indicates the PC-Duo Gateway (if any) that manages the
connection.

€ The Network Address column indicates the network address of the Host computer,
displayed in IP or IPX format as appropriate.

Connection menu from the Cycling Monitor Hosts tab

When the Cycling Monitor Hosts tab of the PC-Duo Master console window is selected, the
Connection menu options change. The following additional options appear:

4 Show Window — Use Connection > Show Window to open the Cycling Monitor window to
view the activities of that Host computer and other Host computers on the cycling list.

¢ Remove — To remove a Host computer listed on the Cycling Monitor Hosts tab, select it
and then select Connection > Remove.

€ Rename — To change the displayed name for a Host computer listed on the Cycling
Monitor Hosts tab, select it and then select Connection > Rename.

Add Host computers

Add to the list of Host computers in the Cycling Monitor Hosts tab by selecting a Host
computer on any other tab of the PC-Duo Master console window, and then choose
Connection > Add to Cycling Monitor Hosts.

When you add a Host computer to the list in the Cycling Monitor Hosts tab, the PC-Duo
Master Cycling Monitor window is automatically moved to the top (and opened, if it has not
yet been opened) if the Activate if a new object has been appended option in the Cycling
Monitor Settings window is selected.

Sort Host computers

Sort the list of Host computers on the Cycling Monitor Hosts tab of the PC-Duo Master
console window by selecting one of the column titles (such as Display Name or Network
Address). The listed Host computers are sorted alphabetically or numerically, according to
the type of information that is displayed in the selected column.

Connect to Host computers

Double-click a Host computer listed on the Cycling Monitor Hosts tab to monitor its activity
through the PC-Duo Master Cycling Monitor window.

Cycle through the Cycling Monitor Hosts list

The default for the PC-Duo Master Cycling Monitor window is to cycle through the Host
computers in the list one at a time. Change the cycle rate using Options > Cycling Monitor
Settings or the tool bar. Freeze the monitoring process from the Connection menu.

As you cycle through monitoring Host computers in the PC-Duo Master Cycling Monitor
window, view the connection status for each Host computer from the icons listed on the
Cycling Monitor Hosts tab.
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Open Cycling Monitor

To open the PC-Duo Master Cycling Monitor window, double-click a selected Host
computer on the Cycling Monitor Hosts tab.

Remove Host computers

To remove a selected Host computer from the list on the Cycling Monitor Hosts tab, right-
click and select Remove.

Clear all Host computers

To clear all Host computers from the Cycling Monitor Hosts list, select Edit > Clear Cycling
Monitor Hosts.
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VNC Hosts

In addition to Peer-to-Peer Hosts and Gateway Hosts, PC-Duo Master can reach and
establish remote control connections to remote computers running a standard version of
the Virtual Network Computing (VNC) server ("VNC Hosts"). PC-Duo Master includes a
proprietary implementation of the VNC Remote Frame Buffer (RFB) protocol, enabling it to
function as a VNC client that can connect to and interoperate with any standard VNC
server.

PC-Duo Master supports connections to VNC server running on the following operating
systems:

€ Apple Macintosh (when the built-in screen sharing is configured to allow VNC
connections, or when an alternative VNC server is installed and configured). The following
specific configurations are supported:

+ 0SX10.5-10.7

€ Linux (when a VNC server is installed and configured). The following specific
configurations are supported:

+ Red Hat Fedora 11-16

Peer-to-Peer Connections to VNC Server

PC-Duo Master console includes a menu item Connection > Connect to VNC Server... to
initiate a peer-to-peer connection to a VNC server:

Conneck

Conneck Special ¥
Conneck to YWMC Server. ..

Send Wake-On-LAMN Signal

Recard. ..

Stop Recording

Elay Recaording
Delete Recording

Expart Recording

Add ko Fayvarites
add ko Cycling Monikor Hosts

Save As Sharkcuk

Propetties

Flay Recording Fram Eile. ..

Play Recording via URL...

Exit
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A dialog box will appear to prompt for the information required to connect to the server:

Enter ¥MC Server Name or Address | x| |

Please enter the name or address of the YMC Server you wish ko conneck Eo;

Server: | 292262123 =]

Protorol: |TcpyP =] port: | 5900 |

Cptionally, enter a passwaord:

Password; I |

(0] 4 I Cancel |

As illustrated, the required information is the server name (DNS name or IP address), the
protocol (currently the only option is TCP), and the port (default is set to port 5900).

VNC servers normally require a password for authentication. This password can be entered
in the dialog box. If no password is entered, but the VNC server requires one, a dialog box
will appear to collect the password:

Enter Metwork Password |

% Flease tvpe the password For Ehis Host,

Huost: 292 2621.23

Bassward:

| (04 I Cancel Help

Once connected, the remote display of the computer running the VNC server appears in a
standard Master Remote Desktop Window.

The Remote Desktop Window for a VNC server has the following limitations:

4 Only the Remote Control service is supported at this time. Menu options and icons for
other services such as File Transfer, Remote Printing, Remote Management and Chat are
disabled.

& Other configuration options are not applicable
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Command Line Support for VNC Hosts

Connections to VNC servers can be invoked from the Master command line utility using the
following option:

« “/v” indicates that the specified Host is a VNC server. This switch can be used in
conjunction with the /p (protocol), /s (station specifier), and /x (password) switches to fully
specify a VNC server to connect to. See "Command line options" for more detail.
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Menu options

Use the following menus to manage configuration settings for PC-Duo Master:
€ Select “Connection” to see detailed list of all remote connection options

& Select “Edit” to modify the list of Host computers on the History or Cycling Monitor Hosts
tab

& Select “View” to show or hide parts of the PC-Duo Master window

& Select “Gateway” to operate the Manage and Refresh buttons on the Gateway Hosts tab
@ Select “Options” for modify default display options for various windows

@ Select “Goto” to select tabs on the PC-Duo Master window

€ Select “Help” to obtain help on the product

NOTE: The menus change according to which tab you select in the PC-Duo Master
window.

Connection

Use the following Connection menu options on the Peer-to-Peer Hosts and Gateway Hosts
tabs of the PC-Duo Master console window:

Conneck

Conneck Special »
Connect to ¥MNC Server...

Send Wake-On-LAMN Signal

Record. .,
Shop Recording

Flaw Recording
Delete Recording
Expatt Recarding

Add ko Favorites
add ko Cycling Monikor Hosts

Save As Shortouk

Properties

Play Recording From Eile. ..
Play Recording wia URL. ..

Exit

¢ “Connect”
& “Connect Special”
¢ “Connect to VNC Server...”
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“Send Wake-on-LAN Signal”
“Record...”

“Stop Recording”

“Play Recording”

“Delete Recording”

“Export Recording”

“Add to Favorites”

“Add to Cycling Monitor Hosts”
“Save as Shortcut”
“Properties”

“Play Recording from File...”

L R 2K JEE JEE JER JEE JEE JER JEE R R 4

“Play Recording via URL...”

See also the following Connection menu options that become available depending on which
tab you select:

4 “Connection menu from the Cycling Monitor Hosts tab”
€ “Connection menu from the Active Connections tab”

¢ “Connection menu from the Favorites tab”

Connect

Select Connection > Connect from any tab other than Active Connections to connect to a
selected Host computer. A PC-Duo Master Remote Desktop Window appears.

Use the PC-Duo Master Remote Desktop window to view or control a remote Host
computer. Establish simultaneous connections to one or more Host computers by repeating
this procedure.

Connect Special

Use Connection > Connect Special to choose from the following connection options when
you connect to a Host computer:

€ Select Remote Control to connect to a selected Host computer and open the PC-Duo
Master Remote Desktop Window with the Remote Control tab selected. See “Remote
Control”.

@ Select File Transfer to connect to a selected Host computer and open the PC-Duo
Master Remote Desktop Window with the File Transfer tab selected. See “File Transfer”.

€ Select Remote Printing to connect to a selected Host computer and open the PC-Duo
Master Remote Desktop Window with the Remote Printing tab selected. See “Remote
Printing”.

€ Select Connect As to connect to a selected Host computer with credentials other than
your Windows user name and password.

Connecting with different credentials

When you connect to a Host computer, you are usually authenticated with the same user
name and password with which you logged in to your local computer. Select Connection >
Connect Special > Connect As to connect to the Host computer with different credentials.
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When you initiate a connection to a Host that requires a different username and/or
password, the Enter Network Password window appears.

Enter Metwork Password Ed |

% Please type vour uzer name and password.

Host: proxygateway

User Mame: I

Pazzword: I

[~ Save these credentials permanemntly

k. I Cancel Help

Enter Network Password window

Enter an authorized username and/or password for the Host computer (fill in all blank
fields) and click OK.

Record...

On the managed Hosts tab, select Record... to start a recording for any Gateway-managed
Host computer that is selected.

Stop Recording

On the managed Hosts tab, select Stop Recording to stop any active recording for any
Gateway-managed Host computer that is selected.

Play Recording

On the managed Hosts tab, select Play Recording to activate the Master Playback window
and play back a recording selected from the Hosts recordings list in the Master Console.

Delete Recording

On the managed Hosts tab, select Delete Recording to delete a recording selected from the
Hosts recordings list in the Master Console.

Export Recording

On the managed Hosts tab, select Export Recording to save a recording selected from the
Hosts recordings list in the Master Console in Microsoft .wmv format The following dialog
box will popup during and that the completion of the recording:
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*ﬁ Conversion complete [_ | O] |

Converking via Gakteway 127.0.0,1
SessionlD; {7F2C040E-3BAC-4BCD-2100-02FFEBS4EFSS}

]

Conyversion completed successhully

Destination:
Ci\Documents and Settingsiadmini. . Swirtual-2003-01-02-16-09-10-372, WY

[ Close this dialog box when conversion is complete

Play Cpen Eolder

Add to Favorites

Select Add to Favorites to add a selected peer-to-peer or Gateway-managed Host
computer to the list of favorite Host computers. The list of favorite Host computers appears
when you select the Favorites tab on the PC-Duo Master console window. See “Favorites”.

Add to Cycling Monitor Hosts

Select Add To Cycling Monitor Hosts to add a selected Host computer to the list on the
Cycling Monitor Hosts tab. This is the list of Host computers you intend to supervise using
the PC-Duo Master Cycling Monitor window.

NOTE: If you check Activate if a new object has been appended under the General tab
of the Cycling Monitor Settings window, cycling monitor connections are automatically
activated when you add a Host computer to the Cycling Monitor Hosts list.

Save as Shortcut

To save connections that you access frequently as shortcut files on your desktop, use
Connection > Save As Shortcut. The shortcut file, which has the extension . PRX4, provides
an easy way to connect to a selected Host computer for the purpose of remote control, file
transfer, or remote printing.

Alternatively, drag and drop connections to your desktop to create a shortcut.

Use a shortcut file to establish a connection to its associated Host computer by double-
clicking the shortcut file from the desktop.

The shortcut file saves information about the connection to the Host computer. You can
view information about your Host computers by right-clicking the shortcut file from your
desktop and selecting Properties. This information includes the following:

€ The protocol used to access the Host computer
€ The Host computer network address
€ The Host computer station name

See “Properties of favorite Host computers” for more information.
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PROXYE.prx4 Properties ﬂ |

Effects | File Transfer I Security I Cuigtarn I Summary I
General Connection I Connect bs I Startup I Remate Control

— Peer-ta-Peer Host

Display Mame:

Protocal; ILIDF'.-'IF' "I Fart: |<Standard> "I

Station Specifier: IEEIE.EEE.'I ZEPROMYE

Station M arme: IF"H 06

Metwork Address: IEEIE. 262.1.23

[T Use encryption

k. I Cancel Apply

Properties

Use Connection > Properties to display the connection information for a selected Host
computer.

When a Host computer is selected from the Favorites or Cycling Monitor Hosts tabs, you
can edit the properties that appear. Editable properties also appear when you right-click a
shortcut file that is saved to your computer and select Properties.

When a Host computer is selected from the Peer-to-Peer Hosts or managed Hosts tabs, you
cannot edit the properties that appear. The following Properties window is for a managed
Host and is not editable.
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FRONTDESK Properties |

Connection |

—Gaakteway Hosk

Display Mame:

Hosk key: I w={ACDF03F7-72F0-4821-B322-22A4F1C31 1
Protocal: I LIDRIP Part: IISEIS—
Station Mame: I FROMTDESK

Metwork Address: I 192,168.1.102

Warkskation I I {9CC70EF7-72F0-45821-B322-224F1C31 1EDf

User: I

Gakeway. . |

k. I Cancel ][I Help

NOTE: When you view properties for a Host computer listed on the managed Hosts tab,
the protocol and port specified indicate those used for the connection between the remote
Host computer and the PC-Duo Gateway.

Click Gateway... to see properties for the connection between the PC-Duo Gateway and the
Master computer.

85



PC-Duo Master Guide

Gateway Properties |

Connection | Connect s I

—Gaakteway

LCisplay Mame: I G5

Protocol; ILlDF'.I'IF' vI Port: I«::Standard} vI

Gateway Specifier: I 152.1.1.1

Statian Mame: | WS

Metwork Address: I 152.1.1.1

[~ Use encryption

Find Gateway. .. I

k. I Cancel Apply | Help |

Edit

Select Edit > Clear History from the History tab of the PC-Duo Master console window to
clear the history list.

Select Edit > Clear Cycling Monitor Hosts from the Cycling Monitor tab of the PC-Duo Master
console window to clear the Cycling Monitor Hosts list.

View

Modify display options for the PC-Duo Master console window by using the View menu.
The View menu is organized into three sections:

€ Top section - user interface elements in the PC-Duo Master window

4 Middle section - tabs in the PC-Duo Master window

€ Bottom section - icon viewing options
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Menu Bar
Toolbar
Page Header
Tabs

Faktus Bar

Peer-to-Peer Hosks Page
.

Ackive Connections Page

akeway Hosts Page

Histary Page
Favaribes Page

Cwcling Monitor Hosts Page

<] <lef<f<]<]<]] <]<]<]<]<]

v Host Recordings

Large Icons
Small Icons
Lisk

IT Dietails

User interface elements in the PC-Duo Master console window

Toggle the appearance of the following elements in the PC-Duo Master console window by
checking or unchecking items on the View menu:

¢ Menu Bar

4 Tool Bar

& Page Header, the heading displayed for each selected tab
4 Status Bar

& Tabs

Tabs in the PC-Duo Master console window

Control the appearance of the following tabs by checking or unchecking the tab names
listed on the View menu:

& Peer-to-Peer Hosts
managed Hosts
Active Connections
History

Favorites

* 6 6 0 o

Cycling Monitor Hosts
Icon viewing options

When a Host computer icon is selected on any tab, the display option for icons can be set
by using the View menu:
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€ Select Large Icons to display Host computer icons as large icons, with the name of the
remote Host computer as the title. The icons are arranged left to right, and then top to
bottom, sorted alphabetically according to Host computer name.

€ Select Small Icons to display Host computer icons as small icons.

& Select List to display Host computer icons as small icons, sorted alphabetically, and
placed top to bottom, and then left to right.

€ Select Details to display Host computer icons in a vertical scrolling list, along with other
details, such as the IP address of each Host computer.

Gateway

Use the Gateway menu from the Gateway Hosts tab of the PC-Duo Master console window
to select the following commands:

® Refresh Host List refreshes the list of Host computers on the Gateway Hosts tab.

€ Manage Gateway List opens the Manage Gateways window from the managed Hosts tab.
See “Add a PC-Duo Gateway”.

Options

Use the Options menu to set the following options:
& “Master Settings”

“Keyboard Mapping”

“Default Remote Desktop Window Settings”
“Cycling Monitor Settings”

“Default Playback Window Settings”

* 6 o o

Master Settings
Select Options > Master Settings to set certain preferences for the following features:

& “Peer-to-Peer Hosts” - to set automatic polling options and station specifier construction
options for the Peer-to-Peer Hosts tab.

€ “Gateway Hosts” - to set some options that may limit the way Host computers display on
the Gateway Hosts tab.

€ “History” - to set some options for how Host computers display on the History tab.

4 “Clipboard” - to set option to include or not include the mouse pointer on Host computer
in screen capture.

Peer-to-Peer Hosts

Select the Peer-to-Peer Hosts tab in the Master Settings window to adjust the following
settings:
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Master Settings |

Peerto-Feer Hosts | Gateway Hn:nstsl Histn:nr_l,ll I:Iipl:n:-ardl

Conztruct station zpecifiers:

™ from DNS name or by network and station name

% from network and station name only

™ from network connection address only

v Pall autcrnatically on startup

k. I Cancel Apply Help |

€ Construct station specifiers: Specify the way that station specifiers (connect strings) are
constructed for polled Hosts by selecting one of the following options:

+ From DNS name, or by network and station name specifies Host computers either
by computer name or by DNS name. With this option, a reverse DNS lookup is
attempted using the network address. A reverse DNS lookup can take a long time
depending on the network configuration, and may cause performance problems if
there is a large number of Host computers. If the reverse DNS lookup succeeds,
the station specifier is the DNS name. Otherwise, the network address and station
name are used.

+ From network and station name only specifies Host computers by network
address and station name using the address: name syntax.

+ From network connection address only specifies Host computers network
address.

& Check Poll automatically on startup to poll for Host computers when you start PC-Duo
Master. With this option, PC-Duo Master searches for all computers listed next to Range on
the Peer-to-Peer Hosts tab. This is useful if the polling range is small. If the polling range is
large, automatic polling may slow PC-Duo Master’s startup significantly.

Gateway Hosts

Use the managed Hosts tab of the Master Settings window to control how items are
displayed on the Gateway tab.
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Master Settings |

Peerto-Peer Host:  Gateway Hosts |Histu:ury| I:Iipl:u:uardl
i~ Show Users

i~ Show Waorkstations

e

% Allow duplicates
™ Hide any Workstation that is a duplicate of a User

" Hide any User that is a duplicate of a Workskation

k. I Cancel Help |

Specify which type of Gateway-managed Host computers to display:
€ Select Show Users to display the set of Gateway-managed users who are logged in.
€ Select Show Workstations to display the target set of Gateway-managed workstations.

€ Select Show both to display all logged-in users and workstations in the set of Gateway-
managed Hosts. You can specify how you want duplicates handled when both a
workstation and a user logged into that workstation are potential Hosts. You can select one
of the following:

+ Allow duplicates: Allow both the logged-in user and corresponding workstation to
display (although they resolve to the same physical Host computer).

+ Hide any workstation that is a duplicate of a user: Display only the logged-in user.

+ Hide any user that is a duplicate of a workstation: Display only the workstation on
which the logged-in user is working.

NOTE: This is an advanced feature. Do not change the default options unless you know
how your PC-Duo Gateway is configured.

History

Use the History tab of the Master Settings window to control the way that items are
recorded on the History tab:

€ Always: All of your connections to Host computers are reported on the History tab.

€ Onlyiftab is not hidden: Your connections to Host computers are reported on the
History tab only when the tab is visible.

€ Never: Your connections to Host computers are not reported on the History tab.
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Master Settings |

Peer-to-Peer Hn:nstsl Gateway Hostz  Histary | I:Iipl:n:-ardl

Record histary
i Always
& Dnly if tab is not hidden;
8 Mewver

Maximurm number of connections ko skare;
20 =

k. I Cancel Help |

Also, you can limit the number of connections to save on the History tab by specifying a
value for Maximum number of connections to store (default = 20).

Clipboard

Use the Clipboard tab of the Master Settings window to specify whether or not the mouse
pointer on the remote Host screen should be captured:

Master Settings |

F'eer-tu:u-F'eerHu:ustsI (3 ateway Hu:ustsl History  Clipboard |

[™ Capture Host pointer when using Copy Graphics:

k. I Cancel Help |
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Keyboard Mapping

Certain key combinations perform special functions on a computer. Because of Windows
features, the following key combinations can apply to the local computer only:

¢ CTRL+ALT+DEL
& CTRL+ESC
€ Any key combination that includes the Windows key

To create a key combination that applies to the remote Host computer, select Options >
Keyboard Mapping.

Keyboard Mapping |
—Commands —Selected Command
Toggle Full Screen Toggles Full Screen mode For
Remaote Ckrl+alk+Del Zonnection Window and Playback
Remote Alt+PrinkScreen Simdow
Remake Print3creen
Accelerakor;
F11

Special Hot Key, .. |

Restore Default

Remowve |

Restare Al Ik Cancel | Help |

There are five sections in the Keyboard Mapping window:
4 “Commands”

“Accelerator and Special Hot Key”

“Restore Default”

“‘Remove”

“Restore All”

* 6 o o

Commands

The Commands list shows the commands available for mapping. A text description of the
currently selected command is shown under Selected Command. The currently mapped
key, which when pressed will invoke the command, is described under Accelerator.

Figure above illustrates the TOGGLE FULL SCREEN accelerator key combination mapped to
the Remote F11 command. This means that when a PC-Duo Master Remote Desktop
Window has the focus and the user presses the F11 key, the Host computer will be sent
F11, which will have the effect of opening the full screen on the Host computer.
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Accelerator and Special Hot Key

To modify the key combination in the Accelerator field, place the cursor in the Accelerator
field and simple press the desired key combination. The text description of the key
combination will automatically appear. To specify special hot key combinations, which you
cannot normally type because the system will immediately interpret them using the default
meaning, such as ALT+TAB, CLICK Special Hot Key to open the Special Hot Key window.

Special Hot Key |
— Ken Definition
S
SyzReq/PrintScreen j
Maone = Cancel |
Tab —
Ezcape
Delete 5 Help |

In the Keyboard Definition section, select the keys you want to use and click OK to return to
the Keyboard Mapping window. The Accelerator field shows the new key combination.

Remove

To remove a key mapping, select the command in the Commands list and click Remove.

Restore Default

To restore a key mapping to its default setting, select the command in the Commands list
and click Restore Default.

Restore All

To restore all key mappings to the default settings, click Restore All.

Default Remote Desktop Window Settings

Use Options > Default Remote Desktop Window Settings to set initial parameters for remote
connections and specify a configuration template for new PC-Duo connections.

NOTE: You can change most of these settings for a particular connection once it is
established. To do so, select Options > Remote Desktop Window Settings from the PC-Duo
Master Remote Desktop Window.

Set five types of default Remote Desktop Window settings can be set:
“Connection”

“Startup”

“‘Remote Control”

“Effects”

® 6 6 o o

“File Transfer”

Connection
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In version 4.0 and later, the Host computer supports encryption. From the Connection tab of
the Default Remote Desktop Window Settings window, require data encryption for data
transfer.

Default Remote Desktop Window Settings |

Connection | Startupl Remate I:::untn:ull Effectsl File Transferl

™ Use encryption (for peer-to-peer connections

k. I Cancel Amply Help

Check Use encryption to require data encryption for data transfer.

NOTE: Host computer encryption requirements override this option. The connection is
encrypted if the Host computer requires encryption, even if you uncheck Use encryption.

Startup

From the Startup tab of the Default Remote Desktop Window Settings window, choose the
name of one of the PC-Duo Master Remote Desktop Window tabs from the Make the
following tab active at connect list. The name you choose is the default tab you view when
you connect to a Host computer.
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Connection  Startup I Remate En:nntr-:nll Effectsl File: Transferl

Make the Following tab active at connect:

=]

k. I Cancel fY a1 Help

Remote Control

Master Operation

Specify the default behavior for remote control connections from the Remote Control tab of

the Default Remote Desktop Window Settings window.
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Default Remote Desktop Window Settings |

En:nnnec:tin:nnl Statup  Remate Cantral |Effect$| File: Transferl

— Wiewer Seftings

[~ Full Screen £+ Fit ko windaw [v¥ Halftone;
[~ Wiew Only  Fit 1-ko-1

—Host Opkions (if allowed/supparked by Hosk)
[™ suppress kevboard and mouse

—auto-scroll
[+ Cursaor (text-mode only) [v Mouse (kexk & graphics modes)

—Text-mode Display ———————— 1~ Text-mode Maouse

Fort:  [Proxy 5 x 14 = ™ Left button clicks
[ Right buttan clicks

Text refresh rate

Foreground: IFast vI % Mo mouse motion

" Absolute mouse motion

Background: I 1 second vI ™ Relative mouse mokion

k. I Cancel | Apply Help

Modify the following options:
€ Use Viewer Settings to specify default settings for the remote display:

+ Select Full Screen to fill the entire screen of the local computer with a view of the
Host computer monitor in the PC-Duo Master Remote Desktop Window.

+ Select View only to allow users of PC-Duo Master to view the display without
taking control of the Host computer.

+ Select Fit to window to scale the display of the Host computer to fit into the PC-
Duo Master Remote Desktop Window.

+ Select Fit 1-to-1 to have each pixel on the Host computer display correspond to
one pixel on the Master computer.

+ Select Halftone to improve the quality of the display when the Master is in Fit to
Window mode.

Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.

4 Modify the Host Options to specify the operation of the remote Host computers when
you establish PC-Duo Master Remote Desktops:

+ Select Suppress keyboard and mouse to request that the remote Host computer
mouse and keyboard be disabled at connection time. If this request is granted, no
one can operate the mouse and keyboard located at the Host computer at any time
during the PC-Duo Master Remote Desktop. Note that even if you select this
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option, it is possible that the remote Host computer is configured so as not to allow
keyboard and mouse suppression.

NOTE: These options are not currently supported on Vista platforms.

€ Modify Auto-scroll group options to specify whether you want the window to scroll when
the cursor (for text-only screens) or mouse reaches a boundary:

+ Select Cursor (text-mode only) to automatically scroll when the cursor comes to
an edge of the PC-Duo Master Remote Desktop Window when you hold the CtrL
key down.

+ Select Mouse (text & graphics mode) to automatically scroll when the mouse
comes to an edge of the PC-Duo Master Remote Desktop Window when you hold
the Ccrrr key down.

€ Modify Text-mode Display options for Host computers that display text screens, rather
than graphical screens:

+ Use the Font drop-down list to select the typeface and type size to use for
viewing remote connections locally. By changing the font, you can increase or
decrease the size of the Host computer screen displayed in the PC-Duo Master
Remote Desktop Window. A smaller font lets you see more of the Host computer
display. A larger font improves readability. You can preview the fonts from each
entry in the Font list. The names of the fonts consist of a typeface name and a size.
Text fonts called PROXY are fonts that are included with this software package.
Fonts with other typeface names are Windows fonts that are also suitable for text
display.

+ Use the Text refresh rate settings to specify the rate at which changes in the text
display are updated on your screen. This allows you to find a suitable compromise
between “refresh rate” and the amount of computation time and network resources
spent in updating the text display. Note the following:

- The Foreground setting rate you select applies when the Remote Desktop
Window is active.

- The Background setting rate you select applies when the Remote Desktop
Window is not active.

In general, if you have sufficient computational power and a speedy connection, you should
leave both refresh rates set to Fast.

€ Modify the Text-mode Mouse group to control how information from the mouse on the
local computer is transmitted to a remote Host computer when it operates in text mode:

+ Check Left button clicks to ensure that left mouse button clicks are sent to the
remote Host computer.

+ Check Right button clicks to ensure that right mouse button clicks are sent to the
remote Host computer.

+ There are three different ways in which the motion of the mouse on the Master
can be interpreted and sent to the remote Host computer:

- If you select No motion, then the mouse does not move at all.

- If you select Absolute motion, then the Host computer is provided an
absolute mouse position [for example, a coordinate such as (44,13)].

- If you select Relative motion, then only the differential motion of the mouse
(up, down, left, or right from current position) is sent to the Host computer.

Effects
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Use the options on the Effects tab of the Default Remote Desktop Window Settings window
to provide default settings for enabling and disabling certain visual effects when connecting
to a Host computer. By disabling any of the listed visual effects, you can reduce the amount
of screen data that needs to be captured and transmitted over the network.

Default Remote Desktop Window Settings |

I:Dnnectil:unl Startupl Fiemote Contral -~ Effects | File Transferl

v ‘Request Visual Effects to be dizabled a3 follows:

—%izual Effects to be Dizabled

¥ Aero Glass [desktop composition]

¥ Backaround wallpaper o pattemn

¥ Mouse shadows and trails

¥ Font smoothing and ClearType

v Menu shadows and window animations
¥ Show window contents while dragging

¥ Scieen Saver

k. I Cancel Amply Help

All visual effect options are enabled by default. Check Request Visual Effects to be disabled
as follows to enable or disable specific graphical effects. Check the visual effects options
that you want to disable under Visual Effects to be Disabled. Leave the visual effects options
that you want to enable unchecked.

File Transfer

Use the File Transfer tab of the Default Remote Desktop Window Settings window to
provide default settings for remote file transfer.
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Default Remote Desktop Window Settings |

En:nnnec:tin:nnl Startupl Fiemate En:nntr-:nll Effects File Transfer |

[T Wiew file attributes
[ Wiew hidden & zystem files

— Left Pane Settingz
Starting direchony:

£ View |ocal file system Sort files by:

" Wiew remate file system Marme j

— Right Pane Settings
Starting directary:

£ Wiew |ocal file system Sort files by:
 Wiew remote file system INE"""E j

k. I Cancel | fY a1 | Help |

Select the following:

& View file attributes: An extra column that provides file attribute information appears on
both the left and right sides of the File Transfer tab.

€ View hidden & system files: Hidden and system files are added to both the left and right
sides of the File Transfer tab.

Specify the following default settings:
& Default starting directories for local and remote computers

€ The location for local and remote computer files. For example, select View local file
system under Left Pane Settings to view local files on the left side of the File Transfer tab
and the remote files on the right side.

& The category by which the files on each side are sorted:
+ Choose Name to sort files by file name
+ Choose Size to sort files by file size

+ Choose Modified to sort files by the file modification date

Cycling Monitor Settings
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Use the PC-Duo Master Cycling Monitor to serially check on multiple remote connections in
the PC-Duo Master Cycling Monitor window. On the PC-Duo Master window, use Options >
Cycling Monitor Settings to control the behavior of this window.

General

Use the General tab to specify preferences for the PC-Duo Master Cycling Monitor window.

Cycling Monitor Settings |

General | Cycling Manitor |

I 10} _Ij seconds cycling.

[T Always on kop

Cycling span: 1
|7 Enter 0 seconds to disable

¥ activate if a new objeck has been appended

] I Cancel Apply Help

Set the following preferences:

€ Set the number of seconds to display each connection in the PC-Duo Master Cycling
Monitor window using Cycling span. Select 0 to disable the automatic cycling through Host
computers. This also disables the Connection > Start Cycling and Connection > Stop Cycling
menu commands in the PC-Duo Master Cycling Monitor window.

@ If you check Always on top, the PC-Duo Master Cycling Monitor window is always the
top window.

@ If you check Activate if a new object has been appended, the PC-Duo Master Cycling
Monitor window is moved to the foreground as soon as you add a new Host computer to
the list on the Cycling Monitor Hosts tab and attempt to establish a connection with that
Host computer.

If you do not check Activate if a new object has been appended, remote Host computers are

silently added to the Cycling Monitor Hosts list without attempting to establish a connection
in the PC-Duo Master Cycling Monitor window.

100



Cycling Monitor Settings
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Control the display of the PC-Duo Master Cycling Monitor window using the Cycling Monitor

Hosts tab.

Cycling Monitor Settings

General  Cwcling konitor |

— Yiewer Setkings

[~ Full Screen

% Fit ko windaw
" Fit 1-to-1

— Auto-scroll

v Cursor (text-mode anly)

[+ Mouse (text & graphics modes)

— D05 Sessions

=]|

Font:  |prowy 5% 14 =~
] 4 I Cancel Apply Help

Select the following:

€ Use Viewer Settings to specify how a remote computer is displayed by default:

+ Select Full Screen to fill the entire screen of the local computer with a view of the
Host computer monitor in the PC-Duo Master Cycling Monitor window.

+ Select Fit to window to scale the display of the remote computer to fit into the
PC-Duo Master Cycling Monitor window.

+ Select Fit 1-to-1 to have each pixel on the remote display correspond to one pixel
on the local computer.

+ Select Halftone to improve the quality of the display when the Master is in Fit to

Window mode.

Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.

€ Modify the Auto-scroll group options to specify whether you want the window to scroll
when the cursor or mouse reaches a boundary:
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+ Select Cursor (text-mode only) to scroll automatically when the cursor comes to
an edge of the PC-Duo Master Remote Desktop Window when you hold the CtrL
key down.

+ Select Mouse (text & graphics mode) to scroll automatically when the mouse
comes to an edge of PC-Duo Master Remote Desktop Window when you hold the
ctry key down.

€ Modify text mode screen options in DOS Sessions:

The Font drop-down list allows you to select the typeface and type size used to display the
remote Host computer screen in the PC-Duo Master Cycling Monitor window.

By varying the font, you can increase or decrease the size of the Host computer screen
displayed in the PC-Duo Master Cycling Monitor window. If you use a small font, you can
display more of the Host computer in a small window. To improve readability (but require a
larger window), use a large font.

The fonts in the list are previewed as they actually appear. The names of the fonts are
composed of a typeface name and a size. PC-Duo text fonts are included with the software
package. Fonts with other typeface names are Windows fonts that are also suitable for text
display.

Default Playback Window Settings

When playing back a PC-Duo screen recording, the display of the PC-Duo Playback
window can be controlled using the Playback Window Settings tab.
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Default Playback Window Settings |

Flayback. I

—Wiewer Settings

[~ Full Screen % Fit o window v Halftone:
" Fit 1-to-1

— fuko-scrall

[+ cCursor (text-made only) [+ Mouse (kext & graphics modes)

— D05 Sessions

Font:  |proscy 5 14 -]

k. I Cancel Apply Help

Select the following:
€ Use Viewer Settings to specify how a remote computer is displayed by default:

+ Select Full Screen to fill the entire screen of the local computer with a view of the
Host computer monitor in the PC-Duo Master Cycling Monitor window.

+ Select Fit to window to scale the display of the remote computer to fit into the
PC-Duo Master Cycling Monitor window.

+ Select Fit 1-to-1 to have each pixel on the remote display correspond to one pixel
on the local computer (set by default).

+ Select Halftone to improve the quality of the display when the Master is in Fit to
Window mode.

Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.

€ Modify the Auto-scroll group options to specify whether you want the window to scroll
when the cursor or mouse reaches a boundary:

+ Select Cursor (text-mode only) to scroll automatically when the cursor comes to
an edge of the PC-Duo Master Remote Desktop Window when you hold the CtrL
key down (set by default).

+ Select Mouse (text & graphics mode) to scroll automatically when the mouse
comes to an edge of PC-Duo Master Remote Desktop Window when you hold the
ctrL key down (set by default).
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€ Modify text mode screen options in DOS Sessions:

The Font drop-down list allows you to select the typeface and type size used to display the
remote Host computer screen in the PC-Duo Master Cycling Monitor window (set to "PC-
Duo 8x14" by default).

By varying the font, you can increase or decrease the size of the Host computer screen
displayed in the PC-Duo Master Cycling Monitor window. If you use a small font, you can
display more of the Host computer in a small window. To improve readability (but require a
larger window), use a large font.

The fonts in the list are previewed as they actually appear. The names of the fonts are
composed of a typeface name and a size. PC-Duo text fonts are included with the software
package. Fonts with other typeface names are Windows fonts that are also suitable for text
display.

Goto

Use the Goto menu to change tabs in the PC-Duo Master console window:
€ Peer-to-Peer Hosts Page

¢ Gateway Hosts Page

€ Active Connections Page

& History Page

& Favorites Page

4 Cycling Monitor Page

Help

The Help menu contains commands to invoke the Help system, provide access to special
webpages on the Internet, and display information about your PC-Duo Master license and
configuration.

Press the F1 key or click a Help button (in the windows that offer one) to access context-
sensitive online help.

The Help menu has the following commands:

“Help Topics”

“Vector Networks Home Page”

“Check for Updates and Maintenance Releases”
“Purchase Additional Licenses”

“Order Technical Support Contract”

“About PC-Duo Master”

* 6 6 O 0 o

Help Topics
Select Help > Help Topics to access the table of contents for the PC-Duo Master online help
system. You can display help for any topics you select.

Vector Networks Home Page
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Select Help > Vector Networks Home Page to connect to the Vector Networks Home page,
where you can get access to upgrades, patches, product news, product information, and
technical notes relevant to your PC-Duo products.

Check for Updates and Maintenance Releases

Select Help > Check for Updates and Maintenance Release to connect to the Vector Networks
Support page, where you can request information about the latest upgrades, patches and
maintenance releases for PC-Duo products.

Purchase Additional Licenses

Select Help > Purchase Additional Licenses to connect to the Vector Networks Store page,
where you can purchase additional licenses of PC-Duo products.

Order Technical Support Contract

Select Help > Order Technical Support Contract to connect to the Vector Networks Support
page, where you can order a Maintenance & Support contract your product. These
contracts will provide you access to live technical support at Vector Networks, and free
upgrades during the contract period for all new maintenance and new feature releases.

About PC-Duo Master

Select Help > About PC-Duo Master to display details about the PC-Duo Master software
that is installed on your computer.

About Master |

About I

F:E Master

Version 12.0.0.1800

Copyright € 2006-2012 Proxy Metworks, Inc, All Rights Reserved,
Your trial period will expire on Saturday, January 14, 2012

30 dav(s) remaining.

Licensels)

add License. .. | Syskerm Infarmation, .. |

(04 I Help |
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The About PC-Duo tab displays the following information:

€ The name and version number of your software

& Copyright information

€ The company and user to whom the software is registered
# License key(s) registered with the package

Some features available with PC-Duo Master are specified by the license key(s) you
purchase. Only the features that you have licensed for use are available to you. You may
have entered one or more licenses. These appear in the License(s) list.

There are two buttons in the About PC-Duo window:

€ Add License: Add more license keys by clicking Add License and entering your license
number in the Add License Key window. See “Licensing” for more information.

€ System Information: Click on System Information to generate a detailed report about the
configuration of your workstation. This report is saved as a text file named
Yourcomputername_Config.txt on your desktop.
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The PC-Duo Master Remote Desktop Window has the following tabs:

4 Select "Remote Control tab" to monitor activity, run applications remotely, and
troubleshoot Host computers using remote control.

@ Select "File Transfer tab" to quickly and securely transfer files between two computers
using the PC-Duo file transfer feature.

€ Select "Remote Printing tab" to print locally from applications you run on a remote
computer.

¢ Select "Remote Management tab" to send view information on hardware and software
resources on a remote computer, and to view/change system settings.

NOTE: Your remote control access rights for Gateway-managed or peer-to-peer
connections are determined by the credentials you use to make the connection. If your
administrator has restricted your access rights, remote control functionality may be
denied or limited.

& GATEWAY via SUPPORT - Master Connection

Jg::unnectiu:un Edit Miew Options Goko Help

BPBE O [HE0 | efvs 8a s |6

5%
Configurati. ..

r\.Remnte Control .f{. File Transfer ,]H. Rermate Printing ,]H. Reraote Management j‘

For Help, press F1 v

The following options are available for managing the Master Remote Desktop Window:
€ “Remote Desktop Window settings”

¢ “Menu options”
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Remote Control tab

Select the Remote Control tab on the Master Remote Desktop Window to view and
operate the remote Host computer as if you were its local user. Take control of the
mouse and keyboard, or simply monitor remote Host computer activity, without
interrupting a local user on the Host computer.

& GATEWAY via SUPPORT - Master Connection

chunnectil:nn Edit W¥iew Options Goto Help

BEEE © |BEneb| e a o e

r\.Remnte Control .f{. File Transfer ,]H. Rermate Printing ,]H. Reraote Management j‘

For Help, press F1 v

Control operations on the remote Host computer using the keyboard and mouse on your
local computer.

From the Remote Control tab, the following actions can be performed:
“Use CTRL-ALT-DEL and other special keys”

“Copy information to the remote clipboard”

“Copy information from the remote clipboard”

“Operate your mouse on the remote Host computer”

“‘Resize the Master Remote Desktop Window”

“Request/release input control”

“Open chat window”

“Capture a screen image from the Host computer display”

L ZBR JER JEE JER JEE 2N JEE 2R 2

“Copy text from the Host computer display”
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See “Menus for the Master Remote Desktop Window” for a summary of menu and tool
bar commands for carrying out these operations.

Tool bar options

Table below summarizes the functions of icons available on the tool bar when the Master
Remote Desktop Window is set to the Remote Control tab.

Icon Function
E Connects to the selected Host computer with the
Remote Control tab selected.

Connects to the selected Host computer with the File
Transfer tab selected.

Connects to the selected Host computer with the
Remote Printing tab selected.

@ | 2

Connects to the selected Host computer with the
Remote Management tab selected.

Closes Master Remote Desktop Window and
disconnects from Host computer.

o

Displays the screen output from the remote Host
computer using the entire monitor screen on the local
computer. To return to the local computer display, click
the Full Screen button on the floating palette, or press
F11 in the Master Remote Desktop Window.

[

Specifies that one pixel of the Host computer display
ﬁ corresponds to exactly one pixel on the display of the
local computer.

m Scales the image of the Host computer display to fit the
size of the Remote Desktop Window.

Sends a predefined key combination to the Host
computer as though it were entered on the keyboard of

] the remote Host computer when you are connected to
it for remote control. This is useful for sending special
key combinations such as CTRL-ALT-DEL.

— Gives keyboard and mouse control of the Host
computer to the remote user of a PC-Duo Gateway-
managed connection.

Toggles on or off View Only mode, which displays the
EAnh Host computer screen, but does not transmit keyboard
or mouse commands to it.

Copies the contents of the clipboard on the remote Host
] computer to the clipboard on your local computer when
" p p Y/ p
you view the Remote Control tab.
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Copies the contents of the clipboard on your local
ﬁ, computer to the clipboard on the remote Host computer
when you view the Remote Control tab.

Opens a Chat window in which text messages can be
= sent to Host and to any other Masters connected to that
Host.

Copies a selected region of the Host computer display
E: in the Master Remote Desktop Window to the clipboard
on your local computer from the Remote Control tab.

Displays the Remote Desktop Window Settings dialog,
which contains settings for the Remote Control tab.

Copy information to the remote clipboard

Transfer text, graphics, or other information from the clipboard on your local computer to
the clipboard on the Host computer.

To copy information to the remote clipboard:

1 Select the text or graphic on your local computer that you want to transfer to your Host
computer. For example, if you use a Paint program, you might select a portion of a
drawing you are making on your local computer.

&4 Panorama.bmp - Paint [_ [0 =]

File Edit Wiew Image Colors Help

B Panorama.psp [1:4] [Layerl) _ O]

oy
1
[P

0|0] /]| @¢]=||S]5

el (N e

|Fn:|r Help, click Help Tapics on the Help Menu, |16?JE=EI p:

Selection to transfer from local computer

2 Copy the information that you want to move to the Host computer to the clipboard on
your local computer; for example, use an application’s Cut or Copy command.

3 To transfer the information from the clipboard on the local computer to the clipboard
on your Host computer, return to the PC-Duo Master Remote Desktop Window and
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select Edit > Send Clipboard to Host. You can also click the Send Clipboard tool bar
button.

4 In the PC-Duo Master Remote Desktop Window, paste the text or graphic into an
application that you are running remotely on the Host computer.

= GATEWAY via SUPPORT - Master Connection [_ |0

Jg:unnecticun Edit Wiew Options Goto Help
EY BRI

[HEOebw e a e |
£d untitled - Paint [_ O] ]

File Edit “ew Image Colors Help

0y

5,
]
L3

m]|0|0|/]8]s|N]Q]%

-
1| | 5

llllllllllllll
enn (R CREEE

|F|:|r Help, click Help Topics on the Help Men| -

r\Remute Control ;{. File Transfer }-.. Fernate Printing }1. Fernote Managemen

For Help, press F1 4

Selection transferred to Host computer

Copy information from the remote clipboard

Transfer text, graphics, or other information, from the clipboard on the remote Host
computer to the clipboard on your local computer.

To copy information from the remote clipboard:

1 Select the text or graphic you want to transfer from an application running on your Host
computer. For example, if you are using a word processing program, you might select a
sentence or a paragraph that you want to transfer.

2 Copy the desired information to the clipboard on the Host computer. Most programs let
you copy information to the clipboard by choosing Edit > Copy or by pressing CTRL+C.
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3 Transfer the information from the clipboard on the Host computer to the clipboard on
your local computer by choosing Edit > Get Clipboard from Host, or by clicking the Get
Clipboard button on the tool bar.

4 Paste the text or graphic into an application running on your local computer.

NOTE: PC-Duo supports clipboard formats by value rather than by reference. The actual
data that you paste, such as text, must be in the clipboard. If the clipboard contains only
a reference to the data, such as a file name, PC-Duo displays a message that the
clipboard does not contain a supported format.

Operate your mouse on the remote Host computer
During remote control sessions, the mouse can exist in the following states:

€ When the mouse cursor is inside the PC-Duo Master Remote Desktop Window, the
mouse is remote and all movements and clicks are transmitted to the Host computer.

€ When the mouse cursor is anywhere else, the mouse is local and any mouse
operation affects your local Windows session only.

Fit-to-Window

The Fit-to-Window display option in the Master preserves the Host screen aspect ratio, and
centers the display in the available space. Also, text mode screen will be centered in available
space in all display modes.

2 SUPPORT via SUPPORT - Master Connection =] B3

Jgonnectinn Edit Wiew Options Goto Help

BB BE | © EEREE LI I

s SRV ST T
30N

Remote Control Fila Transker Rermote Printing Rermote Managerment

For Help, press F1 B8

112



Remote Desktop Window Operation

To improve the quality of display in Fit-to-Window mode, choose Options > Remote
Desktop Window Settings and select the Halfton checkbox.

Note: The Halftone option affects only the way the screen is rendered by the Master, and
may increase CPU usage on the Master.

Resize the PC-Duo Master Remote Desktop Window

Resize the PC-Duo Master Remote Desktop Window by dragging its border. When the
View > Fit 1-to-1 display option is used, you cannot resize the window larger than the Host
computer screen size. If you hold down the CTRL key when you resize the window, it
retains the aspect ratio of the Host computer display.

Request/release input control

When connected to a Host computer, two input control states are possible:
4 With input control, you control the mouse and keyboard of the Host.

4 Without input control, you monitor the Host computer but do not control it.

For a peer-to-peer connection, there can be only one Master connected to a Host. In this
case, you might want to toggle the state to have or not have input control of the Host.

For a Gateway-managed connection, multiple users can be connected to the same Host.
In this case, another user may request input control of the Host. Provided you have the
proper access control rights, you can request or relinquish input control to the other user.

Toggle the input control state by clicking an icon in the toolbar of the PC-Duo Master
Remote Desktop window. The icon you click depends on the type of connection you
have to the Host computer.

To toggle input control of a Host computer:
& For a peer-to-peer connection, click @

: %
& For a Gateway-managed connection, click 2 or choose Edit > Input Control from
the menu.

Open chat window

When connected to a chat-enabled Host (i.e. PC-Duo Host 11.2 or later), you will
automatically join a chat room including the Host end-user and any other Master users
connected to that host. A chat window can be opened to send and receive text messages

with the user at the Host machine by clicking on & icon on the tool bar. When you type
a text message and click Send, the message will be sent to a similar chat window on the
Host display. If the chat window is not already up on Host display, it will automatically be
started to display the message.

If you are using a Gateway-managed connection to the Host, and there are other PC-Duo
Master users connected to the same Host via the same Gateway, any text messages will
automatically be sent to all the other Master displays as well.

NOTE: Chat support requires that all components (Host, Master, Gateway) be version
11.2 or later.
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Capture a screen image from the Host computer display

All or part of the Host display can be captured and copied to the clipboard on your local
computer. After copying a region of the Host computer display, paste the image into a
document or image processing application that you have running on your local computer.

To copy screen images to the clipboard on your local computer, follow these steps:
1 From the Remote Control tab of the PC-Duo Master Remote Desktop Window,
choose Edit > Copy Graphics Screen or click the r— icon on the tool bar. The cursor

changes to a top left corner angle icon r— to indicate where to place the first anchor of
the selection.

2 Move to the top left corner of the rectangle to the top left corner of the graphic or
region of the screen that you wish to copy and hold down the left mouse button at that
location.

3 While holding down the left mouse button, drag the cursor to the bottom right corner of
the region you want to capture. As you move your mouse, the area you select is indicated
visually on the screen.

4 When you have selected the area you want, release the mouse button.

The captured graphic is copied to the clipboard on your local computer and you can
paste the image into a graphics or word processing document.

Copy text from the Host computer display

When the Host computer is operating in full-screen text mode, copy text from your remote
Host computer to the system clipboard of your local computer. To do so, follow these
steps:

1 From the Remote Control tab of the PC-Duo Master Remote Desktop Window,
choose Edit > Copy Text Screen. The cursor changes its shape to indicate that you can
start selecting text.

2 Use your mouse to select the text that you want to capture from the Host computer.

3 When you select the text, the copy text mode is complete and the text is copied into
the clipboard on your local computer. You can paste it into any application you open on
your local computer.

Use CTRL-ALT-DEL and other special keys on the remote
computer

Send special key combinations that would normally be intercepted by your local computer
to the remote computer. To send a key combination to the Host computer, select Edit >
Send Keystroke from the PC-Duo Master Remote Desktop Window., and then select the
key combination.

For example, select Edit > Send Keystroke > Remote Alt+Ctrl+Del to send CTRL-ALT-DEL t0
your Host computer.

Special key combinations are also interpreted by the Host according to the values that
you specify in the PC-Duo Master console window when you select Options > Keyboard
Mapping. For more information, see “Keyboard Mapping”.
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File Transfer tab

Use the File Transfer tab on the Master Remote Desktop Window to transfer files
between your local computer and the remote Host computer. Other file maintenance
tasks can be performed on either computer.

& "File transfer resume"

€ "Manipulate files and folders for file transfer"

& GATEWAY via SUPPORT - Master Connection [_ (O]

J_n:nnnectin:nn Wiew Opkions Goko Help

[ BEE e Q |9 X|aED

chTEMParaphicss”.” o hbemnph
 LOCAL «| [J REMOTE i!l
EI--L«_--|I Laocal Disk [C:] % Local Disk [C:]
=) TEMP =57 temp
L mraphics LI S lll
Mame | a
background.brp 4 g
check_s.brmp evalCerts. ene

client_authenticated.ico i=| | MWE.bmp -
4] | ’ 1] | »

I\- Remote Control hFile Transfer lf'-r.. Femate Printing }-.. Femnobe Managemeant j‘

For Help, press F1 |C|:|nnecting remaoke col

The file transfer display is split into four adjustable panels. By default, files for your local
computer are on the left, and those for your remote Host computer are on the right. The
following defaults apply:

€ The top left panel displays the folder hierarchies on the local computer. Use these
panels to browse your local and remote directories to select folders.

€ Atext field at the top of the tab, one for the left side and another for the right, indicates
the full path name of the currently open or selected folder. Use this text field to navigate
directly to a specific location on a local or remote file system.

€ The bottom left panel shows the files in any folder that you select in the top left panel.
Follow these steps to transfer files between the local and remote computers:

1 From files located on the lower panel of the File Transfer tab, select one or more files to
be transferred:

+ Select from the left side if you plan to transfer files from your local Master
computer to the remote Host computer.

+ Select from the right side if you plan to transfer files from the remote Host
computer to your local Master computer.

115



PC-Duo Master Guide

2 Select a target folder on the local or remote computer from the top panel. This is the
computer to which you plan to transfer files.

3 Drag and drop the files from your source to your target directory, or right-click the
selected files you plan to transfer:

€ Select Get to transfer files from the Host computer to the local computer. Selected files
are copied from the Host computer to the directory you select in the upper panel of the
local computer directory listing.

€ Select Put to transfer files from the local computer to the Host computer. Selected files
are copied from the local computer to the directory you select in the upper panel of the
Host computer directory listing.

Tool bar options

Table below summarizes the functions of icons available on the tool bar when the Master
Remote Desktop Window is set to the File Transfer tab.

Icon Function
E Connects to the selected Host computer with
the Remote Control tab selected.

Connects to the selected Host computer with
the File Transfer tab selected.

Connects to the selected Host computer with
the Remote Printing tab selected.

B | o

Connects to the selected Host computer with
the Remote Management tab selected.

Closes Master Remote Desktop Window and
disconnects from Host computer.

Get selected file or folder from the other
directory.

Put selected file or folder in the other directory.

X| &+ 4| ©

Deleted selected file or folder.

Eji Create a new directory or subdirectory.

[Es Move selected file or folder to a new folder on
the same computer.

Rename selected file or folder.
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File transfer resume

Occasionally while transferring files, your connection may be interrupted, leaving some
files only partially transferred. If the files are large, retransmitting them from the beginning
again could prove very expensive. For this reason, PC-Duo Master provides a File
transfer resume feature, which allows you to resume interrupted transfers exactly where
you left off.

After a connection is interrupted (or if you manually cancel an in-process transfer), the
next time you connect to the same Host and select the File Transfer tab in the Remote
Desktop Window, PC-Duo Master scans both the local machine and the remote Host
machine for records of interrupted file transfers. The list of any such resumable file
transfers is then automatically presented in the Confirm Copy Resume window:

Confirm Copy Resume !EI |

The Following files were in progress, Select those you wish to resume
and click "Resume", ar dlick "Cancel” to discard:

68% [ ci\Documents and Settingsiadnin.doc
r
r
r

Resume Cancel

File transfer resume - Confirm Copy Resume dialog

Check or uncheck each file you wish to resume, and then click the Resume button. At that
point, file transfers for the selected files are resumed, and the transfers will run either to
completion, or until the connection is again interrupted.

File transfers for any files that you uncheck will not be resumed, and their partial contents
will be discarded. Also if you click Cancel instead of Resume, all partial contents will be
discarded, and the record of those transfers will be deleted. Thus you have only one
chance to resume a set of interrupted transfers.

NOTE: PC-Duo Master does not resume the transfer of an entire directory or directory
tree, only the individual files that were in process at the time the connection was lost.

NOTE: PC-Duo Master only allows transfers in one direction or the other (to or from the
Host) at a time, so the list of resumable file transfers will always consist of only files to be
sent to the Host, or only files to be received from the Host. PC-Duo Master does maintain
a separate list of resumable file transfers for each Host.

Manipulate files and folders for file transfer
The following file and folder information is listed on the File Transfer tab:

& The top panels display the folder hierarchy, but only reveal the contents of the nodes
of the tree that you explicitly open.
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€ No files appear in the top panels, nor do any folders appear in any bottom panels.

& A drive, folder, or one or more files must be selected before you can perform most file
transfer operations.

When you double-click a computer, drive or folder, a list of all of the folders (or devices)
that it contains displays in the top panel. The single files are listed in the bottom panel.
Display the files within any folder by selecting the folder in the top panel and choosing the
List Directory command from the right-click menu.

€ Use standard Windows mouse and keyboard controls to browse your directory
listings.

& Perform the following directory organization tasks on either computer by right-clicking
one or more files or a folder, and selecting one of the following commands:

+ Delete - to delete selected files or folders.

+ Rename - to rename files or folders.

+ Create Directory - to create folders by entering the folder path.
+ Move - to move files or folders by entering the folder path.

+ Copy - to copy files or folders by entering the folder path.
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Remote Printing tab

Print remote applications on printers local to your machine using the Remote Printing tab
on the Master Remote Desktop Window. An active remote control connection must be
maintained between the Host computer and the local computer to complete the remote
printing process.

4 "Configure a Host computer for printing"
4 "Configure a local computer for printing"
€ "Print your remote printing job"
2

"Cancel a remote print job"

~E GATEWAY via SUPPORT - Master Connection [_ (O]

Jgn:nnnecti-:nn Wigw Options Goka Help

Y )
Localpivter [ RRRNERORRSRR ~

Drriseer:
Part;

Status: Connected to SUPFPORT
Currently printing:

Total pages:
Cancel Jab I

Rernote Control .Ih File Tramsher hRemnte Printing lﬂr

For Help, press F1 o

Tool bar options

Table below summarizes the functions of icons available on the tool bar when the Master
Remote Desktop Window is set to the Remote Printing tab.

Icon Function
E Connects to the selected Host computer with
the Remote Control tab selected.

E Connects to the selected Host computer with
the File Transfer tab selected.
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% Connects to the selected Host computer with
the Remote Printing tab selected.

Connects to the selected Host computer with
= the Remote Management tab selected.

a Closes Master Remote Desktop Window and
disconnects from Host computer.

Configure a Host computer for printing

After you install PC-Duo Host, a printer port named PC-Duo: is listed in Windows as a
port that can be associated with a printer when you select Start > Control Panel > Printers
and Faxes. To print from a remote application to a printer that is accessible from your
local computer, the Host computer must have the following:

& A print driver that is compatible with the local printer must be installed.
€ The driver must be associated with the PC-Duo: port.

For optimal results, you should select the same printer as the one you use for local print
jobs.

NOTE: You must install a printer driver and associate it with the PC-Duo: printer port on
your local computer before using this service. See the PC-Duo Host Guide for more
details.

Configure a local computer for printing
The following options are available for remote printing:

@ Select a local printer from the Local printer drop-down list. Make sure that you select
the local printer of the same type whose driver you map to the PC-Duo port of your
remote Host computer.

4 View information about a current print job.

& Cancel current print job.

Print your remote printing job

Once you configure the Host and local computers for printing, you can perform remote
printing any time you establish a remote connection.

Note the following:

€ To execute a print job from a remote application, use the printing option associated
with that application when you are connected to it on the remote Host computer.

€ Make sure that the printer that you select for the remote print job is the same one that
you map to the PC-Duo port of your remote Host computer.

€ Your print job is routed to the local printer that you select on your local computer using
the Local printer drop-down list on the Remote Printing tab of the PC-Duo Master Remote
Desktop Window.

Cancel aremote print job
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To cancel a current remote print job, click Cancel Job on the Remote Printing tab of the
PC-Duo Master Remote Desktop window. This clears the print queues on both the
local and Host computers. Canceling a print job does not affect your connection.

However, if you disconnect your connection to the Host computer, any active print job is
cancelled.
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Remote Management tab

Use the Remote Management tab on the Master Remote Desktop Window to view and
manage information about hardware, software, system settings, services, processes,

events and more on the remote Host computer.

“Hardware Manager”
“Software Manager”
“System Manager”

“Shared Resource Manager”
“Account Manager”

“Service Manager”

“Process Manager”
“Registry Manager”

“Event Manager”

® 6 6 O 6 O 6 O 0o

“Power Manager”

=g Master

Jg::unnectinn Wiew Options Goto Help

B EE)

El- -j Remate Computer Managemenk
7, Hardware Manager
Software Manager
Swystem Manager

Shared Resource Manager
g Account Manager

- Service Manager

-- Process Manager

! Registry Manager

-- E'vent Manager

j Power Manager

[l - - -

Remote Computer Management

Marne

Hardware
@ Syskem Manager

m.ﬁ.cmunt Manager
@Service Manager
P'n:u:ess Manager
_! Registry Manager
Event Manager
j Power Manager

Rernote Control .Ih File Tramsher .Ih Rernote Printing hRemnte Management I.Jr

%Snftware Manager

E? Shared Resource Manager

For Help, press F1
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NOTE: PC-Duo uses Microsoft Windows Management Instrumentation (WMI) to request,
receive and modify management information on the remote Host computer. Because PC-
Duo uses secure connection to transport WMI commands and information, PC-Duo
Remote Management does not require RPC (Remote Procedure Call) or file/print sharing
to be enabled on the remote Host computer in order to operate.

NOTE: If the Master cannot find the redistributable MSXML6 system component, an error
message will appear in the Remote Management window. In this case, you must install
MSXML6 and restart the Master. See http://www.microsoft.com for more information
about the redistributable msxml6.msi package.

Tool bar options

Table below summarizes the functions of icons available on the tool bar when the Master
Remote Desktop Window is set to the Remote Management tab.

Icon Function
E Connects to the selected Host computer with
the Remote Control tab selected.

Connects to the selected Host computer with
the File Transfer tab selected.

Connects to the selected Host computer with
the Remote Printing tab selected.

B |

Connects to the selected Host computer with
the Remote Management tab selected.

Closes Master Remote Desktop Window and
disconnects from Host computer.

o

Refresh result pane by resending WMI
command to selected Host computer.

=

Transpose columns and rows in result pane.

o Filter:Basic shows limited set of attributes and
values for any selected component.

Filter:Default shows a default set of attributes
and values for any selected component.

— Filter:All shows full set of attributes and values
for any selected component.

Hardware Manager

Hardware Manager provides you with a graphical view of physical devices and resources
available on the remote Host computer.
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=% Master

Jg:-nnectin:nn Wigw Options Goko Help

Y EEa)

=1~ J Remoke Computer Management
"M Hardware Manager
wey S0fbware Manager
[@] Swstemn Manager
= shared Resource Manager
g Account Manager
Service Manager
Process Manager
! Reqgistry Manager
Ewvent Manager
[+ iy Power Manager

Hardware Manager

Mame

BIOS
j Bus
< Cache Memary
s COROM Drive

W P

“a Logical Disk,

% Logical Disk Changes
G Memory Devices
Maodern

& Mebwork Adapter Configuration
E Metwork Adapters
U PCMCTA Devices

e Phyysical Disk,

< Physical Memory

__2 Prinker

ol

.ﬁ System Enclosure
& USE Ports

Yideo Controller

E' Yideo Monitor

Rermate Contral h File Tranzker h Femate Printing hRemute Management {r

For Help, press F1

€ Select "BIOS" to view details about Basic Input/Output System (BIOS) on remote Host

computer.

€ Select "Bus" to view details about the physical system bus on remote Host computer.

€ Select "Cache Memory" to view details about internal and external cache memory on

the remote Host computer.

& Select "CDROM Drive" to view details about the CDROM drive on the remote Host

computer.

€ Select "CPU" to view details about the CPU(s) on the remote Host computer.

€ Select "Logical Disk" to view details about data source(s) that resolve to actual local

storage device(s) on the remote Host computer.

€ Select "Logical Disk Changes" to view details about network storage devices that are

mapped as logical disks on the remote Host computer.

@ Select "Memory Devices" to view details about memory devices on the remote Host

computer .
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€ Select "Modem" to view details about any POTS (Plain Old Telephone Service)
modems on the remote Host computer.

€ Select "Network Adapter Configuration" to view details about extra properties and
methods that support the management of the TCP/IP and Internetwork Packet Exchange
(IPX) protocols that are independent from the network adapters on the remote Host
computer.

€ Select "Network Adapters" to view details about network adapters on the remote Host
computer.

& Select "PCMCIA Devices" to view details about PCMCIA devices on the remote Host
computer.

€ Select "Physical Disk" to view details about physical disk drives on the remote Host
computer.

€ Select "Physical Memory" to view details about for physical memory on the remote Host
computer.

€ Select "Printer" to view details about for printers connected to the remote Host
computer.

€ Select "SCSI" to view details about SCSI devices connected to the remote Host
computer.

€ Select "System Enclosure" to view details about the system enclosure for the remote
Host computer.

& Select "USB Ports" to view details about the universal serial bus for the remote Host
computer.

€ Select "Video Controller" to view details about the video controller on the remote Host
computer.

€ Select "Video Monitor" to view details about the video monitor connected to the remote
Host computer.

BIOS

BIOS provides you with a graphical view of settings for the BIOS running on the remote
Host computer system.

BIOS has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

. Name

° BIOS Characteristics
° BIOS Version

° Build Number

] Caption

] Code Set

. Current Language
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] Description
° Identification Code
] Installable Languages
° Language Date
° List of Languages
] Manufacturer
J Other Target OS
° Primary BIOS
o Release Date
] Serial Number
J SMBIOS BIOSVersion
J SMBIOS Major Version
J SMBIOS Minor Version
] SMBIOS Present
L Software Element ID
L Software Element State
. Status
o Target Operating System
L Version
WMI Class

PC-Duo uses the following WMI Class to request/retrieve BIOS information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class
BIOS Win32_BIOS
Bus
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Bus provides you with a graphical view of settings for the bus on the remote Host
computer system.

Bus has the following attributes (double-click on any attribute to get a popup window with
table of attributes and values):

Name

Bus Type

Device ID

System Name

Description

Availability

Bus Num

Caption

Config Manager Error Code
Config Manager User Config
Creation Class Name

Error Cleared

Error Description

Install Date

Last Error Code

PNP Device ID

Power Management

Capabilities

WMI Class

Power Management Supported
Status
Status Info

System Creation Class Name

PC-Duo uses the following WMI Class to request/retrieve Bus information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.
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Component WMI Class

Bus Win32_Bus

Cache Memory

Cache Memory provides you with a graphical view of settings for internal and external
cache memory on the remote Host computer system.

Cache Memory has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Name

. Block Size

J Installed Size

J Max Cache Size

J Device ID

° Cache Type

L Number of Blocks

L Cache Speed

° Install Date

. Location

. System Name

° Write Policy

° Access

° Additional Error Data

. Associativity

° Availability

L Caption

° Config Manager Error Code
° Config Manager USer Config
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. Correctable Error

° Creation Class Name

Current SRAM
Description
Ending Address

Error Access

] Error Address

] Error Cleared

° Error Correct Type
° Error Data

o Error Data Order

° Error Description

° Error Info

L Error Methodology

J Error Resolution

J Error Time

. Error Transfer Size
° Flush Timer

L Last Error Code

° Level

° Line Size

] Other Error Description
° PNP Device ID

. Power Management
Capabilities

° Power Management Supported
. Purpose

° Read Policy

. Replacement Policy

Remote Desktop Window Operation
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° Starting Address
o Status
° Status Info
J Supported SRAM
. System Creation Class Name
J System Level Address
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Cache Memory information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class
Cache Memory Win32_CacheMemory
CDROM Drive

CDROM Drive provides you with a graphical view of settings for the CDROM drive on the
remote Host computer system.

CDROM Drive has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Availability

] Capabilities

° Capability Descriptions

. Caption

. Compression Method

° Config Manager Error Code
° Config Manager User Config
] Creation Class Name

L Default Block Size
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Description

Device ID

Drive

Drive Integrity

Error Cleared

Error Description

Error Methodology

File System Flags

File System Flags Ex

ID

Install Date

Last Error Code
Manufacturer

Max Block Size

Maximum Component Length
Max Media Size

Media Loaded

Media Type

Mfr Assigned Revision Level
Min Block Size

Name

Needs Cleaning

Number of Media Supported
PNP Device ID

Power Management

Capabilities

Power Management Supported
Revision Level

SCST Bus

Remote Desktop Window Operation
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] SCSI Logical Unit

] SCSI Port

° SCSI Target ID

J Serial Number

J Size

J Status

] Status Info

. System Creation Class Name

° System Name

° Transfer Rate

J Volume Name

J Volume Serial Number
WMI Class

PC-Duo uses the following WMI Class to request/retrieve CDROM Drive information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component WMI Class
CDROM Drive Win32_CDROMDrive
CPU

CPU provides you with a graphical view of settings for the CPU(s) on the remote Host
computer system.

Each CPU has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Name

° Processor Type
° Version

° CPU Status
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Current Clock Speed
Address Width

Architecture

Availability

Caption

Config Manager Error Code
Config Manager User Config
Creation Class Name
Current Voltage

Data Width

Description

Device ID

Error Cleared

Error Description

Ext Clock

Family

Install date

L2 Cache Size
L2 Cache Speed
L3 Cache Size
L3 Cache Speed
Last Error Code
Level

Load Percentage
Manufacturer

Max Clock Speed

Number of Cores

Remote Desktop Window Operation

Number of Logical Processors

Other Family Description
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J PNP Device ID
° Power Management
Capabilities
° Power Management Supported
o Processor ID
o Revision
] Role
° Socket Designation
J Status
L Status Info
J Stepping
° Status Info
° System Creation Class Name
° System Name
] Unique ID
J Upgrade Method
° Voltage Caps
WMI Class

PC-Duo uses the following WMI Class to request/retrieve CPU information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class
CPU Win32_CPU
Logical Disk

Logical Disk provides you with a graphical view of settings for data source(s) that resolve
to actual local storage device(s) on the remote Host computer system.

Logical Disk has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):
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Name

Description

Media Type

Free Space

Total Size

File System

Install Date

System Name

Status Info

Purpose

Access

Availability

Block Size

Caption

Compressed

Config Manager Error Code
Config Manager USer Config
Creation Class Name

Device ID

Drive Type

Error Cleared

Error Methodology

Last Error Code

Maximum Component Length
Number of Blocks

PNP Device ID

Power Management Capabilities
Power Management Supported

Provider Name
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WMI Class

Quotas Disabled

Quotas Incomplete

Quotas Rebuilding

Status

Supports Disk Quotas

Supports File Based Compression

System Creation Class Name

Volume Dirty

Volume Name

Volume Serial Number

PC-Duo uses the following WMI Class to request/retrieve Logical Disk information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component

WMI Class

Logical Disk

Win32_LogicalDisk

Logical Disk Changes

Logical Disk Changes provides you with a graphical view of settings for network storage
devices that are mapped as logical disks on the remote Host computer system.

Logical Disk Changes has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):
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Config Manager Error Code
Config Manager User Config
Creation Class Name
Description

Device ID

Error Cleared

Error Description

Error Methodology

File System

Free Space

Install Date

Last Error Code

Maximum Component Length
Name

Number of Blocks

PNP Device ID

Power Management Capabilities
Power Management Supported
Provider Name

Purpose

Quotas Disabled

Quotas Incomplete

Quotas Rebuilding

Session ID

Size

Status

Status Info

Supports Disk Quotas

Supports File Based Compression
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° System Creation Class Name
° System Name
. Volume Name
J Volume Serial Number
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Logical Disk Changes
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component WMI Class

Logical Disk

Changes Win32_MappedLogicalDisk

Memory Devices

Memory Devices provides you with a graphical view of settings for memory devices on
the remote Host computer system.

Memory Devices has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Access

° Additional Error Data

° Availability

. Block Size

] Caption

L Config Manager Error Code
° Config Manager User Config
L Correctable Error

] Creation Class Name

L Description

o Device ID
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Ending Address

Error Access

Error Address

Error Cleared

Error Data

Error Data Order

Error Description

Error Granularity

Error Info

Error Methodology

Error Resolution

Error Time

Error Transfer Size
Install Date

Last Error Code

Name

Number of Blocks

Other Error Description
PNP Device ID

Power Management Capabilities
Power Management Supported
Purpose

Starting Address

Status

Status Info

System Creation Class Name
System Level Address

System Name
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WMI Class

PC-Duo uses the following WMI Class to request/retrieve Memory Device information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class
Memory Devices Win32_MemoryDevice
Modem

Modem provides you with a graphical view of settings for any POTS (Plain Old
Telephone Service) modems on the remote Host computer system.

Modem has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

o Answer Mode

o Attached To

° Availability

. Blind Off

o Blind On

. Caption

. Compatibility Flags

. Compression Info

. Compression Off

. Compression On

° Config Manager Error Code
° Config Manager User Config
] Configuration Dialog
° Countries Supported]]
L Country Selected

] Creation Class Name

] Current Passwords]]

. DCB[]

] Default[]

L Description

o Device ID

° Device Loader
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Device Type

Dial Type

Driver Date

Error Cleared

Error Control Forced
Error Control Info
Error Control Off

Error Control On

Error Description

Flow Control Hard

Flow Control Off

Flow Control Soft
Inactivity Scale
Inactivity Timeout
Index

Install Date

Last Error Code

Max Baud Rate To Phone
Max Baud Rate To Serial Port
Max Number Of Passwords
Model

Modem Inf Path

Modem Inf Section
Modulation Bell
Modulation CCITT
Modulation Scheme

Name

PNP Device ID

Port Sub Class

Power Management Capabilities[]
Power Management Supported
Prefix

Properties|]

Provider Name

Pulse

Reset

Responses Key Name
Rings Before Answer

Speaker Mode Dial
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o Speaker Mode Off
J Speaker Mode On
J Speaker Mode Setup
° Speaker Volume High
J Speaker Volume Info
J Speaker Volume Low
o Speaker Volume Med
o Status
° Status Info
] String Format
o Supports Callback
° Supports Synchronous Connect
] System Creation Class Name
] System Name
J Terminator
J Time Of Last Reset
° Tone
o Voice Switch Feature
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Modem information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class

Modem Win32_POTSModem

Network Adapter Configuration

Network Adapter Configuration provides you with a graphical view of settings for extra
properties and methods that support the management of the TCP/IP and Internetwork
Packet Exchange (IPX) protocols that are independent from the network adapters on the
remote Host computer system.

Network Adapter Configuration has the following attributes (double-click on any attribute
to get a popup window with table of attributes and values):
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Arp Always Source Route

Arp Use Ether SNAP

Caption

Database Path

Dead GW Detect Enabled
Default IP Gatewayl[]

Default TOS

Default TTL

Description

DHCP Enabled

DHCP Lease Expires

DHCP Lease Obtained

DHCP Server

DNS Domain

DNS Domain Suffix Search Order[]
DNS Enabled For WINS Resolution
DNS Host Name

DNS Server Search Order|[]
Domain DNS Registration Enabled
Forward Buffer Memory

Full DNS Registration Enabled
Gateway Cost Metric[]

IGMP Level

Index

Interface Index

IP Address/[]

IP Connection Metric

IP Enabled

IP Filter Security Enabled

IP Port Security Enabled
IPSec Permit IP Protocols][]
IPSec Permit TCP Ports|[]
IPSec Permit UDP Ports/[]

IP Subnet[]

IP Use Zero Broadcast

IPX Address

IPX Enabled

IPX Frame Typel]

IPX Media Type
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WMI Class

PC-Duo uses the following WMI Class to request/retrieve Network Adapter Configuration
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

IPX Network Number[]

IPX Virtual Net Number

Keep Alive Interval

Keep AliveT ime

MAC Address

MTU

Num Forward Packets

PMTUBH Detect Enabled

PMTU Discovery Enabled
Service Name

Setting ID

Tcpip Netbios Options

Tcp Max Connect Retransmissions
Tcp Max Data Retransmissions
Tcp Num Connections

Tcp Use RFC1122 Urgent Pointer
Tcp Window Size

WINS Enable LM Hosts Lookup
WINS Host Lookup File

WINS Primary Server

WINS Scope ID

WINS Secondary Server

Component

WMI Class

Network Adapter
Configuration

Network Adapters

Network Adapters provides you with a graphical view of settings for network adapters on

the remote Host computer system.

Network Adapters has the following attributes (double-click on any attribute to get a

popup window with table of attributes and values):
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Adapter Type
Adapter Type ID
Auto Sense
Availability
Caption

Config Manager Error Code

Config Manager User Config

Creation Class Name
Description

Device ID

Error Cleared

Error Description
GUID

Index

Install Date
Installed

Interface Index
Last Error Code

MAC Address
Manufacturer

Max Number Controlled
Max Speed

Name

Net Connection ID
Net Connection Status
Net Enabled

Network Addresses]|]
Permanent Address
Physical Adapter
PNP Device ID

Remote Desktop Window Operation

Power Management Capabilities[]

Power Management Supported

Product Name
Service Name
Speed
Status
Status Info

System CreationClass Name
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° System Name
° Time Of Last Reset
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Network Adapter information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class

Network Adapters Win32_NetworkAdapter

PCMCIA Devices

PCMCIA Devices provides you with a graphical view of settings for PCMCIA devices on
the remote Host computer system.

PCMCIA Devices has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Availability

J Caption

° Config Manager Error Code
. Config Manager User Config
. Creation Class Name

. Description

° Device ID

° Error Cleared

J Error Description

° Install Date

] Last Error Code

° Manufacturer

° Max Number Controlled

. Name

° PNP Device ID

] Power Management Capabilities[]
° Power Management Supported
° Protocol Supported

° Status
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° Status Info
. System Creation Class Name
. System Name
° Time Of Last Reset
WMI Class

PC-Duo uses the following WMI Class to request/retrieve PCMCIA information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class
PCMCIA Devices Win32_PCMCIAController
Physical Disk

Physical Disk provides you with a graphical view of settings for physical disk drives on
the remote Host computer system.

Physical Disk has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Availability

° Bytes Per Sector

° Capabilities[]

° Capability Descriptions]|]
] Caption

] Compression Method

° Config Manager Error Code
. Config Manager User Config
. Creation Class Name

. Default Block Size

. Description

o Device ID

° Error Cleared

° Error Description

° Error Methodology

° Firmware Revision

° Index
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° Install Date
J Interface Type
] Last Error Code
] Manufacturer
J Max Block Size
J Max Media Size
. Media Loaded
L Media Type
. Min Block Size
] Model
. Name
° Needs Cleaning
J Number Of Media Supported
J Partitions
J PNP Device ID
° Power Management Capabilities[]
° Power Management Supported
J SCSI Bus
] SCSI Logical Unit
] SCSI Port
° SCSI Target Id
° Sectors Per Track
L Serial Number
J Signature
. Size
o Status
° StatusInfo
. System Creation Class Name
. System Name
° Total Cylinders
° Total Heads
L Total Sectors
. Total Tracks
J Tracks Per Cylinder
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Physical Disk information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.
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Component WMI Class

Physical Disk Win32_DiskDrive

Physical Memory

Physical Memory provides you with a graphical view of settings for physical memory on
the remote Host computer system.

Physical Memory has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

] Bank Label

. Capacity

. Caption

J Creation Class Name
° Data Width

] Description

o Device Locator

° Form Factor

J Hot Swappable

L Install Date

L Interleave Data Depth
. Interleave Position
° Manufacturer

° Memory Type

. Model

. Name

] Other Identifying Info
° Part Number

° Position In Row

] Powered On

° Removable

° Replaceable

] Serial Number

] SKU

° Speed

° Status

° Tag

° Total Width
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] Type Detail
° Version
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Physical Memory information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class
Physical Memory Win32_PhysicalMemory
Printer

Printer provides you with a graphical view of settings for printers connected to the remote
Host computer system.

Printer has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

J Attributes

J Availability

o Available Job Sheets][]

J Average Pages Per Minute
° Capabilities[]

° Capability Descriptions|]
] Caption

° Char Sets Supported]]

. Comment

° Config Manager Error Code
. Config Manager User Config
. Creation Class Name

° Current Capabilities]]

] Current Char Set

° Current Language

] Current Mime Type

° Current Natural Language
o Current Paper Type

. Default

o Default Capabilities]]
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Default Copies

Default Language
Default Mime Type
Default Number Up
Default Paper Type
Default Priority
Description

Detected Error State
Device ID

Direct

Do Complete First
Driver Name

Enable BIDI

Enable Dev Query Print
Error Cleared

Error Description

Error Information]]
Extended Detected Error State
Extended Printer Status
Hidden

Horizontal Resolution
Install Date

Job Count Since Last Reset
Keep Printed Jobs
Languages Supportedl[]
Last Error Code

Local

Location

Marking Technology

Max Copies

Max Number Up

Max Size Supported

Mime Types Supportedl]
Name

Natural Languages Supported][]
Network

Paper Sizes Supported[]
Paper Types Available[]

Parameters
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WMI Class

PNP Device ID

Port Name

Power Management Capabilities(]
Power Management Supported
Printer Paper Names]|]
Printer State

Printer Status

Print Job Data Type

Print Processor

Priority

Published

Queued

Raw Only

Separator File

Server Name

Shared

Share Name

Spool Enabled

Start Time

Status

Status Info

System Creation Class Name
System Name

Time Of Last Reset

Until Time

Vertical Resolution

Work Offline

PC-Duo uses the following WMI Class to request/retrieve Printer information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class
Printer Win32_Printer
SCSI
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SCSI provides you with a graphical view of settings for SCSI devices connected to the
remote Host computer system.

SCSI has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

° Availability
° Caption
] Config Manager Error Code
L Config Manager User Config
° Controller Timeouts
L Creation Class Name
] Description
J Device ID
J Device Map
J Driver Name
L Error Cleared
J Error Description
J Hardware Version
J Index
o Install Date
J Last Error Code
J Manufacturer
J Max Data Width
° Max Number Controlled
. Max Transfer Rate
° Name
. PNP Device ID
J Power Management Capabilities|]
. Power Management Supported
. Protection Management
L Protocol Supported
° Status
° Status Info
L System Creation Class Name
° System Name
° Time Of Last Reset
WMI Class
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PC-Duo uses the following WMI Class to request/retrieve SCSI information from the
remote Host computer. Please consult this class for more detailed information about the

specific attributes and values available.

Component

WMI Class

SCSI

System Enclosure

System Enclosure provides you with a graphical view of settings for the system enclosure

for the remote Host computer system.

System Enclosure has the following attributes (double-click on any attribute to get a

popup window with table of attributes and values):

154

Audible Alarm

Breach Description
Cable Management Strategy
Caption

Chassis Types][]
Creation Class Name
Current Required Or Produced
Depth

Description

Heat Generation

Height

Hot Swappable

Install Date

Lock Present
Manufacturer

Model

Name

Number Of Power Cords
Other Identifying Info
Part Number

Powered On

Removable

Replaceable

Security Breach

Security Status

Win32_SCSIController
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] Serial Number
. Service Descriptions][]
° Service Philosophy[]
° SKU
. SMBIOS Asset Tag
J Status
° Tag
L Type Descriptions]]
] Version
] Visible Alarm
° Weight
o Width
WMI Class

PC-Duo uses the following WMI Class to request/retrieve System Enclosure information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class
System Enclosure Win32_SystemEnclosure
USB Ports

USB Ports provides you with a graphical view of settings for the universal serial bus for
the remote Host computer system.

USB Ports has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Availability

. Caption

] Config Manager Error Code
° Config Manager User Config
J Creation Class Name

] Description

° Device 1ID

. Error Cleared

] Error Description

. Install Date
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° Last Error Code
] Manufacturer
] Max Number Controlled
° Name
J PNP Device ID
. Power Management Capabilities(]
° Power Management Supported
] Protocol Supported
o Status
° Status Info
° System Creation Class Name
° System Name
° Time Of Last Reset
WMI Class

PC-Duo uses the following WMI Class to request/retrieve USB information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class

USB Ports Win32_USBController

Video Controller

Video Controller provides you with a graphical view of settings for the video controller on
the remote Host computer system.

Video Controller has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

. Accelerator Capabilities|]
° Adapter Compatibility

] Adapter DAC Type

] Adapter RAM

° Availability

° Capability Descriptions|]

L Caption

] Color Table Entries

. Config Manager Error Code
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Config Manager User Config
Creation Class Name

Current Bits Per Pixel
Current Horizontal Resolution
Current Number Of Colors
Current Number Of Columns
Current Number Of Rows
Current Refresh Rate
Current Scan Mode

Current Vertical Resolution
Description

Device ID

Device Specific Pens

Dither Type

Driver Date

Driver Version

Error Cleared

Error Description

ICM Intent

ICM Method

Inf Filename

Inf Section

Install Date

Installed Display Drivers
Last Error Code

Max Memory Supported

Max Number Controlled

Max Refresh Rate

Min Refresh Rate

Monochrome

Name

Number Of Color Planes
Number Of Video Pages

PNP Device ID

Power Management Capabilities[]
Power Management Supported
Protocol Supported

Reserved System Palette Entries

Specification Version
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WMI Class

Status

Status Info

System Creation Class Name
System Name

System Palette Entries
Time Of Last Reset

Video Architecture

Video Memory Type

Video Mode

Video Mode Description

Video Processor

PC-Duo uses the following WMI Class to request/retrieve Video Controller information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component

WMI Class

Video Controller Win32_VideoController

Video Monitor

Video Monitor provides you with a graphical view of settings for the video monitor
connected to the remote Host computer system.

Video Monitor has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):
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Availability

Bandwidth

Caption

Config Manager Error Code
Config Manager User Config
Creation Class Name
Description

Device 1ID

Display Type

Error Cleared

Error Description
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° Install Date
] Is Locked
] Last Error Code
J Monitor Manufacturer
° Monitor Type
° Name
] Pixels Per X Logical Inch
] Pixels Per Y Logical Inch
° PNP Device ID
L Power Management Capabilities[]
° Power Management Supported
° Screen Height
J Screen Width
] Status
L Status Info
] System Creation Class Name
] System Name
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Video Monitor information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component WMI Class

Video Monitor Win32_DesktopMonitor

Software Manager

Software Manager provides you with a graphical view of the software applications that
are installed on the remote Host computer.
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Adobe AIR
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Rernote Control h File Tramsker h Rernote Printing hRemute Management lr'r

For Help, press F1
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Each software application has the following attributes (double-click on any service to get
a popup window with table of attributes and values):

J Identifying Number
. Product Name

° Manufacturer

° Product Version

° File Path

° Assignment Type

] Caption

] Description

. Install Date and Time
o Install State

. Help Link

o Help Telephone

o Install Source
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Remote Desktop Window Operation

Language

Local Package
Package Cache
Package Code
Package name
Product ID

Reg Owner

Reg Company
SKU Number
Transforms

URL Info About
URL Update info

Source File Image Type (WordCount)

PC-Duo uses the following WMI Class to request/retrieve information about software
applications installed on the remote Host computer:

Component

WMI Class

Products

Win32_Products

System Manager

System Manager provides you with a graphical view of various configuration settings on
the remote Host computer.
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=g Master

Jgnnne::ti::un Wiew Opkions Goto Help
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= j Remote Computer Management

il, Hardware Manager

Software Manager

Swskem Manager

Shared Resource Manager
g Account Manager

- Service Manager

-- Process Manager

! Reqistry Manager

-- Event Manager

- i Power Manager
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€ Select "Computer System" to view details about system settings on remote Host

computer.

@ Select "Desktop" to view details about desktop on remote Host computer.

€ Select "Event Log Files" to view details about event log files system on remote Host

computer.

€ Select "Network Login Profile" to view details about network login profiles on remote

Host computer.

@ Select "Operating System" to view details about the operating system on remote Host

computer.

€ Select "Operating System Updates (QFE)" to view details about operating system

updates on remote Host computer.

€ Select "Page File" to view details about page file on remote Host computer.

€ Select "Page File Usage" to view details about current usage profile of page file on

remote Host computer.

& Select "Tasks Scheduled" to view details about current scheduled tasks for the remote

Host computer.

@ Select "TCP/IP Settings" to view details about TCP/IP connections to the remote Host

computer.

€ Select "Time Zone" to view details about time-related settings for the remote Host

computer.

Computer System
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Computer System provides you with a graphical view of system settings for the remote
Host computer system.

Computer System has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):

° Name

J Admin Password Status

L Automatic Reset Boot Option
° Automatic Reset Capability
] Boot Option On Limit

] Boot Option On Watch Dog

J Boot ROM Supported

] Bootup State

J Caption

J Chassis Bootup State

J Creation Class Name

J Current Time Zone

o Daylight In Effect

] Description

. DNS Host Name

L Domain

° Domain Role

. Enable Daylight Savings Time
. Front Panel Reset Status

° Infrared Supported

° Initial Load Info

. Install Date

] Keyboard Password Status

o Last Load Info

o Manufacturer

L Model
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164

Name Format

Network Server Mode Enabled
Number of Processors

OEM Logo Bitmap

OEM String Array

Part Of Domain

Pause After Reset

Power Management Capabilities
Power Management Supported
Power On Password Status
Power State

Power Supply State

Primary Owner Contact

Reset Capability

Reset Count

Reset Limit

Roles

Status

Support Contact Description
System Startup Delay

System Startup Options
System Startup Setting
System Type

Thermal State

Total Physical Memory

User Name

Wake Up Type

Workgroup
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WMI Class

PC-Duo uses the following WMI Class to request/retrieve Computer System information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class
Computer System Win32_ComputerSystem
Desktop

Desktop provides you with a graphical view of settings for the desktop on the remote
Host computer.

Desktop has the following attributes (double-click on any attribute to get a popup window
with table of attributes and values):

. Name

° Wallpaper

J Cursor Blink Rate

] Icon Title Size

J Screen Saver Timeout
° Border Width

. Caption

° Cool Switch

. Description

. Drag Full Windows

. Grid Granularity

° Icon Spacing

° Icon Title Face Name
° Icon Title Wrap

° Pattern

° Screen Saver Active

165



PC-Duo Master Guide

WMI Class

Screen Saver Executable
Screen Saver Secure
Setting ID

Wallpaper Stretched

Wallpaper Tiled

PC-Duo uses the following WMI Class to request/retrieve Desktop information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component

WMI Class

Desktop

Win32_Desktop

Event Log Files

Event Log Files provides you with a graphical view of currently available Event Log Files
for the remote Host computer.

Each Event Log File has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):
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Caption

Access Mask

Archive

Compressed

Compression Method
Creation Class Name
Creation Date

CS Creation Class Name
CS Name

Description
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Drive

Eight Dot Three File name
Encrypted
Encryption Method
Extension

File Name

File Size

File Type

FS Creation Class Name
FS Name

Hidden

Install Date

In Use Count

Last Accessed

Last Modified

Log File Name
Manufacturer

Max File Size

Name

Number Of Records
Overwrite Outdated
Overwrite Policy
Path

Readable

Sources

Status

System

Version

Writeable
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WMI Class

PC-Duo uses the following WMI Class to request/retrieve Event Log File information from
the remote Host computer. Please consult this class for more detailed information about
the specific attributes and values available.

Component WMI Class

Event Log Files Win32_NTEventLogFile

Network Login Profile

Network Login Profile provides you with a graphical view of currently available Network
Login Profiles for the remote Host computer.

Each Network Login Profile has the following attributes (double-click on any attribute to
get a popup window with table of attributes and values):

. Name

] Description

° Maximum Storage

J Account Expires

L Authorization Flags
] Bad Password Count
. Caption

L Code Page

. Comment

° Country Code

° Flags

° Full Name

° Home Directory

° Home Directory Drive
. Last Logoff

. Last Logon
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Logon Hours
Logon Server
Number of Logons
Parameters
Password Age
Password Expires
Primary Group ID
Privileges
Profile

Script Path
Setting ID

Units Per Week
User Comment
User ID

User Type

Workstations

Remote Desktop Window Operation

PC-Duo uses the following WMI Class to request/retrieve Network Login Profile
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component

WMI Class

Network Login

Profile

Win32_NetworkLoginProfile

Operating System

Operating System provides you with a graphical view of settings for the Operating
System on the remote Host computer.

Operating System has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):
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170

Caption

Manufacturer

Boot Device

Build Number

Build Type

Code Set

Country Name

Creation Class Name

CS Creation Class Name

CSD Version

CS Name

Current Time Zone

Data Execution Prevention Available
Data Execution Prevention 32 Bit Applications
Data Execution Prevention Drivers
Data Execution Prevention Support Policy
Debug

Description

Distributed

Encryption Level

Foreground Application Boost

Free Physical Memory

Free Space in Paging Files

Free Virtual Memory

Install Date

Large System Cache

Last Boot Up Time

Local Date Time
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Locale

Max Number of Processes
Max Process Memory Size
Name

Number of Licensed Users
Number of Processors
Number of Users
Organization

O0S Language

OS Product Suite

0S Type

Other Type Description

PAE Enabled

Plus Product ID

Plus Version Number
Primary

Product Type

Quantum Length

Quantum Type

Registered User

Serial Number

Service Pack Major Version
Service Pack Minor Version
Size Stored in Paging Files
Status

Suite Mask

System Device

System Directory

System Drive
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° Total Swap Space Size
] Total Virtual Memory Sizez
] Total Visible Memory
J Version
° Windows Directory
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Operating System information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component WMI Class

Operating System Win32_OperatingSystem

Operating System Updates (QFE)

Operating System Updates (Quick Fix Engineering) provides you with a graphical view of
updates applied to the Operating System on the remote Host computer.

Each Operating System Update has the following attributes (double-click on any attribute
to get a popup window with table of attributes and values):

. Name

] Caption

. CS Name

. Description
. Fix Comments
. Hot Fix ID

] Install date
] Installed By
° Installed On
° Service Pack In Effect
° Status
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WMI Class

PC-Duo uses the following WMI Class to request/retrieve Operating System Update
information from the remote Host computer. Please consult this class for more detailed
information about the specific attributes and values available.

Component WMI Class

Operating System

Updates (QFE) Win32_QuickFixEngineering

Page File

Page File provides you with a graphical view of the Page File for the remote Host
computer.

The Page File has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

° Name

J Access Mask

° Archive

] Caption

L Compressed

] Compression Method

. Creation Class Name

. Creation Date

° CS Creation Class Name
. CS Name

. Description

° Drive

] Eight Dot Three File name
° Encrypted

° Encryption Method

° Extension

° File Name
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° File Size

° File Type

° Free Space

J FS Creation Class Name

J FS Name

J Hidden

J Initial Size

] Install Date

J In Use Count

J Last Accessed

o Last Modified

° Manufacturer

o Maximum Size

J Path

J Readable

. Status

° System

° Version

° Writeable
WMI Class

PC-Duo uses the following WMI Class to request/retrieve Page File information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available.

Component WMI Class

Event Log Files Win32_PageFile

Page File Usage

Page File Usage provides you with a graphical view of the current usage profile of the
Page File for the remote Host computer.
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Page File Usage has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

WMI Class

Name

Install Date

Allocated Base Size

Caption

Current Usage

Description
Peak Usage

Status

Temp Page File

PC-Duo uses the following WMI Class to request/retrieve Page File information from the
remote Host computer. Please consult this class for more detailed information about the

specific attributes and values available.

Component

WMI Class

Page File Usage

Win32_PageFileUsage

Tasks Scheduled

Tasks Scheduled provides you with a graphical view of current scheduled tasks for the
remote Host computer.

Each scheduled task has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):

Caption
Command
Days Of Month
Days Of Week

Description
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WMI Class

Elapsed Time

Installed Date

Interact WIth Desktop

Job ID

Job Status
Name

Notify

Owner

Priority

Run Repeatedly
Start Time
Status

Time Submitted

Until Time

PC-Duo uses the following WMI Class to request/retrieve scheduled task information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component

WMI Class

Scheduled Tasks

Win32_ScheduledJob

TCP/IP Settings

TCPI/IP Settings provides you with a graphical view of settings for TCP/IP connections to
the remote Host computer.

Each Event Log File has the following attributes (double-click on any attribute to get a
popup window with table of attributes and values):
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] Description

L Connectionless Service

o Guarantees Delivery

. Guarantees Sequencing

] Install date

J Maximum Address Size

° Maximum Message Size

° Message Oriented

. Minimum Address Size

J Pseudo Stream Oriented

° Status

° Supports Broadcasting

° Supports Connect Data

° Supports Disconnect Data

° Supports Encryption

J Supports Expedited Data

. Supports Fragmentation

] Supports Graceful Closing

° Supports Guaranteed Bandwidth

] Supports Multicasting

° Supports Quality Of Service
WMI Class

PC-Duo uses the following WMI Class to request/retrieve TCP/IP Setting information
from the remote Host computer. Please consult this class for more detailed information
about the specific attributes and values available.

Component

WMI Class

TCP/IP Settings

Win32_NetworkProtocol
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Time Zone

Time Zone provides you with a graphical view of time-related settings for the remote Host
computer.

Time Zone has the following attributes (double-click on any attribute to get a popup
window with table of attributes and values):

] Caption

J Bias

° Daylight Bias

] Daylight Day

J Daylight Day of Week
] Daylight Hour

o Daylight Millisecond
. Daylight Minute

] Daylight Month

o Daylight Name

J Daylight Second

J Daylight Year

. Description

] Setting ID

. Standard Bias

o Standard Day

o Standard Day Of Week
° Standard Hour

J Standard Millisecond
] Standard Minute

] Standard Month

L Standard Name

L Standard Second

L Standard Year
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Remote Desktop Window Operation

PC-Duo uses the following WMI Class to request/retrieve Time Zone information from the
remote Host computer. Please consult this class for more detailed information about the

specific attributes and values available.

Component

WMI Class

Time Zone

Win32_TimeZone

Shared Resource Manager

Shared Resource Manager provides you with a graphical view of currently available
shared resources (Shares) and any current network users with connections (Sessions) to
the remote Host computer to access the shared resources.

=z Master

Jg:-nnecticun Wiew Options Goto Help

Y EE)

=1~ J Remoke Computer Management
. Hardware Manager

i Software Manager

Swskem Manager

Shared Resource Manager
h-; Sessions

BR=

g Account Manager
-- Service Manager
Process Manager
! Reqgistry Manager
Event Manager
M- iy Power Manager

Shares WMl class Win32_Share]
Zapkion Shared Folder Shared Path

k= Remate IPC PCH

ﬁ-? Remote Admin ADMING M TS

ih_? Default share % gl

1| |

Rernote Control h File Tramsker h Fernote Printing hRemnte Management lﬂr

For Help, press F1

& 4

Shares

A shared resource can be a disk drive, printer, interprocess communication, or other
shareable device. Each shared resource has the following attributes (double-click on any
shared resource to get a popup window with table of attributes and values):

] Caption
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o Shared Folder
o Shared Path
° Comment
i Type
] Access Mask
J Allow Maximum
] Install date
J Maximum Allowed
° Status
Sessions

Each session has the following attributes (double-click on any session to get a popup
window with table of attributes and values):

J Active Time
J Caption
° Client Type
] Computer Name
. Description
° Idle Time
° Install Date
. Name
L Resources Opened
. Session Type
° Status
J Transport name
o User Name
WMI Class

PC-Duo uses the following WMI Classes to request/retrieve Shared Resource information
from the remote Host computer. Please consult these classes for more detailed
information about the specific attributes and values for Shares or Sessions.
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Component WMI Class
Shares Win32_Share
Sessions Win32_Session

Account Manager

Account Manager provides you with a graphical view of currently available user, group

and system accounts on the remote Host computer.
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Groups

Each group account has the following attributes (double-click on any group to get a

popup window with table of attributes and values):

° Name

L Caption

L Description
J Domain
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° Install Date
] Local
Account

° SID

° SID Type

o Status

System Accounts

Each system account has the following attributes (double-click on any system account to
get a popup window with table of attributes and values):

° Name

] Caption

] Description

J Domain

o Install Date
o Local Account
L] SID

o SID Type

L Status

Users

Each user account has the following attributes (double-click on any user to get a popup
window with table of attributes and values):

. Name

L Domain

° Account Type
] Description
L Caption

° Disabled

° Full Name
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° Install Date
° Local Account
° Lockout
J Password Changeable
° Password Expires
° Password Required
° SID
. SID Type
° Status
WMI Class

PC-Duo uses the following WMI Classes to request/retrieve account information from the
remote Host computer. Please consult these classes for more detailed information about
the specific attributes and values available for each account type.

Component WMI Class

Groups Win32_Group
System Accounts Win32_SystemAccount
Users Win32_UserAccount

Service Manager

Service Manager provides you with a graphical view of currently available services and
system drivers on the remote Host computer.
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Services

Each service has the following attributes (double-click on any service to get a popup
window with table of attributes and values):

. Service Name

. Display Name

. Accept Pause

. Accept Stop

. Check Point

. Creation Class Name
] Description

] Desktop Interact
L Display Name

° Error Code

° Exit Code
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Install Date

Path Name

Process ID

Service Specific Exit Code
Service Type

Started

Startup Type

Start Name

State

Status

System Creation Class Name
LogOn As

Tag ID

Wait Hint

You can apply any of the following commands by right-clicking on any service and
selecting the command from the context menu:

Command Description

Start Start a service that is currently stopped

Stop Stop a service that is currently started

Restart Stop and then start a service that is currently started

System Drivers

Each system driver has the following attributes (double-click on any service to get a
popup window with table of attributes and values):

Name
Description

Path Name
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o Accept Pause
° Accept Stop
° Display Name
J Creation Class Name
J Desktop Interact
° Caption
] Error Control
J Exit Code
o Install Date
o Service Specific Exit Code
° Service Type
] Started
] Start Mode
] Start Name
] State
] Status
° System Creation Class Name
o System Name
° Tag ID
WMI Class

PC-Duo uses the following WMI Classes to request/retrieve Service and System Driver
information from the remote Host computer. Please consult these classes for more
detailed information about the specific attributes and values available for each service.

Component WMI Class
Services Win32_Service
System Drivers Win32_SystemDriver
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Remote Desktop Window Operation

Process Manager provides you with a graphical view of currently running processes on

the remote Host computer.
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Each process has the following attributes (double-click on any process to get a popup

window with table of attributes and values):

. Process ID

L] Name

° Command Line

° Started

o Description

. Executable Path

. Parent Process ID
U Session ID

. Priority

° Handle Count
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Commands

You can apply any of the following commands by right-clicking on any process and
selecting the command from the context menu:

Thread Count

Kernel Mode Time

User Mode Time
Current Working Set
Minimum Working Set
Maximum Working Set
Peak Working Set

Page File Usage

Peak Page File Usage
Virtual Bytes

Virtual Bytes Peak
Read Operation Count
Write Operation Count
Other Operation Count
Read Transfer Count
Write Transfer Count
Other Transfer Count
Page Faults

Private Page Count

Command

End Process

WMI Class

PC-Duo uses the following WMI Class to request/retrieve process information from the
remote Host computer. Please consult this class for more detailed information about the
specific attributes and values available for each process.
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Remote Desktop Window Operation

Component

WMI Class

Process Scan

Win32_Process

Registry Manager

Registry Manager provides you with a graphical view of currently available Registry keys

on the remote Host computer.
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Registry keys are organized into the following hives:

¢ "HKEY_CLASSES_ROOT"
¢ "HKEY_LOCAL_MACHINE"
¢ "HKEY_USERS"

¢ "HKEY_CURRENT_CONFIG"

Each Registry key has the following attributes (double-click on any Registry key to get a
popup window with table of attributes and values):

. Name

. Type
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(] Data

Commands

You can apply any of the following commands by right-clicking on any Registry key and
selecting the command from the context menu:

Command Description

Delete Delete an existing registry key

Modify Modify attributes of an existing registry key
New > Key Create a new registry key

New > String Value

Specify String Value for a new registry key

New > Dword Value

Specify Double Word Value for a new registry key

New > Expanded String

Specify Expanded String Value for a new registry key

Event Manager

Event Manager provides you with a graphical view of the Application, Security and
System logs kept on the remote Host computer.
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Event Logs

A Windows computer records events in three kinds of logs:

€ Application Log: The application log contains events logged by applications or
programs. For example, a database program might record a file error in the application
log. Program developers decide which events to monitor.

€ Security Log: The security log records events such as valid and invalid logon
attempts, as well as events related to resource use such as creating, opening, or deleting
files or other objects. An administrator can specify what events are recorded in the
security log. For example, if you have enabled logon auditing, attempts to log on to the

system are recorded in the security log.

€ System Log: The system log contains events logged by Windows system
components. For example, the failure of a driver or other system component to load
during startup is recorded in the system log. The event types logged by system

components are predetermined by Windows.

Event Records

Each event recorded in the logs has the following attributes (double-click on any event

record to get a popup window with table of attributes and values):

. Event Type

° Time Generated
° Source name

° Category
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° Event Code
° User
° Computer Name
° Logfile
° Message
° Category String
° Data
J Event Identifier
J Insertion Strings
° Record Number
° Time Written
. Type
WMI Class

PC-Duo uses the following WMI Classes to request/retrieve event log information from
the remote Host computer. Please consult these classes for more detailed information
about the specific attributes and values available for each event record.

Component WMI Class

Application Log Win32_NTLogEvent
Security Log Win32_NTLogEvent
System Log Win32_NTLogEvent

Power Manager

Power Manager provides you with a graphical view of power management options on the
remote Host computer.
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€ Select "Power Summary" to view summary of current power settings on remote Host
computer.

€ Select "Shutdown Manager" to view options to shutdown, reboot or logoff current
console user on remote Host computer.

& Select "Power Scheme Manager - XP" to view and edit power scheme settings for
various users on remote Host computer running Windows XP or Windows Server 2003.
In general, each user account has its own power scheme.

€ Select "Power Scheme Manager - Vista/Win7" to view and edit power scheme settings for
remote Host computer running Windows Vista, Windows 7 or Windows Server 2008. In
general, the computer has a single power scheme that applies to all the user accounts on
the system.

Power Summary

Power Summary provides you with a graphical view of the current power settings for the
remote Host computer.
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Power Summary has the following attributes:

194

Power Button Present

Sleep Button Present

Lid Present
Sleep state
Sleep state
Sleep state
Sleep state
Sleep state
Wake Supported

Video Dim Supported

S4 (hibernate)

S1 Supported
S2 Supported

S3 Supported

Supported

S5 Supported




Remote Desktop Window Operation

J APM BOPS Present

° UPS Present

° Disk Spin Down Supported
J Batteries Are Present

J Batteries Are Short Term
° Hybrid Sleep Supported

J AC Status

] Current Idle Level

] Idle Time Remaining

Power Management Structure

PC-Duo uses the following Power Management Structure to request/retrieve power
capabilities of the remote Host computer. Please consult this structure for more detailed
information about the specific attributes and values available.

Component Structure

Power Management Structures System_Power_Capabilities

Shutdown Manager

Shutdown Manager provides you with a graphical view of the options available to
shutdown, reboot or logoff the console user from the remote Host computer.

195



PC-Duo Master Guide
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Commands

You can apply any of the following commands to the remote Host computer by clicking on

the corresponding button:

Command

Description

Log Off Console
User

Stop current session for logged on user on remote

Host computer

Shutdown Computer

Shutdown remote Host computer

Restart Computer

Shutdown and restart remote Host computer

Power Off Computer

Shutdown and power off remote Host computer

Select the Force operation option to make the selected command apply immediately and
without response from logged on user.

Power Scheme Manager - XP
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Power Scheme Manager - XP provides you with a graphical view of the current settings
for power schemes for various user accounts on a remote Host computer running

Windows XP or Windows Server 2003.

In general, power settings on Windows XP or Windows Server 2003 fall into one of 3

categories:

€ Global settings which apply across the system

¢ User account-specific settings defined in a power scheme

¢ User account-specific settings not defined in a power scheme

Note: Changes to power settings will not take affect until after current user logs out and

logs back in.

Global Settings

If Power Scheme Manager detects any global power settings, a Global node will appear
under Power Scheme Manager in the navigation tree. If this Global node is selected, a
list of global power settings and their current values will be presented:
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j Shut Down Manager
E| ! Power Scheme Manager
A Fax

- Administrator

- GLOBAL

Power settings for: GLOBAL

Save Sektings |

Walue: IOFF

<

| Setting | Plugged In { Global | On Battery
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Remate Control )\ File Transfer )\ Remote Printing )\Remote l*"‘lanagemenll,’r

For Help, press F1
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To edit a global setting, highlight the setting and select a value from the dropdown box
that appears at the bottom. An asteric will appear in the first column next to any values
that have been changed. Click the Save Settings box to apply the changes.

User Account Settings - Not in Power Scheme
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Some power settings are user account-specific but are not defined in power schemes. To
view/edit these settings, click on a user account node in the navigation tree under Power
Scheme Manager and a list of these settings will appear.

= Master

Jgonnectinn Wiew Options Goko  Help

By ©
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Critical battery sound alarm CIff P&

Low battery lewvel 10 % A

Low battery alarm enable on MIA

Low battery action Da Mothing A

Low battery display message on A
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Yalue: I 3
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=

Any changes to these settings can be applied just to the selected user account (Save
Settings) or to all user accounts (Apply Settings to All Users).

User Account Settings - Power Scheme

Under each user account node, a list of default and custom power scheme configurations
will appear. Click on one of these schemes to view/edit the settings:
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Power scheme settings are divided into two subgroups:
& Power scheme settings that apply only to this user account
& Power scheme settings that apply all user accounts that use this power scheme

You can view/edit settings in either subgroup as described above.

Commands

You can apply any of the following commands to the power scheme by clicking on the

corresponding button:

Command

Description

Active Scheme

Make this the active power scheme for this user

account
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Activate Scheme for Make this the active power scheme for all user
All Users accounts on this system
Delete Scheme Delete this power scheme from this user account

Create a new custom power scheme with the same

Duplicate Scheme
values

Power Scheme Manager - Vista/Win7

Power Scheme Manager - Vista/Win7 provides you with a graphical view of the current
settings for power schemes on a remote Host computer running Windows Vista or
Windows 7.

In general, the computer has a single power scheme that applies to all the user accounts
on the system.

Power Scheme Settings

Under the Power Scheme Manager node, the system name will appear. Under this node,
a list of default and custom power scheme configurations will appear. Click on one of
these schemes to view/edit the settings:
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To edit a power scheme setting, highlight the setting and select a value from the

dropdown box that appears at the bottom. An asteric will appear in the first column next
to any values that have been changed. Click the Save Settings box to apply the changes

to this power scheme

Commands

You can apply any of the following commands to the power scheme by clicking on the

corresponding button:

Command

Description
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Active Scheme

Make this the active power scheme for this system

Delete Scheme

Delete this power scheme from this system

Duplicate Scheme

values

Create a new custom power scheme with the same

Menu options

The following table describes menu commands and, in some cases, their equivalent tool
bar icons in the PC-Duo Master Remote Desktop Window. The menu items and icons
that display depend on which tab you select.

Menu

Tool
Command bar
icon

Description

Connection

Properties

Opens a window that
displays the information
about the remote
connection.

Disconnect @

Closes a connection to one
or more of the PC-Duo
services to the remote Host
computer. If you choose
Remote Control, the
Master Remote Desktop
Window closes.

Begin
Recording

Starts a recording of the
screen display of the remote
Host computer. The Master
must connect to the Host
through a Gateway to
enable recording.

Stop
Recording

Stops a recording of the
screen display of the remote
Host computer. The
completed recording will be
accessible on the Gateway
through which the Master
connected to the Host.

Add to
Favorites

Adds the Host computer to
which you are connected to
the Favorites list on the
PC-Duo Master console
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window.

Add to
Cycling
Monitor
Hosts

Adds the open Host
computer (from the Remote
Control tab on the Master
Remote Desktop Window)
to the Cycling Monitor
Hosts list on the PC-Duo
Master console window.

Reboot Host

Restarts a remote Host
computer running DOS or
Windows 3.1. Use the Start
> Shut Down command to
reboot remote Host
computers running later
versions of Windows.

Terminates the connection
to the current Host and

Exit closes the Master Remote
Desktop Window.
Gives keyboard and mouse
Inout control of the Host computer
Edit P to the remote user of a PC-
Control
Duo Gateway-managed
connection.
Sends a predefined key
combination to the Host
computer as though it were
entered on the keyboard of
Send the remote Host computer
Keystroke when you are connected to
it for remote control. This is
useful for sending special
key combinations such as
CTRL-ALT-DEL.
Request Sends command to remote
Screen Host computer to refresh
Refresh screen capture.
Copies the contents of the
clipboard on the remote
Get
- Host computer to the
Clipboard clipboard on your local
from Host P y .
computer when you view
the Remote Control tab.
Copies the contents of the
clipboard on your local
Send .
- computer to the clipboard
Clipboard to
Host on the remote Host

computer when you view
the Remote Control tab.
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Copy Text
Screen

Copies selected text from
the Host computer display in
the Master Remote Desktop
Window to the clipboard on
your local computer from
the Remote Control tab.

Copy
Graphics
Screen

Copies a selected region of
the Host computer display in
the Master Remote Desktop
Window to the clipboard on
your local computer from
the Remote Control tab.
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View

Menu Bar

Toggles whether the menu
bar is displayed in the
Master Remote Desktop
Window.

Tool Bar

Toggles whether the tool
bar is displayed in the
Master Remote Desktop
Window.

Page Header

Toggles whether the
heading is displayed in the
Master Remote Desktop
Window.

Toggles whether tabs are

Tabs displayed in the Master
Remote Desktop Window.
Toggles whether the status
bar is displayed in the

Status Bar Master Remote Desktop
Window.

Remote Toggles whether the

Control Remote Control tab is

Page displayed.

File Transfer
Page

Toggles whether the File
Transfer tab is displayed.

B | @ |

Remote Toggles whether the
Printing Remote Printing tab is
Page displayed.
Remote Toggles whether the
Management Remote Management tab
Page is displayed.

Scales the image of the
Fit to m Host computer display to fit
Window the size of the Remote

Desktop Window.




Fit 1-to-1

Remote Desktop Window Operation

Specifies that one pixel of
the Host computer display
corresponds to exactly one
pixel on the display of the
local computer.

Full Screen

Displays the screen output
from the remote Host
computer using the entire
monitor screen on the local
computer. To return to the
local computer display, click
the Full Screen button on
the floating palette, or press
F11 in the Master Remote
Desktop Window.

Open Chat
Window

Opens a Chat window in
which text messages can be
sent to Host and to any
other Masters connected to
that Host.

Options

Keyboard
Mapping

Opens the Keyboard
Mapping window, which
lets you define the key
combinations that you can
enter on the local computer
to initiate keystrokes on the
Host computer.

Remote
Desktop
Window
Settings

Displays the Remote
Desktop Window Settings
dialog, which contains
settings for various tabs in
the Master Remote Desktop
Window.

View Only

Toggles whether PC-Duo
Master sends keystrokes,
mouse movements, or
mouse selections to the
remote Host computer from
the Remote Control tab of
the Master Remote Desktop
Window. When you select
View Only, PC-Duo Master
displays the Host computer
screen, but does not
transmit keyboard or mouse
commands to it.

Suppress
Host Mouse
& Keyboard

Check Suppress Host
Mouse & Keyboard option
from the Remote Control
tab of Master Remote
Desktop Window to request
that the remote Host
computer mouse and
keyboard be disabled. If this
request is granted, the user
at the remote Host
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computer cannot operate
that computer when you
connect to it through PC-
Duo Master. You maintain
exclusive control throughout
your Master Remote

Desktop Window.
Remote
GoTo Control E ggkaecstit/r;e Remote Control
Page '
File Transfer E Makes the File Transfer tab
Page active.
Re_mpte % Makes the Remote Printing
Printing tab active
Page '
Remote
Sy Makes the Remote
I\P/Ianagement Management tab active.
age
Hel Helo Topics Opens the PC-Duo Master
P prop online help system.
Vector Opens the Vector Networks
Networks home page in a browser
Home Page window.
Check for Opens a web page with

Updates and
Maintenance

information about recent
updates and new releases

Releases of Vector software.
Purchase Opens a web page to
Additional purchase license(s) for PC-
Licenses Duo Master.

Order Opens a web page to
Technical purchase Maintenance &
Support Support contracts from
Contract Vector Networks.

About PC- and loense key informator
Duo Master y

for PC-Duo Master.
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PC-Duo screen recordings can be played back in a Playback window that pops up as a
separate window from PC-Duo Master.

The following elements in the window provide information about the playback you are
watching:

€ The Title bar displays the name of the managed Host on which you recorded screen
activity, followed by the date and time of the recording.

@ The Slider represents the playback in process. To go to an earlier or later part of the

playback, click and drag J-to another position on the slider.

€ The Time increments field displays the following measurements in xx:YY:ZZ, where
X represents hours, Y represents minutes, and Z represents seconds.

+ Elapsed Time indicates how much of the recording has played.
+ Out of indicates the total time of the recording.

€ The Playback area plays the recording.

& C:Documents and Settings' AdministratorDesk27.PruRec - Proxy M... M=l

Jgn:nnnecti-:nn Edit Wiew Options Help

[y Uy nme pzl=l=lE =

/
JJ Elapsed Time: 00:00:57 out of: 00:04:46

£¥ Oracle Forms Runtime

Wirdo

LIS EIEIEE =]

Lsername:

Passwiord;

Dakabase;
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For more configuration options, see:
"Playback options"

"Playback window settings"
"Recording properties"
"Gateway properties"

"Delete options"

"Recording format options"

* 6 6 6 0 0 o

"Menu options"

Tool bar options

Table below summarizes the functions of icons available on the tool bar for the Playback
window:

Icon Function

} Resumes a paused playback.

Il Pauses the playback.

D’ Plays back the recording at half the speed of
the original activity.

b Plays the recording.

kb Plays back the recording at twice the speed of

the original activity.

m‘ Plays back the recording at triple the speed of
the original activity.

@I Closes the Playback window.

Displays the screen output from the remote
Host computer using the entire monitor screen

EE on the local computer. To return to the local
computer display, click the Full Screen button
on the floating palette, or press F11 in the
Master Remote Desktop Window.

208



Playback Window Operation

Specifies that one pixel of the Host computer
display corresponds to exactly one pixel on the
display of the local computer.

Scales the image of the Host computer display
to fit the size of the Remote Desktop Window.

Copies a selected region of the Host computer
display in the Master Remote Desktop Window
to the clipboard on your local computer from
the Playback window.

Go to the Playback Window Settings tab to
modify the display settings for the Playback
window.
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Playback options

Recordings can be played back from the following source locations:

& From the PC-Duo Gateway, which streams the recording in real-time over a network
connection to the Playback window.

@ From a PC-Duo recording file that has been saved with the . PrxRec extension to the
local drive.

& From any standard web server, which streams the recording in real-time over HTTP or
HTTPS to the Playback window.

Play a recording from the PC-Duo Gateway
To play a recording from the PC-Duo Gateway:
1 Select the recording you want to play.

2 Right-click the recording and choose Play Recording or choose Connection > Play
Recording from the menu.

The Playback window opens and the recording begins to play.

Zommect

Conneck Special *
Connect to YMNC Server,..

Send Wake-0n-LAMN Signal

Recard, .,

Stop Recording

Flay Recording
Delete Recording

Export Recording

#dd to Favorites
Sdd to Cyeling Monitor Hosts

Save As Shorkouk

Properties

Play Recording From Eile. ..
Play Recording wia URL. ..

Exit

Play a recording from alocal disk file

By default, PC-Duo recordings are stored by the PC-Duo Gateway at a location
configured by the Gateway Administrator (which may or may not be accessible through a
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network share). If recordings are moved to another machine, you can use PC-Duo
Master to play that recording locally:

1 Choose Connection > Play Recording from File... from the menu. Find recording in the
explorer window that pops up

2 Click Open and the Playback window will pop up and start playing the recording.

Playback Recording File EH

Look jr: | | {365054FE-9FFF-46C5-9F3E-E3844BC5E701 | &= (8] F BB~

Deskta B

Y

ky Documents

™

tdy Computer

-

File name: ITest Recaording. PreRec j Open

Carnicel |
F

Files of type: | Recording Files

Play a recording from a web server

By default, PC-Duo recordings are stored by the PC-Duo Gateway at a location
configured by the Gateway Administrator (which may or may not be accessible through a
network share). If recordings are moved to a location accessible by a standard web
server, you can use PC-Duo Master to play that recording via standard URL.:

1 Choose Connection > Play Recording via URL... from the menu. Find recording in the
explorer window that pops up

2 Click OK and the Playback window will pop up and start playing the recording.
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Enter URL |

Please enter the URL of the recording file wou wish ko play:

I http: fiproxywebservert Test Recording. prirec

Ik I Cancel

The following syntax can be used to specify the URL of the recording file you wish to
play:

® http://<webservername>/<recordingfile.prxrec> (default port is
8080)

® http://<webservername:port>/<recordingfile.prxrec>
& https://<webservername>/<recordingfile.prxrec>

€ https://<username.password@webservername>/<recordingfile.prxrec>

If URL is specified using HTTPS, the Master will attempt to validate the server's
certificate, and will display a warning dialog if the certificate has any errors.

If server requires authentication, and no username or password is specified in the URL,
the Master will present the current logged on user's credentials to the webserver; if the
default credentials are not accepted, a username/password dialog will appear.

Recordings played via URL or from a local file store will appear in the Master's History
tab and can be added to the Favorites tab. From either location, they can be played
again, deleted or exported (and converted to .wmv format).

Note the following limitations:

Note: If the server has a certificate error, the error action (i.e. to accept the certifcate) is
not stored in History or Favorites. The only way to export a recording from URL with a
certificate error is from within the Playback window.

Note: Playback via URL does not have access to metadata about the recording, i.e.
workstation ID, user name, date/time started, etc., so those fields are blank in the
properties dialog. The exception is duration, which is shown by default.

Play a recording using command line utility

The Playback window can be invoked by using the Master command line with following
syntax:

€ pcduo.exe /g"<Gateway>" /r"<sessionID>" (GUID sessionID of
recording)

€ pcduo.exe <recordingfile.prxrec> (recording file in local file
store)
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€ pcduo.exe http://<webservername:port>/<recordingfile.prxrec>
(recording file accessible via URL on webserver)

The standard command line options "/u<username>" and "/x<password>" can be used to
provide specific credentials if default credentials of current logged-on user are no
sufficient. See "Command line syntax examples" for more information.
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Playback window settings

To control the display of the PC-Duo Master Playback window, choose Options >
Playback Window Settings to open the Playback Window Settings tab.

Default Playback Window Settings |

Playback. I

—Wiewer Settings
[~ Full Screen

+ Fit ko windaw
" Fit 1-ko-1

—fuko-scrall

v Cursaor (text-mode only) v Mouse (kexk & graphics modes)

— 25 Sessions
Font:  |Procey & % 14 =]
k. I Cancel Apply Help

The settings in this window are for viewing, scrolling, and displaying a recording
playback:

€ Viewer Settings determine how activity on a remote computer is displayed.

214

+ Full Screen displays the playback using the entire monitor screen on the local

computer.

+ Fit to window scales the image of the playback to fit the size of the PC-Duo
Master Playback window.

+ Fit 1-to-1 specifies that one pixel of the playback corresponds to exactly one
pixel on the display of the local computer.

+ Select Halftone to improve the quality of the display when the Master is in Fit to

Window mode.
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Note: The Halftone option affects only the way the screen is rendered by the
Master, and may increase CPU usage on the Master.

Select these options from the View menu and toolbar icons,

€ Auto-scroll settings determine if the window scrolls when the cursor or mouse reaches
a boundary.

+ Cursor (text-mode only) - automatically scrolls when the cursor comes to an
edge of the Playback Window when you hold the CTRL key down.

+ Mouse (text & graphics mode) - automatically scrolls when the mouse comes to
an edge of the Playback Window when you hold the CTRL key down.

€ The DOS Sessions setting determines the Font that the Master uses when it displays a
DOS session on the Host. Each choice consists of combination of two elements, typeface
and point size.
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Recording properties
View the properties of a recording from two windows:
4 In the PC-Duo Master window, right-click a recording and choose Properties.

4 In the Playback window, choose Connection > Properties.

FORD 2,/2,/2006 3:49:22 PM Properties El

Connection |

—Gateway Recording

Start Time: | 2}2}2006 3:49:22 PM

Duration: I 1 min

YWarkskation I I {5DF2E7FO-432C-4393-9095- 2866344 55B5L

Iser: I Adrministrakor

Recording Key: I {12EEZ2B26-C510-4600-9656-0642E7EG465 1

Filename: I C:\Program FilestFunk SoftwareiProxy Gake:
Size (Bytes): | 4405
Starked By I BEMELLI A&drinistrakor

Gateway... |

k. I Cancel | Ay | Help |

The following properties of a recording are listed in the Connection tab.
Start Time

Duration

Workstation ID

User

Recording Key

Filename

Size (Bytes)

Started By

L 2R 2B JBR JBK 2B R JNE NN 2

Gateway
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Gateway properties

To record screen activity on a Host, the Host must be connected to a PC-Duo Gateway.
When you view the properties of a recording and click Gateway, the properties of the PC-
Duo Gateway that managed that connection are displayed.

Gateway Properties |

Connection | Connect s I

—Gaakteway

Cisplay Mame: I W5

Praotocal; ILlDF'.I'IF' vI Faort: I-::Standard::- vI

Gateway Specifier: I 152.1.1.1

Statian Mame: | WS

Metwork Address: I 152.1.1.1

[~ Use encryption

Eind Gakteway. .. I

k. I Cancel Apply | Help |
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Delete options

To delete a recording from the Host Recordings list on the PC-Duo Gateway, follow these
steps

1 Inthe Host Recordings list, select each recording that you want to delete.

2 Right-click and choose Delete Recording or choose Connection > Delete Recording
from the menu. The recording is removed from the Host Recordings list and deleted from
the PC-Duo Gateway.

To delete a recording from a local drive, you must use Windows Explorer to find and
delete the . PrxRec file from the computer.
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Recording format options

From the PC-Duo Master Playback window, you can convert a PC-Duo recording to
Microsoft .wmv format and save it to your file system.

From the Connection menu, select Export Recording

A Windows dialog box will appear to let you choose where to save the converted
recording. Once the conversion begins, a status box will appear to indicate when the
conversion is complete.

£ Conversion complete _ [} |

Converking wia Gateway 127.0.0.1
SessionlD: {7F2C04DE-3BAC-4BCD-91DD-02FFEBS4EFS3}

]

Conversion completed successfulky

Destination:
CDocuments and Settingsisdmind, . virtual-2008-01-02-16-09-10-372, WPy

[™ Close this dislog box when conversion is complete

Play: Open Folder
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Menu options

Table below describes menu commands and tool bar icons in the PC-Duo Master

Playback window:

Tool
Menu Command bar Description
icon
. Disconnect; Closes the PC-Duo Master
Connection Exit X Playback window.
Copies selected text to the
. clipboard on your local
Edit Copy Text computer. The playback must
be of a text-only screen.
Copies a selected region of the
gopy . E‘;", playback to the clipboard on
raphics
your local computer.
Toggles whether the menu bar
View Menu Bar is displayed in the PC-Duo
Master Playback window.
Toggles whether the tool bar is
Tool Bar displayed in the PC-Duo
Master Playback window.
Toggles whether the position
Playback indicator is displayed in the
Position PC-Duo Master Playback
window.
Page Toggles whether the heading is
Hegder displayed in the PC-Duo
Master Playback window.
Toggles whether the status bar
Status Bar is displayed in the PC-Duo
Master Playback window.
Scales the image of the
Fit to m playback to fit the size of the
Window PC-Duo Master Playback

window.

Fit 1-to-1 =

Specifies that one pixel of the
playback corresponds to
exactly one pixel on the display
of the local computer.

Full Screen EEI

Displays the playback using
the entire monitor screen on
the local computer.
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Opens the Keyboard Mapping
window, which lets you define

Obpti Keyboard the key combinations that you
ptions .

Mapping can enter on the local
computer to initiate keystrokes
on the Host computer.
Displays the Playback Window

Plgyback 2] Settings dialog, which contains

Window X

Setti the settings for the Playback

ettings .
window.
Help Help Topics Op_ens the PC-Duo Master

online help system.

Home Page Qpens the PC-.Duo home page
in a browser window.

Vector Opens the Vector Networks

Networks home page in a browser

Home Page window.

Register Opens a web page that you

PC-DUO can use to register your copy of
PC-Duo Master.

Purchase Opens a web page from which

PC-Duo you can purchase your copy of
PC-Duo Master.

About PC- Displays version number of

Duo Master PC-Duo Master.
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Cycling Monitor Window Operation

PC-Duo Master Cycling Monitor allows you to serially check in on a list of Host computers
that you create on the Cycling Monitor Hosts tab of the PC-Duo Master window.

=] E3

=z Master

Jg::unnectinn Edit Miew Options Goto Help

EO%- =T
Cycling Monitor Hosts

Display Mame Protocol Fatemay Metwork Address

Oy E-&- &=
=]

T ECATEWAY lacal
=) 2 pPoRT lacal
=) < ppoRTZ lacal

Peer-to-Peer Hosts h Gateway Hosts }-.. Active Connections h Histary }H. Favorites }-..E',rtling Monitor Hoslts l{'—
3 Hosts, 1 selected v

This window is similar to the PC-Duo Master Remote Desktop Window, except that you
cannot remotely control any of the active remote connections from it. Instead, the PC-
Duo Master Cycling Monitor window will start with the Host at the top of the Cycling
Monitor Hosts list, make a connection to that Host, display the Host screen for a
predetermined interval, and then move on to the next Host on the list.
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;—. GATEWAY wia SUPPORT - Master Cycling Monitor

JQ::nneu:tiu:un Edit View Options Help

; |« = BED %

For Help, press F1 Connecting ko next host in 4 seconds, ., |E|_ o

Note that a countdown of cycling span interval time remaining is displayed in the status
bar in the bottom right hand corner.

The following options are available for managing the Cycling Monitor window:
& “Cycling Monitor window settings”
¢ “Menu options”

NOTE: Depending on how PC-Duo Host (or PC-Duo Gateway) is configured, your
credentials may be restricted from monitoring one or more Host computers on your
cycling monitor list.

Tool bar options

Table below summarizes the functions of icons available on the tool bar for the Cycling
Monitor window:

Icon Function

e Closes the Cycling Monitor window.
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Change the Cycling Monitor window to show
the previous Host computer on the Cycling
Monitor Hosts list.

Change the Cycling Monitor window to show
the next Host computer on the Cycling Monitor
Hosts list.

Displays the screen output from the remote
Host computer using the entire monitor screen
on the local computer. To return to the local
computer display, click the Full Screen button
on the floating palette, or press F11 in the
Master Remote Desktop Window.

Specifies that one pixel of the Host computer
display corresponds to exactly one pixel on the
display of the local computer.

Scales the image of the Host computer display
to fit the size of the Remote Desktop Window.

Copies a selected region of the Host computer

o display in the Master Remote Desktop Window
L to the clipboard on your local computer from
the Cycling Monitor window.
- Go to the Cycling Monitor Settings tab to
modify the display settings for the Cycling

Monitor window.
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Menu options

The following table describes menu commands and tool bar icons in the Cycling Monitor

window.

Menu

Tool
Command bar
icon

Description

Connection

Properties

Opens a window that
displays the information
about the remote
connection.

Connect to

Closes a connection to
one or more of the PC-
Duo services to the
remote Host computer. If
you choose Remote
Control, the Master
Remote Desktop Window
closes.

Next Host =

Change the Cycling
Monitor window to show
the next Host computer
on the Cycling Monitor
Hosts list.

Previous
=]

Host

Change the Cycling
Monitor window to show
the previous Host
computer on the Cycling
Monitor Hosts list.

Start
Cycling

Adds the Host computer
to which you are
connected to the
Favorites list on the PC-
Duo Master console
window.

Stop
Cycling

Adds the open Host
computer (from the
Remote Control tab on
the Master Remote
Desktop Window) to the
Cycling Monitor Hosts
list on the PC-Duo Master
console window.

Exit

Terminates the
connection to the current
Host and closes the
Master Remote Desktop
Window.
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Edit

Cycling
Monitor
Hosts

Gives keyboard and
mouse control of the Host
computer to the remote
user of a PC-Duo
Gateway-managed
connection.

Copy Text
Screen

Copies selected text from
the Host computer
display in theMaster
Remote Desktop Window
to the clipboard on your
local computer from the
Remote Control tab.

Copy
Graphics
Screen

Copies a selected region
of the Host computer
display in the Master
Remote Desktop Window
to the clipboard on your
local computer from the
Remote Control tab.

View

Menu Bar

Toggles whether the
menu bar is displayed in
the Master Remote
Desktop Window.

Tool Bar

Toggles whether the tool
bar is displayed in the
Master Remote Desktop
Window.

Page Header

Toggles whether the
heading is displayed in
the Master Remote
Desktop Window.

Tabs

Toggles whether tabs are
displayed in the Master
Remote Desktop
Window.

Fit to
Window

Displays the screen
output from the remote
Host computer using the
entire monitor screen on
the local computer. To
return to the local
computer display, click
the Full Screen button
on the floating palette, or
press F11 in the Master
Remote Desktop
Window.

Fit 1-to-1

Specifies that one pixel of
the Host computer
display corresponds to
exactly one pixel on the
display of the local
computer.
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Scales the image of the
Host computer display to

Full Screen m fit the size of the Remote
Desktop Window.
Opens the Keyboard
Mapping window, which
lets you define the key
Options Keyboard combinations that you
Mapping can enter on the local
computer to initiate
keystrokes on the Host
computer.
Displays the Cycling
Cycling Monitor Settings dialog,
Monitor which contains settings
Settings for Cycling Monitor
window.
Opens the PC-Duo
Help Help Topics Master online help
system.
Vector Opens the Vector
Networks Networks home page in a
Home Page browser window.
Check for Opens a web page with

Updates and
Maintenance

information about recent
updates and new
releases of Vector

Releases
software.
Purchase Opens a web page to
Additional purchase license(s) for
Licenses PC-Duo Master.
Order Opens a web page to
Technical purchase Maintenance &
Support Support contracts from
Contract Vector Networks.
Displays version number
About PC- and license key
Duo Master information for PC-Duo

Master.
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The command line from the Windows command prompt, Start > Run >cmd, can be used
to run PC-Duo Master and manually perform any of the following tasks:

4 Use commands to set up connections to specific Host computers.

€ Use command line scripts to make connections to specific Host computers whose
configuration is specified in a shortcut file (a file with a .PRX4 extension).

€ Run a script to connect automatically to the remote Host computer with PC-Duo
Master preconfigured.

& Specify a PC-Duo Host recording file, with a .PrxRec extension, to be played in a
Playback Window.

The command line can also be used to manage configuration options, including the
following:

& Specify the Host computer in terms of address, port, and protocol.

& Customize the title bar of the “Remote Desktop Window operation” that appears when
you make a remote connection.

& Provide the name of the shortcut file for opening connections.

The syntax for using the command line is as follows:

pcduo.exe [/option"values"]|[ ShortCutFile | RecordingFile ]

With this syntax, follow the command pcduo . exe with a sequence of configuration
option/value pairs (do not include brackets). Specify the option with a forward slash (‘/’)
followed by one letter. If you specify a value that has a space or a special character, the
value must be in quotes. Optionally, you can include the name of a shortcut file to specify
all other configuration parameters for the connection. The shortcut file extension must be
.PRX4. See “Command line options”.

The following is an example of the PC-Duo Master command line syntax.
pcduo.exe /PUDP /S198.186.166.124 MyShortcut.prx4

If you have created and specified a shortcut file called MyShortcut.prx4, use this
syntax to run MyShortcut.prx4 with its “Default Remote Desktop Window Settings”,
and open a connection to a remote Host computer at 198.186.166.124, using the UDP/IP
protocol and the standard port. All other configuration parameters are specified in the
shortcut file.

4 "Command line option values and syntax"

4 "Command line syntax examples”
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Command line options

Command line options can be used to customize your remote connection configuration.

All command line options consist of a one-letter option specification, preceded by a
forward slash (*/’). Follow each command immediately by a command value surrounded
by double quotes, with no space between the one-letter command and its value. If you do
not have any special characters such as blank spaces in your option values, you do not
have to use quotes.

Command options are not case-sensitive; for example, /W and /w are the same
command.

The command options are as follows:

€ /H opens a custom remote Host computer connection, but hides the PC-Duo Master
console window when you open it. Note that /H does not hide any instances of PC-Duo
Master that are already open.

& /M starts a new instance of PC-Duo Master, even if one is already open and running.

& /P specifies the network protocol and nonstandard listening port required by your
remote Host computer.

@ /s specifies Host information. For a peer-to-peer connection, use this command to
specify the Host computer name or network address in the syntax required by the
protocol you choose. For remote connections through a PC-Duo Gateway, use the PC-
Duo Gateway syntax of this command to specify your Host computer key. See
“Connection tab”.

& /G specifies the PC-Duo Gateway to connect to for a remote connection. With this
option, you must also use the PC-Duo Gateway syntax for /S to specify a Host computer
key associated with a Host computer. The specified PC-Duo Gateway must be
configured to manage the specified Host computer.

€ /U specifies a user name that your remote Host computer or PC-Duo Gateway
requires. You must configure PC-Duo Host on your remote Host computer to accept this
user name (and corresponding password).

& /v specifies a DNS name or IP address of a VNC server to connect to for a remote
connection.

& /u specifies a title other than the default for the “Master Remote Desktop Window”.
€ /X provide a password for your remote connection.

€ <recordingfile.prxrec> specifies a local PC-Duo screen recording file to be
played

€ <http://webserver:port/recordingfile.prxrec> specifies a PC-Duo
screen recording file located at a webserver to be played over HTTP (or HTTPS).

If you do not specify one or more of these connection options in a command line, PC-Duo
Master relies on the connection values in the current PC-Duo Master console window, or
the default configuration values if you have not yet configured the product.

Command line option values and syntax
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The values that you can assign to a command line option depend on the option. For
example, /H /M take no values.

The following values can be assigned to the other command line options as listed in table

below.

Comman

d Value(s) Notes or Syntax
For TCP/IP protocol. No quotes
required.

/P TCP For UDP/IP protocol. No quotes

(No F_’f(?rt ; UDP required.

ZE}‘;CI icatl IPX For IPX protocol. No quotes required.
The default (standard) port is
assigned in each case.

Syntax:
Protocol /P"Protocol_namel Port num

/P name | port pair (see ber"

(With port above for the allowed Example:

specificati protocol name values). /P"TCP|5001"

The entire phrase is in . . .
on) quotes P The vertical bar is required as a
' separator for the protocol/port number
pair.
] Typically, the required format is
String value for username . , . .
/U in quotes /U”domain\user name”, asin
' /U”ACME\george”.
/X String value for the Example: /X" foo"
password in quotes. ple:

/W tslttlgnlg \éigjtiéor the new Example: /W"Stock Traders"
When you specify the PC-Duo
Gateway, you must also specify the
Host computer using the Host key

. Gateway syntax for /S, as described
String value for the RC' for Gateway-managed connections.
/G Duo Gateway name in .
Lotes When you specify the PC-Duo
q ' Gateway and protocol (using /P), the
protocol applies between the local
PC-Duo Master computer and the
PC-Duo Gateway.
In quotes, the string value
for the station name, DNS
/s name, or network The peer-to-peer syntax depends on

address specifier for
peer-to-peer Host
computer connections.

your protocol specification.
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In quotes, the string value
for the station name, DNS

Examples:

/v name, or network /PTCP /V"192.168.160.138"
address specifier for VNC /PTCP /V"Mac VNC Server"
server connections.

/PTCP Examples:

S "192.168.160.138"
/ network address /PUDP /S"192.168.160.138
or . /PTCP /S"jackson"

station name

/PUDP g ~ /PTCP

/s ns_name /S"jackson.acme.com"
@node Examples:

/PIPX @network:node /PIPX /S@1B13DAEY

/S "Station_name" /PIPX /S@20:lBl3DAE9
"het— /PIPX /S"Dell P200"
work:station name /PIPX /S"2:Dell

The Gateway syntax depends on the

managed Host specification:

Use u for a logged-in user, and w

(with curly braces) for a workstation.
In quotes, the string value NOTE: The u and w that you use
for the Host key for for the PC-Duo Gateway syntax of
remote connections / ind dent of the /U
through a PC-Duo S are independent of the

/S Gateway: and /W commands.

& “w={host key}” To find the Host key, navigate to the

- managed Hosts tab of the PC-Duo

€ “u=host key” Master console window. Select the
PC-Duo Gateway and display its list
of managed Host computers. Right-
click the desired Host computer, and
select Properties. The Host key
displays.
Examples:

Gateway Name and /67 Gat 17

ol ateway
Workstat Host
orxstation Host_ /S"w={6F93DF16-8352-46EB-
/G /S Key

ADDF-T7FD752EAT72FA}"”

or Gateway Name and

U — /G”Gatewayl™

ser Name
- /S”u=ACME\george"

Specify a GUID session ID of
recording on a Gateway to be played:

/R Gateway Name and

SessionID

/G”Gatewayl”
/R"{92E3970A-682E-4B93-
B4A4-925F96EB9E85}"
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Command line syntax examples

Table below describes a set of full command-line calls.

Examples of syntax for command lines

Command

Explanation

pcduo.exe /PUDP
/U"ACME\george" /X"foo"
/S"jackson.acme.com"

Opens both the PC-Duo Master console
window and the PC-Duo Master
Remote Desktop window, connecting
to a computer whose DNS name is
jackson.acme. com using the
UDP/IP protocol, valid username,
ACME\george, and password foo.

pcduo.exe /PIPX /X"foo"
/S"Dell P200"

Uses the IPX protocol to connect to a
computer named Dell P200 with the
configured PC-Duo Host password foo.

pcduo.exe /P"IPX|5001"
/S@20:1B31DAEY

Uses the IPX protocol to connect to a
computer on network 20 with IPX
address 1B31DAE9, using port 5001
and the local computer user credentials.
Note that to specify the port, you must
separate the protocol/port number pair
with a vertical bar | and put the entire
group in quotes.

pcduo.exe /PTCP
/S"192.168.160.138"

Uses the TCP/IP protocol to connect to a
remote Host computer with network
address 192.168.160.138, using
the local computer user credentials.

pcduo.exe /PTCP /S"jackson"

Uses the TCP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials. All
other PC-Duo Master console window
configuration parameters are specified in
the current configuration of PC-Duo
Master.

pcduo.exe /PTCP /S"jackson"
jackson.prx4

Uses the TCP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials. All
other PC-Duo Master console window
configuration parameters are specified in
the PC-Duo Master shortcut file named
Jjackson.prx4.

pcduo.exe /PTCP /W"Jackson"
/Sjackson

Uses the TCP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials. The
resulting Remote Desktop Window is
titled jackson.
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pcduo.exe /H /PUDP
/S"jackson™"

Uses the UDP/IP protocol to connect to a
remote Host computer named jackson
with local computer user credentials, and
hides the PC-Duo Master console
window for this connection.

pcduo.exe jackson-2008-04-
24 .prxrec

Opens a Playback window to play the
recording file “jackson-2008-04-
24.prxrec" from local file store

pcduo.exe
http://MyIIS:8080/jackson-
2008-04-24.prxrec

Opens a Playback window to play the
recording file “jackson-2008-04-

24 prxrec” from webserver "MylIS" over
port 8080

pcduo.exe /P"TCP|5900"
/V"Mac VNC Server"

Uses the TCP/IP protocol to connect to a
VNC server on a remote Host computer
with DNS name "Mac VNC Server".
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